libgpg-error: updated to 1.29
Noteworthy changes in version 1.29: * The yat2m tool is during cross-compile now also installed on the host platform. * New option parser and associated functions similar to the one used by GnuPG. * New Base-64 encoder. * Fixes regression in 1.28 for arm64 and w64 builds. * Interface changes relative to the 1.28 release: gpgrt_argparse New. gpgrt_usage New. gpgrt_strusage New. gpgrt_set_strusage New. gpgrt_set_usage_outfnc New. gpgrt_set_fixed_string_mapper New. GPGRT_ENABLE_ARGPARSE_MACROS New macro. gpgrt_b64enc_start New. gpgrt_b64enc_write New. gpgrt_b64enc_finish New.
This commit is contained in:
parent
65777cc1b5
commit
24c6c03acf
4 changed files with 7 additions and 60 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.61 2018/04/11 08:29:24 maya Exp $
|
||||
# $NetBSD: Makefile,v 1.62 2018/04/12 06:56:17 adam Exp $
|
||||
|
||||
DISTNAME= libgpg-error-1.28
|
||||
PKGREVISION= 2
|
||||
DISTNAME= libgpg-error-1.29
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ftp://ftp.gnupg.org/gcrypt/libgpg-error/
|
||||
MASTER_SITES+= ftp://ftp.ring.gr.jp/pub/net/gnupg/libgpg-error/
|
||||
|
|
|
@ -1,10 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.36 2018/04/11 08:29:24 maya Exp $
|
||||
$NetBSD: distinfo,v 1.37 2018/04/12 06:56:17 adam Exp $
|
||||
|
||||
SHA1 (libgpg-error-1.28.tar.bz2) = 2b9baae264f3e82ebe00dcd10bae3f2d64232c10
|
||||
RMD160 (libgpg-error-1.28.tar.bz2) = 2ed66ada89612822ba3f639dd957892646fe81cd
|
||||
SHA512 (libgpg-error-1.28.tar.bz2) = 967e5e9930ca2bcd4cc790d69c907684500120c1363ed384a5540ccd4e9a387977c7352da03ff7e0feeacedf073131fc0db9eea9d097d0fbd389fd0bc9b5c209
|
||||
Size (libgpg-error-1.28.tar.bz2) = 862569 bytes
|
||||
SHA1 (patch-doc_Makefile.in) = 39695ac1dc4601445f335979f3db0c8c2b53a095
|
||||
SHA1 (libgpg-error-1.29.tar.bz2) = a56241d60bb7d810fdb478463b1732b134a52a19
|
||||
RMD160 (libgpg-error-1.29.tar.bz2) = 57abd8eb1b0a5be3ee217213917295d040c4efe5
|
||||
SHA512 (libgpg-error-1.29.tar.bz2) = 57b95a7ed0ed808f05a75d7ee700ed0317da06fde1f8c59f5a4f049d784c4598f3c693068ddd47cd8bb0efdb43b9b628b876d34211f8a3e67d5088110a15323b
|
||||
Size (libgpg-error-1.29.tar.bz2) = 894749 bytes
|
||||
SHA1 (patch-src_estream.c) = 0502a55403062abeab22c83a6d919c57ff1c5d82
|
||||
SHA1 (patch-src_gpg-error-config.in) = e22e99208192971f8c123d7ee9b22c5f615669e1
|
||||
SHA1 (patch-src_logging.c) = ea8fa46844a40fdde57ac26c43ec8d011c4a75b5
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-doc_Makefile.in,v 1.1 2018/03/20 12:39:28 wiz Exp $
|
||||
|
||||
Honor LDFLAGS.
|
||||
|
||||
--- doc/Makefile.in.orig 2018-03-20 12:35:10.116499729 +0000
|
||||
+++ doc/Makefile.in
|
||||
@@ -885,7 +885,7 @@ uninstall-man: uninstall-man1
|
||||
|
||||
|
||||
yat2m: yat2m.c
|
||||
- $(CC_FOR_BUILD) -DPACKAGE_VERSION="\"$(PACKAGE_VERSION)\"" \
|
||||
+ $(CC_FOR_BUILD) $(LDFLAGS) -DPACKAGE_VERSION="\"$(PACKAGE_VERSION)\"" \
|
||||
-o $@ $(srcdir)/yat2m.c
|
||||
|
||||
yat2m-stamp: $(myman_sources)
|
|
@ -1,35 +0,0 @@
|
|||
$NetBSD: patch-src_logging.c,v 1.1 2018/04/11 08:29:24 maya Exp $
|
||||
|
||||
From: Werner Koch <wk@gnupg.org>
|
||||
Date: Sun, 18 Mar 2018 16:39:43 +0000 (+0100)
|
||||
Subject: core: Fix regression on arm64 due to invalid use of va_list.
|
||||
|
||||
* src/logging.c (_gpgrt_log_printhex): Provide a dummy arg instead of
|
||||
NULL.
|
||||
--
|
||||
|
||||
Fix
|
||||
Suggested-by: Jakub Wilk <jwilk@jwilk.net>
|
||||
|
||||
Signed-off-by: Werner Koch <wk@gnupg.org>
|
||||
|
||||
--- src/logging.c.orig 2017-12-08 12:22:41.000000000 +0000
|
||||
+++ src/logging.c
|
||||
@@ -1150,7 +1150,16 @@ _gpgrt_log_printhex (const void *buffer,
|
||||
va_end (arg_ptr);
|
||||
}
|
||||
else
|
||||
- _gpgrt_logv_printhex (buffer, length, NULL, NULL);
|
||||
+ {
|
||||
+ /* va_list is not necessary a pointer and thus we can't use NULL
|
||||
+ * because that would conflict with platforms using a straight
|
||||
+ * struct for it (e.g. arm64). We use a dummy variable instead;
|
||||
+ * the static is a simple way zero it out so to not get
|
||||
+ * complains about uninitialized use. */
|
||||
+ static va_list dummy_argptr;
|
||||
+
|
||||
+ _gpgrt_logv_printhex (buffer, length, NULL, dummy_argptr);
|
||||
+ }
|
||||
}
|
||||
|
||||
|
Loading…
Reference in a new issue