Update wsbasic to 1.2.5. Patches provided by Geert Hendrickx.

Changes:
- patch-ab and patch-ac were incorporated.
This commit is contained in:
minskim 2005-10-26 21:38:30 +00:00
parent 24299b5cb3
commit 253a856ed3
5 changed files with 9 additions and 58 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.1.1.1 2005/10/19 03:36:03 minskim Exp $
# $NetBSD: Makefile,v 1.2 2005/10/26 21:38:30 minskim Exp $
DISTNAME= wsbasic-1_2_4
DISTNAME= wsbasic-1_2_5
PKGNAME= ${DISTNAME:S/_/./g}
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=wsbasic/}

View file

@ -1,8 +1,6 @@
$NetBSD: distinfo,v 1.2 2005/10/26 15:58:54 minskim Exp $
$NetBSD: distinfo,v 1.3 2005/10/26 21:38:30 minskim Exp $
SHA1 (wsbasic-1_2_4.tar.gz) = 5470c247fcdf7d3940d51f824d549c40495b60a5
RMD160 (wsbasic-1_2_4.tar.gz) = 022c80019a5f6c85073d3a7386b51b41ff9285fe
Size (wsbasic-1_2_4.tar.gz) = 20850 bytes
SHA1 (patch-aa) = 0758724f05585c357a530b8979e56f6e15584493
SHA1 (patch-ab) = 210b1f0dd17a2dfce691a79cbb375d920add9350
SHA1 (patch-ac) = 62d1dabae7a7b566a4bea236814e28d86ef5227a
SHA1 (wsbasic-1_2_5.tar.gz) = 7cac105c3d11ee00e008b7d1756f8ddf9a70929e
RMD160 (wsbasic-1_2_5.tar.gz) = 70b8aeb73a2a2ba9f05b9067645c6feb895ee382
Size (wsbasic-1_2_5.tar.gz) = 20745 bytes
SHA1 (patch-aa) = 5217f62abd2efd27faaf9dad9371932a28218230

View file

@ -1,4 +1,4 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/10/19 03:36:03 minskim Exp $
$NetBSD: patch-aa,v 1.2 2005/10/26 21:38:30 minskim Exp $
--- Makefile.orig 2005-01-28 02:40:58.000000000 +0100
+++ Makefile
@ -8,5 +8,5 @@ $NetBSD: patch-aa,v 1.1.1.1 2005/10/19 03:36:03 minskim Exp $
FLAGS = -O2 -Wall #-D_DEBUG_
+FLAGS += $(CXXFLAGS)
INSTALL_DIR = /usr/local/bin/
RELEASE = 1_2_4
RELEASE = 1_2_5

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.1 2005/10/26 15:58:54 minskim Exp $
--- number.h.orig 2004-06-09 02:20:18.000000000 +0200
+++ number.h
@@ -26,7 +26,7 @@ class Number{
//==============
void toString(); //explicit conversion to string strVal
void toDouble(); //explicit conversion to double val
- void setValue( double d ){ val=d; strVal.clear(); bString=false;}
+ void setValue( double d ){ val=d; bString=false;}
void setValue( const string& s ){ strVal=s; bString=true;}
void minus(){ val=-val; }

View file

@ -1,34 +0,0 @@
$NetBSD: patch-ac,v 1.1 2005/10/26 15:58:54 minskim Exp $
--- executer.cpp.orig 2005-01-27 01:27:53.000000000 +0100
+++ executer.cpp
@@ -641,7 +641,8 @@ void Executer::execLeft( TreeNode* node
GET_BINARY_OPERANDS
string val = a->strVal;
int to = (int) b->val;
- delete a,b;
+ delete a;
+ delete b;
runStack.pop();
if( ( to >= 0 ) && ( to < (int)val.size() ) ){
@@ -658,7 +659,8 @@ void Executer::execRight( TreeNode* node
GET_BINARY_OPERANDS
string val = a->strVal;
int to = (int) b->val;
- delete a,b;
+ delete a;
+ delete b;
runStack.pop();
if( ( to >= 0 ) && ( to < (int)val.size() ) ){
@@ -681,7 +683,8 @@ void Executer::execMid( TreeNode* node )
GET_BINARY_OPERANDS
string val = a->strVal;
int from = (int) b->val-1;
- delete a,b;
+ delete a;
+ delete b;
runStack.pop();
int to=0;