Update to 1.8.5:
Changes Doxygen's source code is now managed using git and GitHub. Automatic builds and regression tests are scheduled via Travis CI. Configuration data for the config file, the documentation, and the wizard are now produced from a single source (thanks to Albert) All translation files have been migrated to UTF-8 (thanks to Petr Prikryl) Added black box testing framework and a set of tests. New features Added SOURCE_TOOLTIPS option for advanced tooltip support while source browsing. Lots of bug fixes.
This commit is contained in:
parent
294ce6bb4c
commit
253c193f2c
5 changed files with 17 additions and 32 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.102 2013/06/04 22:15:51 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.103 2013/09/02 16:38:56 wiz Exp $
|
||||
|
||||
DISTNAME= doxygen-1.8.4.src
|
||||
DISTNAME= doxygen-1.8.5.src
|
||||
PKGNAME= ${DISTNAME:S/.src//}
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://ftp.stack.nl/pub/users/dimitri/ \
|
||||
http://ftp.stack.nl/pub/users/dimitri/
|
||||
|
|
|
@ -1,12 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.50 2013/08/20 17:41:15 bsiegert Exp $
|
||||
$NetBSD: distinfo,v 1.51 2013/09/02 16:38:56 wiz Exp $
|
||||
|
||||
SHA1 (doxygen-1.8.4.src.tar.gz) = a363811b932e44d479addbadffcc8257cde60b44
|
||||
RMD160 (doxygen-1.8.4.src.tar.gz) = 7087480667cb138c739fae54ca21f77e2099f4eb
|
||||
Size (doxygen-1.8.4.src.tar.gz) = 6456090 bytes
|
||||
SHA1 (doxygen-1.8.5.src.tar.gz) = 1fc5ceec21122fe5037edee4c308ac94b59ee33e
|
||||
RMD160 (doxygen-1.8.5.src.tar.gz) = b826c120543a424a938759fc9efa71b855318008
|
||||
Size (doxygen-1.8.5.src.tar.gz) = 6511944 bytes
|
||||
SHA1 (patch-aa) = 74aa6e068c150d2e40c5a73723afd24d510f4538
|
||||
SHA1 (patch-ab) = 1bd196c38786bb6b0b1817bb9575924ca234aee3
|
||||
SHA1 (patch-ac) = 87c68a2ce598c10d90d775764f4c05739eb51435
|
||||
SHA1 (patch-af) = 0942cc0fdcb49e74ce018d7e790dba36b21b4d08
|
||||
SHA1 (patch-af) = 233fe278d6d47a0af799178cc35ed2fe2e833fd5
|
||||
SHA1 (patch-ah) = db6f117bf1faa3a1ed0b2ca9af81fc4f8d0913f9
|
||||
SHA1 (patch-aj) = 1f4822364eb9aeb82084d30b0bc75af504da63f1
|
||||
SHA1 (patch-tmake_lib_macosx-c++_tmake.conf) = f6f7414bf8e1c26264211c72991d8dc4222cc738
|
||||
SHA1 (patch-aj) = d771e76cfc659442b2d41d5e3364b3c3189b42c8
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-af,v 1.4 2009/09/27 01:30:38 minskim Exp $
|
||||
$NetBSD: patch-af,v 1.5 2013/09/02 16:38:56 wiz Exp $
|
||||
|
||||
--- doc/Makefile.in.orig 2008-12-06 13:16:23.000000000 +0000
|
||||
--- doc/Makefile.in.orig 2013-07-27 21:46:15.000000000 +0000
|
||||
+++ doc/Makefile.in
|
||||
@@ -23,7 +23,7 @@ all: language FORCE
|
||||
@@ -23,7 +23,7 @@ all: language config.doc FORCE
|
||||
@cp Makefile.latex ../latex/Makefile
|
||||
@sed -e "s/\$$VERSION/$(VERSION)/g" doxygen_manual.tex >../latex/doxygen_manual.tex
|
||||
@sed -e "s/\$$VERSION/$(VERSION)/g" doxygen.sty >../latex/doxygen.sty
|
||||
|
@ -11,11 +11,12 @@ $NetBSD: patch-af,v 1.4 2009/09/27 01:30:38 minskim Exp $
|
|||
|
||||
clean:
|
||||
rm -rf ../html ../latex *.bak
|
||||
@@ -31,6 +31,6 @@ clean:
|
||||
@@ -31,7 +31,7 @@ clean:
|
||||
language: language.doc
|
||||
|
||||
language.doc: $(wildcard ../src/translator*.h) maintainers.txt language.tpl translator.py
|
||||
- python translator.py
|
||||
+ @PYTHONBIN@ translator.py
|
||||
|
||||
FORCE:
|
||||
config.doc: ../src/config.xml ../src/configgen.py
|
||||
python ../src/configgen.py -doc ../src/config.xml > config.doc
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aj,v 1.3 2013/05/21 14:43:05 wiz Exp $
|
||||
$NetBSD: patch-aj,v 1.4 2013/09/02 16:38:56 wiz Exp $
|
||||
|
||||
make build honor LDFLAGS
|
||||
|
||||
--- src/doxygen.pro.in.orig 2013-03-24 14:12:01.000000000 +0000
|
||||
--- src/doxygen.pro.in.orig 2013-07-28 13:28:16.000000000 +0000
|
||||
+++ src/doxygen.pro.in
|
||||
@@ -19,6 +19,7 @@ CONFIG = console warn_on $extraopt
|
||||
HEADERS = doxygen.h
|
||||
|
@ -10,5 +10,5 @@ make build honor LDFLAGS
|
|||
unix:LIBS += -L../lib -ldoxygen -ldoxycfg -lqtools -lmd5 -lpthread %%SQLITE3_LIBS%% %%LIBCLANG_LIBS%%
|
||||
+unix:TMAKE_LFLAGS += $(LDFLAGS)
|
||||
win32:INCLUDEPATH += .
|
||||
win32-mingw:LIBS += -L../lib -ldoxygen -ldoxycfg -lqtools -lmd5 -lpthread %%SQLITE3_LIBS%% %%LIBCLANG_LIBS%%
|
||||
win32-mingw:LIBS += -L../lib -ldoxygen -ldoxycfg -lqtools -lmd5 -lpthread -llibiconv -lole32 %%SQLITE3_LIBS%% %%LIBCLANG_LIBS%%
|
||||
win32-msvc:LIBS += qtools.lib md5.lib doxygen.lib doxycfg.lib shell32.lib iconv.lib
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-tmake_lib_macosx-c++_tmake.conf,v 1.1 2013/08/20 17:41:15 bsiegert Exp $
|
||||
|
||||
Drop an option that is unsupported by the default compiler in Mac OS 10.8.
|
||||
--- tmake/lib/macosx-c++/tmake.conf.orig 2013-08-20 17:30:43.000000000 +0000
|
||||
+++ tmake/lib/macosx-c++/tmake.conf
|
||||
@@ -9,7 +9,7 @@ CONFIG = qt warn_on release
|
||||
|
||||
TMAKE_CC = cc
|
||||
TMAKE_CFLAGS = -pipe
|
||||
-TMAKE_CFLAGS_WARN_ON = -Wall -W -Wno-deprecated-declarations -Wno-invalid-source-encoding
|
||||
+TMAKE_CFLAGS_WARN_ON = -Wall -W -Wno-deprecated-declarations
|
||||
TMAKE_CFLAGS_WARN_OFF =
|
||||
TMAKE_CFLAGS_RELEASE = -O2
|
||||
TMAKE_CFLAGS_DEBUG = -g -fstack-protector
|
Loading…
Reference in a new issue