Patch from SVN to fix building with recent SIP.

Bump PKGREVISION.
This commit is contained in:
markd 2010-07-18 13:08:58 +00:00
parent 5c0b8ca2cb
commit 2546aa6604
3 changed files with 24 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.15 2010/07/14 11:11:40 sbd Exp $
# $NetBSD: Makefile,v 1.16 2010/07/18 13:08:58 markd Exp $
PKGNAME= kdebindings4-python-${_KDE_VERSION}
DISTNAME= kdebindings-${_KDE_VERSION}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= misc
COMMENT= Python bindings for the KDE integrated X11 desktop
@ -31,6 +31,9 @@ REPLACE_PYTHON+= \
post-extract:
${CP} ${FILESDIR}/FindPolkitQt.cmake ${WRKSRC}/cmake/modules
post-patch:
rm ${WRKSRC}/python/pykde4/sip/akonadi/addressattribute.sip.orig
.include "../../meta-pkgs/kde4/kde4.mk"
.include "../../lang/python/application.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.11 2010/07/04 11:02:35 markd Exp $
$NetBSD: distinfo,v 1.12 2010/07/18 13:08:58 markd Exp $
SHA1 (kdebindings-4.4.5.tar.bz2) = 2f041c5b050da879e8f5d09f668b56881f9f1bb2
RMD160 (kdebindings-4.4.5.tar.bz2) = 057cafc1922a5ab3999e6dcc532d656dd4cf446c
@ -6,3 +6,4 @@ Size (kdebindings-4.4.5.tar.bz2) = 5092007 bytes
SHA1 (patch-aa) = f01b1d350a8e79e639f46c797baf035684275158
SHA1 (patch-ab) = cae51d216ad914009b4e9c80a17a172ec5a5eaec
SHA1 (patch-ac) = 698eaecc5cb2489b16409bc14c4beee5ca93a296
SHA1 (patch-ad) = 1f0170c454dd5eecf7433b937667ad200e1bd3a8

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ad,v 1.1 2010/07/18 13:08:58 markd Exp $
svn 1150377
--- python/pykde4/sip/akonadi/addressattribute.sip 2010/07/15 20:17:59 1150376
+++ python/pykde4/sip/akonadi/addressattribute.sip 2010/07/15 20:19:01 1150377
@@ -57,6 +57,10 @@
else if (dynamic_cast<Akonadi::MessageThreadingAttribute*>(sipCpp))
sipType = sipType_Akonadi_MessageThreadingAttribute;
%End
+private:
+//force
+Akonadi::AddressAttribute& operator = (const Akonadi::AddressAttribute&);
+//end
};
};
%ModuleHeaderCode