Update to 4.1.0, provided by Peter Bex via pkgsrc-wip (wip/chicken-current).
4.1.0 - The new parameter "parantheses-synonyms" and the command-line option "-no-parantheses-synonyms" allows disabling list-like behaviour of "{ ... }" and "[ ... ]" tokens - The new parameter "symbol-escape" and the command-line option "-no-symbol-escape" allows disabling "| ... |" symbol escape syntax - Added command-line option "-r5rs-syntax" to disable CHICKEN-specific read-syntax - Added compiler command-line-option "-no-compiler-syntax" - Deprecated "getenv" (use "get-environment-variable" instead) - Removed "macro?" and "undefine-macro!" - Support for Microsoft Visual Studio / MSVC has been dropped - The compiler provides now a simple flow-analysis pass that does basic checking of argument-count and -types for core library procedures (new option "-scrutinize") - New compiler-options "-no-argc-checks", "-no-bound-checks", "-no-procedure checks", "-no-procedure-checks-for-usual-bindings", "-types TYPEFILE" and "-consult-inline-file FILENAME" - Added a "chicken-setup" stub-application to catch incorrect use of this tool (which has been replaced in 4.0.0 with "chicken-install") - Changed "setup-install-flag" and "setup-verbose-flag" to "setup-install-mode" and "setup-verbose-mode" in "setup-api" module, the old names are still available but deprecated - Posix unit: added "socket?", "block-device?" and "character-device?", deprecated redundant "stat-..." procedures - Also in Posix unit: "canonical-path" has been deprecated, "normalize-pathname" from the "files" unit provides now most of the functionality - Added "directory-exists?" - "(for-each (lambda ...) X)" is compiled as a loop - The argument-count check for format-strings for "[sf]printf" with a constant string argument is done at compile-time - A stub application named "chicken-setup" is installed to catch when a user invokes theobsolete tool instead of the new "chicken-install". 4.0.0 - removed `apropos' and `apropos-list' from the "utils" library unit; available as an extension - removed texinfo and PDF documentation - this will possible be added back later - replaced PCRE regex engine with Alex Shinn's "irregex" regular expression package - removed `-extension' option - removed `-static-extensions' csc option and added `-static-extension NAME' - `regex' unit: removed `regexp*' and `regex-optimize' - added `CHICKEN_new_finalizable_gc_root()' - `length' checks its argument for being cyclic - removed custom declarations and "link-options" and "c-options" declarations - deprecated "-quiet" option to "chicken" program - added "-update-db" option to chicken-install - the compiler now suggests possibly required module-imports - moved non-standard syntax-definitions into "chicken-syntax" library unit - the pretty-printer prints the end-of-file object readably now - alternative conditional execution paths have separate allocation computation (previously the allocation of all alternatives was coalesced) - removed unused "%kmp-search" from "srfi-13" library unit - expander handles syntax-reexports and makes unexported syntax available for exported expanders in import libraries - added checks in some procedures in the "tcp" library unit - the macro system has been completely overhauled and converted to hygienic macros - a macro-aware module system has been added - added "-sx" option to csi - removed the following deprecated functions: [un]shift! andmap ormap byte-vector? byte-vector-fill! make-byte-vector byte-vector byte-vector-set! byte-vector-ref byte-vector->list list->byte-vector string->byte-vector byte-vector->string byte-vector-length make-static-byte-vector static-byte-vector->pointer byte-vector-move! byte-vector-append! set-file-position! set-user-id! set-group-id! set-process-group-id! macro? undefine-macro! - the situation-identifiers "run-time" and "compile-time" have been removed - the compiler options "-check-imports", "-import" and "-emit-exports" have been removed - new procedures: strip-syntax expand - new macros define-syntax module export - the following macros have been removed: define-foreign-record define-foreign-enum define-macro define-extension - "local" mode, in which locally defined exported toplevel variables can be inlined - new options and declarations "[-]local", "[-]inline-global" and "-emit-inline-file" - optimization levels changed to use inlining: -optimize-level 3: enables -inline -local (but *not* -unsafe) -optimize-level 4: enables -inline -local -unsafe - increased default inlining-limit to 20 - support for cross-module inlining - "make <VARIABLES> bench" runs the benchmark suite - "chicken-setup" has been replaced by new command line tools "chicken-install", "chicken-uninstall" and "chicken-status", which are more flexible and allow greater freedom when creating local or application- specific repositories - extension-installation can be done directly from SVN repositories or a local file tree - enabled chicken mirror site as alternative download location
This commit is contained in:
parent
d65bc236c3
commit
25767a65ae
4 changed files with 106 additions and 87 deletions
|
@ -1,30 +1,35 @@
|
|||
# $NetBSD: Makefile,v 1.37 2008/10/07 15:28:44 ahoka Exp $
|
||||
# $NetBSD: Makefile,v 1.38 2009/08/08 15:12:24 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= chicken-3.4.0
|
||||
DISTNAME= chicken-4.1.0
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://chicken.wiki.br/releases/${PKGVERSION_NOREV}/
|
||||
MASTER_SITES= http://chicken.wiki.br/releases/${PKGVERSION_NOREV}/ \
|
||||
http://galinha.ucpel.tche.br/releases/${PKGVERSION_NOREV}/ \
|
||||
${HOMEPAGE}
|
||||
|
||||
MAINTAINER= asau@inbox.ru #, airhead@users.sourceforge.net
|
||||
HOMEPAGE= http://www.call-with-current-continuation.org/
|
||||
COMMENT= Scheme to C compiler, handling R5RS
|
||||
LICENSE= modified-bsd
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
MAKE_JOBS_SAFE= no
|
||||
|
||||
INFO_FILES= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake makeinfo
|
||||
UNLIMIT_RESOURCES= datasize
|
||||
|
||||
INSTALLATION_DIRS= share/chicken
|
||||
OWN_DIRS= ${PREFIX}/lib/chicken ${PREFIX}/lib/chicken/3
|
||||
OWN_DIRS= ${PREFIX}/lib/chicken ${PREFIX}/lib/chicken/4
|
||||
|
||||
BUILD_TARGET= all chicken.info
|
||||
BUILD_TARGET= all
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
# PLATFORM detection:
|
||||
.if !empty(OPSYS:M*BSD) || ${OPSYS} == "DragonFly"
|
||||
.if !empty(OPSYS:M*BSD) || ${OPSYS} == "DragonFly"
|
||||
PLATFORM= bsd
|
||||
.elif ${OPSYS} == "Linux"
|
||||
PLATFORM= linux
|
||||
|
@ -45,14 +50,9 @@ MAKE_FLAGS+= PLATFORM=${PLATFORM:Q} PREFIX=${PREFIX:Q} DESTDIR=${DESTDIR:Q}
|
|||
MAKE_FLAGS+= TOPMANDIR=${PREFIX:Q}/${PKGMANDIR}
|
||||
MAKE_FLAGS+= INFODIR=${PREFIX:Q}/${PKGINFODIR:Q}
|
||||
MAKE_FLAGS+= DOCDIR=${PREFIX:Q}/share/doc/${PKGNAME_NOREV}
|
||||
MAKE_FLAGS+= USE_HOST_PCRE=yes
|
||||
|
||||
SUBST_CLASSES+= add-rpath
|
||||
SUBST_STAGE.add-rpath= pre-configure
|
||||
SUBST_FILES.add-rpath= defaults.make
|
||||
SUBST_SED.add-rpath= -e 's|-lpcre|${COMPILER_RPATH_FLAG}${PREFIX}/lib -L${PREFIX}/lib -lpcre|'
|
||||
|
||||
TEST_TARGET= check
|
||||
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
CHECK_PORTABILITY_SKIP += scripts/test-dist.sh
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,90 +1,95 @@
|
|||
@comment $NetBSD: PLIST,v 1.23 2009/06/14 20:34:13 joerg Exp $
|
||||
@comment $NetBSD: PLIST,v 1.24 2009/08/08 15:12:24 wiz Exp $
|
||||
bin/chicken
|
||||
bin/chicken-bug
|
||||
bin/chicken-install
|
||||
bin/chicken-profile
|
||||
bin/chicken-setup
|
||||
bin/chicken-status
|
||||
bin/chicken-uninstall
|
||||
bin/csc
|
||||
bin/csi
|
||||
include/chicken-config.h
|
||||
include/chicken.h
|
||||
info/chicken.info
|
||||
lib/chicken/4/chicken.import.so
|
||||
lib/chicken/4/csi.import.so
|
||||
lib/chicken/4/data-structures.import.so
|
||||
lib/chicken/4/extras.import.so
|
||||
lib/chicken/4/files.import.so
|
||||
lib/chicken/4/foreign.import.so
|
||||
lib/chicken/4/irregex.import.so
|
||||
lib/chicken/4/lolevel.import.so
|
||||
lib/chicken/4/ports.import.so
|
||||
lib/chicken/4/posix.import.so
|
||||
lib/chicken/4/regex.import.so
|
||||
lib/chicken/4/scheme.import.so
|
||||
lib/chicken/4/setup-api.import.so
|
||||
lib/chicken/4/setup-api.so
|
||||
lib/chicken/4/setup-download.import.so
|
||||
lib/chicken/4/setup-download.so
|
||||
lib/chicken/4/srfi-1.import.so
|
||||
lib/chicken/4/srfi-13.import.so
|
||||
lib/chicken/4/srfi-14.import.so
|
||||
lib/chicken/4/srfi-18.import.so
|
||||
lib/chicken/4/srfi-4.import.so
|
||||
lib/chicken/4/srfi-69.import.so
|
||||
lib/chicken/4/tcp.import.so
|
||||
lib/chicken/4/utils.import.so
|
||||
lib/libchicken.a
|
||||
lib/libchicken.so
|
||||
lib/libuchicken.a
|
||||
lib/libuchicken.so
|
||||
man/man1/chicken-bug.1
|
||||
man/man1/chicken-install.1
|
||||
man/man1/chicken-profile.1
|
||||
man/man1/chicken-setup.1
|
||||
man/man1/chicken-status.1
|
||||
man/man1/chicken-uninstall.1
|
||||
man/man1/chicken.1
|
||||
man/man1/csc.1
|
||||
man/man1/csi.1
|
||||
share/chicken/chicken-ffi-macros.scm
|
||||
share/chicken/chicken-more-macros.scm
|
||||
share/chicken/chicken-sys-macros.scm
|
||||
share/chicken/data-structures.exports
|
||||
share/chicken/eval.exports
|
||||
share/chicken/extras.exports
|
||||
share/chicken/files.exports
|
||||
share/chicken/library.exports
|
||||
share/chicken/lolevel.exports
|
||||
share/chicken/ports.exports
|
||||
share/chicken/posix.exports
|
||||
share/chicken/regex.exports
|
||||
share/chicken/scheduler.exports
|
||||
share/chicken/srfi-1.exports
|
||||
share/chicken/srfi-13.exports
|
||||
share/chicken/srfi-14.exports
|
||||
share/chicken/srfi-18.exports
|
||||
share/chicken/srfi-4.exports
|
||||
share/chicken/srfi-69.exports
|
||||
share/chicken/tcp.exports
|
||||
share/chicken/utils.exports
|
||||
share/chicken/setup.defaults
|
||||
share/doc/${PKGNAME}/LICENSE
|
||||
share/doc/${PKGNAME}/README
|
||||
share/doc/${PKGNAME}/chicken.pdf
|
||||
share/doc/${PKGNAME}/html/accessing-external-objects.html
|
||||
share/doc/${PKGNAME}/html/acknowledgements.html
|
||||
share/doc/${PKGNAME}/html/basic-mode-of-operation.html
|
||||
share/doc/${PKGNAME}/html/bibliography.html
|
||||
share/doc/${PKGNAME}/html/bugs-and-limitations.html
|
||||
share/doc/${PKGNAME}/html/c-interface.html
|
||||
share/doc/${PKGNAME}/html/callbacks.html
|
||||
share/doc/${PKGNAME}/html/chicken-setup.html
|
||||
share/doc/${PKGNAME}/html/data-representation.html
|
||||
share/doc/${PKGNAME}/html/declarations.html
|
||||
share/doc/${PKGNAME}/html/deviations-from-the-standard.html
|
||||
share/doc/${PKGNAME}/html/embedding.html
|
||||
share/doc/${PKGNAME}/html/extensions-to-the-standard.html
|
||||
share/doc/${PKGNAME}/html/Accessing external objects.html
|
||||
share/doc/${PKGNAME}/html/Acknowledgements.html
|
||||
share/doc/${PKGNAME}/html/Basic mode of operation.html
|
||||
share/doc/${PKGNAME}/html/Bibliography.html
|
||||
share/doc/${PKGNAME}/html/Bugs and limitations.html
|
||||
share/doc/${PKGNAME}/html/C interface.html
|
||||
share/doc/${PKGNAME}/html/Callbacks.html
|
||||
share/doc/${PKGNAME}/html/Data representation.html
|
||||
share/doc/${PKGNAME}/html/Declarations.html
|
||||
share/doc/${PKGNAME}/html/Deviations from the standard.html
|
||||
share/doc/${PKGNAME}/html/Embedding.html
|
||||
share/doc/${PKGNAME}/html/Extensions to the standard.html
|
||||
share/doc/${PKGNAME}/html/Extensions.html
|
||||
share/doc/${PKGNAME}/html/Foreign type specifiers.html
|
||||
share/doc/${PKGNAME}/html/Interface to external functions and variables.html
|
||||
share/doc/${PKGNAME}/html/Locations.html
|
||||
share/doc/${PKGNAME}/html/Modules and macros.html
|
||||
share/doc/${PKGNAME}/html/Non-standard macros and special forms.html
|
||||
share/doc/${PKGNAME}/html/Non-standard read syntax.html
|
||||
share/doc/${PKGNAME}/html/Other support procedures.html
|
||||
share/doc/${PKGNAME}/html/Parameters.html
|
||||
share/doc/${PKGNAME}/html/Supported language.html
|
||||
share/doc/${PKGNAME}/html/The User's Manual.html
|
||||
share/doc/${PKGNAME}/html/Unit data-structures.html
|
||||
share/doc/${PKGNAME}/html/Unit eval.html
|
||||
share/doc/${PKGNAME}/html/Unit expand.html
|
||||
share/doc/${PKGNAME}/html/Unit extras.html
|
||||
share/doc/${PKGNAME}/html/Unit files.html
|
||||
share/doc/${PKGNAME}/html/Unit library.html
|
||||
share/doc/${PKGNAME}/html/Unit lolevel.html
|
||||
share/doc/${PKGNAME}/html/Unit ports.html
|
||||
share/doc/${PKGNAME}/html/Unit posix.html
|
||||
share/doc/${PKGNAME}/html/Unit regex.html
|
||||
share/doc/${PKGNAME}/html/Unit srfi-1.html
|
||||
share/doc/${PKGNAME}/html/Unit srfi-13.html
|
||||
share/doc/${PKGNAME}/html/Unit srfi-14.html
|
||||
share/doc/${PKGNAME}/html/Unit srfi-18.html
|
||||
share/doc/${PKGNAME}/html/Unit srfi-4.html
|
||||
share/doc/${PKGNAME}/html/Unit tcp.html
|
||||
share/doc/${PKGNAME}/html/Unit utils.html
|
||||
share/doc/${PKGNAME}/html/Using the compiler.html
|
||||
share/doc/${PKGNAME}/html/Using the interpreter.html
|
||||
share/doc/${PKGNAME}/html/faq.html
|
||||
share/doc/${PKGNAME}/html/foreign-type-specifiers.html
|
||||
share/doc/${PKGNAME}/html/getting-started.html
|
||||
share/doc/${PKGNAME}/html/index.html
|
||||
share/doc/${PKGNAME}/html/interface-to-external-functions-and-variables.html
|
||||
share/doc/${PKGNAME}/html/locations.html
|
||||
share/doc/${PKGNAME}/html/non-standard-macros-and-special-forms.html
|
||||
share/doc/${PKGNAME}/html/non-standard-read-syntax.html
|
||||
share/doc/${PKGNAME}/html/other-support-procedures.html
|
||||
share/doc/${PKGNAME}/html/parameters.html
|
||||
share/doc/${PKGNAME}/html/pattern-matching.html
|
||||
share/doc/${PKGNAME}/html/supported-language.html
|
||||
share/doc/${PKGNAME}/html/unit-data-structures.html
|
||||
share/doc/${PKGNAME}/html/unit-eval.html
|
||||
share/doc/${PKGNAME}/html/unit-extras.html
|
||||
share/doc/${PKGNAME}/html/unit-files.html
|
||||
share/doc/${PKGNAME}/html/unit-library.html
|
||||
share/doc/${PKGNAME}/html/unit-lolevel.html
|
||||
share/doc/${PKGNAME}/html/unit-match.html
|
||||
share/doc/${PKGNAME}/html/unit-ports.html
|
||||
share/doc/${PKGNAME}/html/unit-posix.html
|
||||
share/doc/${PKGNAME}/html/unit-regex.html
|
||||
share/doc/${PKGNAME}/html/unit-srfi-1.html
|
||||
share/doc/${PKGNAME}/html/unit-srfi-13.html
|
||||
share/doc/${PKGNAME}/html/unit-srfi-14.html
|
||||
share/doc/${PKGNAME}/html/unit-srfi-18.html
|
||||
share/doc/${PKGNAME}/html/unit-srfi-4.html
|
||||
share/doc/${PKGNAME}/html/unit-srfi-69.html
|
||||
share/doc/${PKGNAME}/html/unit-tcp.html
|
||||
share/doc/${PKGNAME}/html/unit-utils.html
|
||||
share/doc/${PKGNAME}/html/using-the-compiler.html
|
||||
share/doc/${PKGNAME}/html/using-the-interpreter.html
|
||||
@pkgdir lib/chicken/3
|
||||
share/doc/${PKGNAME}/html/manual.css
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.25 2008/10/07 15:28:44 ahoka Exp $
|
||||
$NetBSD: distinfo,v 1.26 2009/08/08 15:12:24 wiz Exp $
|
||||
|
||||
SHA1 (chicken-3.4.0.tar.gz) = 6a73186eb01e2aa952056cf2ccb8fa136f9fab4e
|
||||
RMD160 (chicken-3.4.0.tar.gz) = e28808de5408753df1e0b050dcac19f540567f13
|
||||
Size (chicken-3.4.0.tar.gz) = 4242443 bytes
|
||||
SHA1 (chicken-4.1.0.tar.gz) = 683b36f84e59b89c0bf877927571e9e0a677d182
|
||||
RMD160 (chicken-4.1.0.tar.gz) = e660777fc71aa7d5f73d07c19f9c2857f2ee5b1b
|
||||
Size (chicken-4.1.0.tar.gz) = 3392068 bytes
|
||||
SHA1 (patch-aa) = 56beae9ad61357f7e37ce228d320ca8c20b9b1e5
|
||||
|
|
13
lang/chicken/patches/patch-aa
Normal file
13
lang/chicken/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.14 2009/08/08 15:12:25 wiz Exp $
|
||||
|
||||
--- rules.make.orig 2009-08-01 00:16:25.000000000 +0200
|
||||
+++ rules.make
|
||||
@@ -837,7 +837,7 @@ install:
|
||||
$(REMOVE_COMMAND) $(REMOVE_COMMAND_OPTIONS) $(CHICKEN_PROGRAM)$(EXE) \
|
||||
$(CSI_PROGRAM)$(EXE) $(CSC_PROGRAM)$(EXE) $(CHICKEN_PROFILE_PROGRAM)$(EXE) \
|
||||
$(CHICKEN_INSTALL_PROGRAM)$(EXE) $(CHICKEN_UNINSTALL_PROGRAM)$(EXE) \
|
||||
- $(CHICKEN_STATUS_PROGRAM)$(EXE) \
|
||||
+ $(CHICKEN_STATUS_PROGRAM)$(EXE) $(CHICKEN_SETUP_PROGRAM)$(EXE) \
|
||||
$(IMPORT_LIBRARIES:%=%.so) $(IMPORT_LIBRARIES:%=%.import.so)
|
||||
$(MAKE) -f $(SRCDIR)Makefile.$(PLATFORM) NEEDS_RELINKING=no RUNTIME_LINKER_PATH=$(LIBDIR) install
|
||||
$(MAKE_WRITABLE_COMMAND) $(CHICKEN_PROGRAM)$(EXE) $(CSI_PROGRAM)$(EXE) \
|
Loading…
Reference in a new issue