aarch64 needs TLC with mfbt

This commit is contained in:
richard 2016-08-30 07:45:51 +00:00
parent 2ca7d60e23
commit 257ef3e0ea
2 changed files with 15 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.1 2016/05/20 18:45:22 youri Exp $ $NetBSD: distinfo,v 1.2 2016/08/30 07:45:51 richard Exp $
SHA1 (mozjs17.0.0.tar.gz) = 7805174898c34e5d3c3b256117af9944ba825c89 SHA1 (mozjs17.0.0.tar.gz) = 7805174898c34e5d3c3b256117af9944ba825c89
RMD160 (mozjs17.0.0.tar.gz) = 2fa3a891da2a7a09019f67c1555c03bcdc51e6c5 RMD160 (mozjs17.0.0.tar.gz) = 2fa3a891da2a7a09019f67c1555c03bcdc51e6c5
@ -15,4 +15,5 @@ SHA1 (patch-js_src_jsgc.cpp) = 0e617094a4b7d87cdf801d9bc4ac1f52d909a12a
SHA1 (patch-js_src_jsinterp.cpp) = bee8bdde7dd951dbfbe5b049eb502f7412fbf8e6 SHA1 (patch-js_src_jsinterp.cpp) = bee8bdde7dd951dbfbe5b049eb502f7412fbf8e6
SHA1 (patch-js_src_jsmath.cpp) = 04b0081e5abc1de3df5bdfc78db3971fe77da3d4 SHA1 (patch-js_src_jsmath.cpp) = 04b0081e5abc1de3df5bdfc78db3971fe77da3d4
SHA1 (patch-js_src_methodjit_MethodJIT.cpp) = f2b12fa554ec319b5848b1cc13ec17ef967b08d7 SHA1 (patch-js_src_methodjit_MethodJIT.cpp) = f2b12fa554ec319b5848b1cc13ec17ef967b08d7
SHA1 (patch-mfbt_double-conversion_utils.h) = d4f2a7c1eb7aa72a147c7f1f4147dfb5fe38ac92
SHA1 (patch-ml) = fdb4452a613f7ca185cd6b936538bec9ef97c4c1 SHA1 (patch-ml) = fdb4452a613f7ca185cd6b936538bec9ef97c4c1

View file

@ -0,0 +1,13 @@
$NetBSD: patch-mfbt_double-conversion_utils.h,v 1.1 2016/08/30 07:45:51 richard Exp $
deal with aarch64
--- mfbt/double-conversion/utils.h.orig 2013-02-11 22:33:28.000000000 +0000
+++ mfbt/double-conversion/utils.h
@@ -58,7 +58,7 @@
defined(__mips__) || defined(__powerpc__) || \
defined(__sparc__) || defined(__sparc) || defined(__s390__) || \
defined(__SH4__) || defined(__alpha__) || \
- defined(_MIPS_ARCH_MIPS32R2)
+ defined(_MIPS_ARCH_MIPS32R2) || defined(__aarch64__)
#define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
#elif defined(_M_IX86) || defined(__i386__) || defined(__i386)
#if defined(_WIN32)