py-ligotimegps: convert to wheel.mk

Fix build with Python 3.12.

Bump PKGREVISION.
This commit is contained in:
wiz 2023-11-05 20:25:22 +00:00
parent e71870a8c8
commit 259d8110c3
4 changed files with 31 additions and 11 deletions

View File

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.6 2023/06/06 12:42:38 riastradh Exp $
# $NetBSD: Makefile,v 1.7 2023/11/05 20:25:22 wiz Exp $
DISTNAME= ligotimegps-2.0.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= time python
MASTER_SITES= ${MASTER_SITE_PYPI:=l/ligotimegps/}
@ -11,12 +11,12 @@ HOMEPAGE= https://github.com/gwpy/ligotimegps
COMMENT= Pure-python version of lal.LIGOTimeGPS
LICENSE= gnu-lgpl-v3
TOOL_DEPENDS+= ${PYPKGPREFIX}-test-runner-[0-9]*:../../devel/py-test-runner
TEST_DEPENDS+= ${PYPKGPREFIX}-test>=2.8:../../devel/py-test
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
USE_LANGUAGES= # none
PYTHON_VERSIONS_INCOMPATIBLE= 27
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,8 +1,9 @@
@comment $NetBSD: PLIST,v 1.2 2018/12/05 15:57:48 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
@comment $NetBSD: PLIST,v 1.3 2023/11/05 20:25:22 wiz Exp $
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/ligotimegps/__init__.py
${PYSITELIB}/ligotimegps/__init__.pyc
${PYSITELIB}/ligotimegps/__init__.pyo

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.5 2021/10/26 11:24:34 nia Exp $
$NetBSD: distinfo,v 1.6 2023/11/05 20:25:22 wiz Exp $
BLAKE2s (ligotimegps-2.0.1.tar.gz) = b629a3253132d170c72d0f7ef599edbccd9a9daae5a162554d3af0da56cc1389
SHA512 (ligotimegps-2.0.1.tar.gz) = 075dfe98d588305aa3fbad47895d54f26d72fc756d175b607fff51913a40b1219f50602c86da35bb47b335b9275775b903bdcfbd053d7df519f3c6df5f71c997
Size (ligotimegps-2.0.1.tar.gz) = 35191 bytes
SHA1 (patch-versioneer.py) = f0a75391fa70ed6f7f1e18079bbf57a80ee5ca94

View File

@ -0,0 +1,18 @@
$NetBSD: patch-versioneer.py,v 1.1 2023/11/05 20:25:22 wiz Exp $
Fix build with Python 3.12.
--- versioneer.py.orig 2019-04-25 15:59:49.000000000 +0000
+++ versioneer.py
@@ -409,9 +409,9 @@ def get_config_from_root(root):
# configparser.NoOptionError (if it lacks "VCS="). See the docstring at
# the top of versioneer.py for instructions on writing your setup.cfg .
setup_cfg = os.path.join(root, "setup.cfg")
- parser = configparser.SafeConfigParser()
+ parser = configparser.ConfigParser()
with open(setup_cfg, "r") as f:
- parser.readfp(f)
+ parser.read_file(f)
VCS = parser.get("versioneer", "VCS") # mandatory
def get(parser, name):