Update xsane to 0.43

Notable changes are:
 - Disabled selection of LZW compression for libtiff.
 - PNG problems (not supported, lineart wrong) are solved.
 - Device name is saved in drc file now.
 - Xsane version is saved in drc file now.
 - Warning is printed if device rc file was not created for active device .
 - In GIMP mode there is no empty file created any more.
 - changed calculation of size in info row from unisgned long to float
   because unsigned long / 10 were to small to fit A4 with 1200x1200 dpi
 - removed member device from struct preferences - was never used
 - warning is printed if device rc file was not created for active device
 - bounded contrast to >=-100.0
 - added continuous update to histogram sliders and preview selection
 - moved "show xxx" menu items form menu "Preferences" to menu "View"
 - changed brightness and contrast range maximum from 300 to 400 %
 - added french translation - thanks to Vincent Renardias
 - added german translation table
 - replaced button-texts negative, rgb default, auto, default, store and
   restore by icons
 - setup/jpeg quality selection is enabled
 - implemented real single-bit format for tiff
 - added tiff compression type selection for multi bit and one bit images
 - the preview selection is based on device coordinates instead of
   preview window coordinates now
 - if there are no standard device settings at program startup, xsane
   take the backend predefined resolution (before this was set to 100)
This commit is contained in:
rh 1999-11-11 14:02:04 +00:00
parent 6fd648befd
commit 25c5a12454
6 changed files with 89 additions and 52 deletions

View file

@ -1,9 +1,16 @@
# $NetBSD: Makefile,v 1.8 1999/10/24 16:42:51 tron Exp $
# $NetBSD: Makefile,v 1.9 1999/11/11 14:02:04 rh Exp $
#
DISTNAME= xsane-0.33
DISTNAME= xsane-0.43
CATEGORIES= graphics
MASTER_SITES= http://www.wolfsburg.de/~rauch/sane/
MASTER_SITES= http://www.wolfsburg.de/~rauch/sane/ \
http://gd.tuwien.ac.at/hci/sane/xsane/ \
ftp://ftp.mostang.com/pub/sane/xsane/ \
ftp://ftp.informatik.uni-oldenburg.de/pub/sane/xsane/ \
ftp://gd.tuwien.ac.at/hci/sane/xsane/ \
ftp://ftp.u-aizu.ac.jp/pub/misc/device/scsi/scanner/sane/xsane/ \
ftp://ftp.umax.co.uk/sane/ \
ftp://sunsite.uio.no/pub/sane/xsane/
MAINTAINER= rh@netbsd.org
HOMEPAGE= http://www.wolfsburg.de/~rauch/sane/sane-xsane.html
@ -19,6 +26,6 @@ USE_GMAKE= YES
USE_X11BASE= YES
USE_LIBTOOL= YES
CPPFLAGS+= -I${PREFIX}/include
CPPFLAGS+= -I${PREFIX}/include -I${LOCALBASE}/include
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.5 1999/08/27 06:11:46 rh Exp $
$NetBSD: md5,v 1.6 1999/11/11 14:02:08 rh Exp $
MD5 (xsane-0.33.tar.gz) = e0b360199bc2103240338154f03b64f6
MD5 (xsane-0.43.tar.gz) = 8378587301e271341af0a1e251e7bac7

View file

@ -1,5 +1,5 @@
$NetBSD: patch-sum,v 1.2 1999/07/27 21:23:49 rh Exp $
$NetBSD: patch-sum,v 1.3 1999/11/11 14:02:09 rh Exp $
MD5 (patch-aa) = 04892436e29c653f268a252b44295168
MD5 (patch-ab) = d69519de2f6b3ba1db8e91eae2e8ceee
MD5 (patch-aa) = d9ded3d2665d4cdb2976d211bff15a6a
MD5 (patch-ab) = d180e1bee83c3ec706effb9901113fb0
MD5 (patch-ac) = 0d04e0930db85eb06c9e0fa73cb4a159

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.2 1999/05/03 16:29:23 rh Exp $
$NetBSD: patch-aa,v 1.3 1999/11/11 14:02:09 rh Exp $
--- configure.orig Wed Apr 14 00:42:49 1999
+++ configure Sun May 2 14:11:59 1999
--- configure.orig Wed Nov 3 19:39:12 1999
+++ configure Thu Nov 11 12:36:07 1999
@@ -9,7 +9,7 @@
# Defaults:
@ -10,8 +10,25 @@ $NetBSD: patch-aa,v 1.2 1999/05/03 16:29:23 rh Exp $
+ac_default_prefix=${PREFIX}
# Any additions from configure.in:
ac_help="$ac_help
--with-x use the X Window System"
@@ -3674,10 +3674,12 @@
--enable-intl-patch add -lintl to check for sane"
@@ -4743,7 +4743,7 @@
# so we have to use x_includes and x_libraries to test for png
# and all following checks (=sane)
# saved_CPPFLAGS is still up to date
-CPPFLAGS="${CPPFLAGS} -I${x_includes}"
+CPPFLAGS="${CPPFLAGS} -I${x_includes} -I${LOCALBASE}/include"
if test "${USE_PNG}" = "yes"; then
for ac_hdr in png.h
do
@@ -4844,6 +4844,7 @@
# check must stand at end of list because of the missing libintl in libsane.so
# check needs x_libraries and x_includes because they may be needed by png
if test "${ADD_LIBINTL}" = "no"; then
+ CPPFLAGS="${CPPFLAGS} -I${x_includes}"
for ac_hdr in sane/sane.h
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
@@ -5328,10 +5329,12 @@
top_srcdir="$ac_dots$ac_given_srcdir" ;;
esac

View file

@ -1,19 +1,20 @@
$NetBSD: patch-ab,v 1.3 1999/07/27 21:22:41 rh Exp $
$NetBSD: patch-ab,v 1.4 1999/11/11 14:02:09 rh Exp $
--- frontend/Makefile.in.orig Thu Apr 15 18:18:45 1999
+++ frontend/Makefile.in Tue Jul 27 23:13:08 1999
@@ -29,12 +29,12 @@
--- frontend/Makefile.in.orig Thu Nov 11 12:20:53 1999
+++ frontend/Makefile.in Thu Nov 11 12:22:58 1999
@@ -29,13 +29,13 @@
CC = @CC@
INCLUDES = -I. -I$(srcdir) -I$(top_builddir)/include -I$(top_srcdir)/include \
- @GTK_CFLAGS@ @INCLUDES@
+ @GTK_CFLAGS@ @INCLUDES@ -I${LOCALBASE}/include
- @GTK_CFLAGS@ @INCLUDES@ \
+ @GTK_CFLAGS@ @INCLUDES@ -I${LOCALBASE}/include \
-DLOCALEDIR=\""$(datadir)/locale"\"
DEFS = @DEFS@
CPPFLAGS = @CPPFLAGS@
CFLAGS = @CFLAGS@
LDFLAGS = @LDFLAGS@
-LIBS = @LIBS@
+LIBS = @LIBS@ -L${X11BASE}/lib -Wl,-R${X11BASE}/lib/sane -lsane
-LIBS = @INTLLIBS@ @LIBS@
+LIBS = @INTLLIBS@ @LIBS@ -L${X11BASE}/lib -Wl,-R${X11BASE}/lib/sane -lsane
GTK_LIBS = @GTK_LIBS@
GIMP_LIBS = @GIMP_LIBS@

View file

@ -1,6 +1,8 @@
@comment $NetBSD: PLIST,v 1.3 1999/07/27 15:44:33 rh Exp $
@comment $NetBSD: PLIST,v 1.4 1999/11/11 14:02:09 rh Exp $
bin/xsane
man/man1/xsane.1
share/locale/fr/LC_MESSAGES/xsane.mo
share/locale/de/LC_MESSAGES/xsane.mo
share/sane/xsane-style.rc
share/sane/xsane-logo.xpm
share/sane/sane-backends-doc.html
@ -15,36 +17,46 @@ share/sane/sane-xsane-fax-doc.html
share/sane/sane-xsane-gimp-doc.html
share/sane/sane-xsane-histogram-doc.html
share/sane/sane-xsane-main-doc.html
share/sane/brightness.gif
share/sane/autoenhance.jpg
share/sane/sane-xsane-preview-doc.html
share/sane/sane-xsane-scan-doc.html
share/sane/sane-xsane-setup-doc.html
share/sane/sane-xsane-setup-display-doc.html
share/sane/sane-xsane-setup-fax-doc.html
share/sane/sane-xsane-setup-printer-doc.html
share/sane/sane-xsane-setup-save-doc.html
share/sane/sane-xsane-standard-doc.html
share/sane/contrast.gif
share/sane/gamma.gif
share/sane/sane-logo.gif
share/sane/sane-logo2.gif
share/sane/sane-xsane-advanced.gif
share/sane/sane-xsane-copy.gif
share/sane/sane-xsane-fax-project.gif
share/sane/sane-xsane-fax.gif
share/sane/sane-xsane-gimp.gif
share/sane/sane-xsane-histogram.gif
share/sane/sane-xsane-pipette-black.gif
share/sane/sane-xsane-pipette-gray.gif
share/sane/sane-xsane-pipette-white.gif
share/sane/sane-xsane-preview.gif
share/sane/sane-xsane-setup-display.gif
share/sane/sane-xsane-setup-fax.gif
share/sane/sane-xsane-setup-printer.gif
share/sane/sane-xsane-setup-save.gif
share/sane/sane-xsane-standard.gif
share/sane/sane-xsane-visible-area.gif
share/sane/sane-xsane-zoom-in.gif
share/sane/sane-xsane-zoom-not.gif
share/sane/sane-xsane-zoom-out.gif
share/sane/sane-xsane-zoom-undo.gif
share/sane/sane-xsane.gif
share/sane/xsane-logo.gif
share/sane/xsane-logo2.gif
share/sane/brightness.jpg
share/sane/contrast.jpg
share/sane/default.jpg
share/sane/gamma.jpg
share/sane/negative.jpg
share/sane/restore.jpg
share/sane/rgb-default.jpg
share/sane/sane-logo.jpg
share/sane/sane-logo2.jpg
share/sane/sane-xsane-copy.jpg
share/sane/sane-xsane-advanced.jpg
share/sane/sane-xsane-fax-project.jpg
share/sane/sane-xsane-fax.jpg
share/sane/sane-xsane-gimp.jpg
share/sane/sane-xsane-histogram.jpg
share/sane/sane-xsane-pipette-black.jpg
share/sane/sane-xsane-pipette-gray.jpg
share/sane/sane-xsane-pipette-white.jpg
share/sane/sane-xsane-preview.jpg
share/sane/sane-xsane-setup-display.jpg
share/sane/sane-xsane-setup-fax.jpg
share/sane/sane-xsane-setup-printer.jpg
share/sane/sane-xsane-setup-save.jpg
share/sane/sane-xsane-standard.jpg
share/sane/store.jpg
share/sane/sane-xsane-visible-area.jpg
share/sane/sane-xsane-zoom-in.jpg
share/sane/sane-xsane-zoom-not.jpg
share/sane/sane-xsane-zoom-out.jpg
share/sane/sane-xsane-zoom-undo.jpg
share/sane/sane-xsane.jpg
share/sane/xsane-logo.jpg
share/sane/xsane-logo2.jpg
share/sane/xxx.jpg
@dirrm share/sane