py-rt: Backport upstream patch to fix search() Format='s' and Format='i'
At least on RT 4 blank lines can be present at the end of the search response, backport upstream commit bb07009c4f62dd2ac393aab82fded6424eead82f to address that. Bump PKGREVISION
This commit is contained in:
parent
594bf629af
commit
25cdc1d259
3 changed files with 33 additions and 2 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.1 2018/09/15 10:53:31 leot Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2019/06/09 13:57:27 leot Exp $
|
||||
|
||||
DISTNAME= rt-1.0.11
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= net python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=r/rt/}
|
||||
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2018/09/15 10:53:31 leot Exp $
|
||||
$NetBSD: distinfo,v 1.2 2019/06/09 13:57:27 leot Exp $
|
||||
|
||||
SHA1 (py-rt/rt-1.0.11.tar.gz) = 2a919c9df7a7aec75aa9f1f19df9fbc81341e784
|
||||
RMD160 (py-rt/rt-1.0.11.tar.gz) = cd0ee2929ede3c878e21bf0750e4fe262550ded5
|
||||
SHA512 (py-rt/rt-1.0.11.tar.gz) = 00007710d152472bf25e656b6298502e0b571932c8c3f4c498074fe7a849d575fd2deaad91a4814a7aece4dbfa847c913045e927830a8e0a02d3d13876562696
|
||||
Size (py-rt/rt-1.0.11.tar.gz) = 35084 bytes
|
||||
SHA1 (patch-rt.py) = a1180f06f39e1dba6fca86205755549c34d6b8b8
|
||||
|
|
29
net/py-rt/patches/patch-rt.py
Normal file
29
net/py-rt/patches/patch-rt.py
Normal file
|
@ -0,0 +1,29 @@
|
|||
$NetBSD: patch-rt.py,v 1.1 2019/06/09 13:57:27 leot Exp $
|
||||
|
||||
Backport upstream commit bb07009c4f62dd2ac393aab82fded6424eead82f
|
||||
to ignore ignore possible empty lines.
|
||||
|
||||
--- rt.py.orig 2018-07-16 12:47:27.000000000 +0000
|
||||
+++ rt.py
|
||||
@@ -518,15 +518,19 @@ class Rt:
|
||||
return items
|
||||
elif Format == 's':
|
||||
items = []
|
||||
- msgs = msg.splitlines()[2:]
|
||||
+ msgs = lines[2:]
|
||||
for msg in msgs:
|
||||
+ if "" == msg: # Ignore blank line at the end
|
||||
+ continue
|
||||
ticket_id, subject = msg.split(': ', 1)
|
||||
items.append({'id': 'ticket/' + ticket_id, 'Subject': subject})
|
||||
return items
|
||||
elif Format == 'i':
|
||||
items = []
|
||||
- msgs = msg.splitlines()[2:]
|
||||
+ msgs = lines[2:]
|
||||
for msg in msgs:
|
||||
+ if "" == msg: # Ignore blank line at the end
|
||||
+ continue
|
||||
_, ticket_id = msg.split('/', 1)
|
||||
items.append({'id': 'ticket/' + ticket_id})
|
||||
return items
|
Loading…
Reference in a new issue