Import new "gnome-python" package:
Python Bindings for the GNU Network Object Model Environment
This commit is contained in:
parent
6118de5ebe
commit
25dca8022d
7 changed files with 115 additions and 0 deletions
16
x11/gnome-python/Makefile
Normal file
16
x11/gnome-python/Makefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 1999/11/20 20:17:47 tron Exp $
|
||||
|
||||
DISTNAME= gnome-python-1.0.50
|
||||
CATEGORIES= x11 gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=gnome-1.0.53/sources/}
|
||||
|
||||
MAINTAINER= tron@netbsd.org
|
||||
HOMEPAGE= http://www.daa.com.au/~james/gnome/
|
||||
|
||||
DEPENDS+= py-gtk-*:../py-gtk
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_X11= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
x11/gnome-python/files/md5
Normal file
3
x11/gnome-python/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/11/20 20:17:48 tron Exp $
|
||||
|
||||
MD5 (gnome-python-1.0.50.tar.gz) = 7fee8cae9550d0f30f24b2a3a3c2e293
|
3
x11/gnome-python/files/patch-sum
Normal file
3
x11/gnome-python/files/patch-sum
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 1999/11/20 20:17:48 tron Exp $
|
||||
|
||||
MD5 (patch-aa) = b076b23801243a822940141323601e4e
|
13
x11/gnome-python/patches/patch-aa
Normal file
13
x11/gnome-python/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1999/11/20 20:17:48 tron Exp $
|
||||
|
||||
--- Makefile.in.orig Fri Oct 1 10:36:40 1999
|
||||
+++ Makefile.in Sat Nov 20 21:07:24 1999
|
||||
@@ -97,7 +97,7 @@
|
||||
pyexecdir = @pyexecdir@
|
||||
pythondir = @pythondir@
|
||||
|
||||
-SUBDIRS = macros pygtk pygnome
|
||||
+SUBDIRS = macros pygnome
|
||||
|
||||
EXTRA_DIST = gnome-python.spec
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
1
x11/gnome-python/pkg/COMMENT
Normal file
1
x11/gnome-python/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
Python Bindings for the GNU Network Object Model Environment
|
16
x11/gnome-python/pkg/DESCR
Normal file
16
x11/gnome-python/pkg/DESCR
Normal file
|
@ -0,0 +1,16 @@
|
|||
gnome-python -- Python bindings for GNOME
|
||||
====================================
|
||||
|
||||
Author: James Henstridge <james@daa.com.au>
|
||||
|
||||
This is a set of bindings for the GNOME libraries for use with python. To
|
||||
use them, you will also need the pygtk package compiled and installed. It
|
||||
can be found at either:
|
||||
ftp://ftp.daa.com.au/pub/james/python/
|
||||
ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python/
|
||||
ftp://ftp.python.org/pub/contrib/Graphics/
|
||||
|
||||
You will need gnome-libs 1.0.9 or later installed on your system (the
|
||||
newer the better). Optionally, gnome-core 1.0.x and control-center
|
||||
1.0.x can be used. If they are detected, they add support for writing
|
||||
panel applets and control center capplets respectively.
|
63
x11/gnome-python/pkg/PLIST
Normal file
63
x11/gnome-python/pkg/PLIST
Normal file
|
@ -0,0 +1,63 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1999/11/20 20:17:48 tron Exp $
|
||||
lib/python1.5/site-packages/gnome/__init__.py
|
||||
lib/python1.5/site-packages/gnome/config.py
|
||||
lib/python1.5/site-packages/gnome/file.py
|
||||
lib/python1.5/site-packages/gnome/help.py
|
||||
lib/python1.5/site-packages/gnome/history.py
|
||||
lib/python1.5/site-packages/gnome/metadata.py
|
||||
lib/python1.5/site-packages/gnome/mime.py
|
||||
lib/python1.5/site-packages/gnome/score.py
|
||||
lib/python1.5/site-packages/gnome/triggers.py
|
||||
lib/python1.5/site-packages/gnome/url.py
|
||||
lib/python1.5/site-packages/gnome/ui.py
|
||||
lib/python1.5/site-packages/gnome/uiconsts.py
|
||||
lib/python1.5/site-packages/gnome/xmhtml.py
|
||||
lib/python1.5/site-packages/gnome/zvt.py
|
||||
lib/python1.5/site-packages/gnome/affine.py
|
||||
lib/python1.5/site-packages/gnome/applet.py
|
||||
lib/python1.5/site-packages/gnome/capplet.py
|
||||
lib/python1.5/site-packages/gnome/__init__.pyc
|
||||
lib/python1.5/site-packages/gnome/config.pyc
|
||||
lib/python1.5/site-packages/gnome/file.pyc
|
||||
lib/python1.5/site-packages/gnome/help.pyc
|
||||
lib/python1.5/site-packages/gnome/history.pyc
|
||||
lib/python1.5/site-packages/gnome/metadata.pyc
|
||||
lib/python1.5/site-packages/gnome/mime.pyc
|
||||
lib/python1.5/site-packages/gnome/score.pyc
|
||||
lib/python1.5/site-packages/gnome/triggers.pyc
|
||||
lib/python1.5/site-packages/gnome/url.pyc
|
||||
lib/python1.5/site-packages/gnome/ui.pyc
|
||||
lib/python1.5/site-packages/gnome/uiconsts.pyc
|
||||
lib/python1.5/site-packages/gnome/xmhtml.pyc
|
||||
lib/python1.5/site-packages/gnome/zvt.pyc
|
||||
lib/python1.5/site-packages/gnome/affine.pyc
|
||||
lib/python1.5/site-packages/gnome/applet.pyc
|
||||
lib/python1.5/site-packages/gnome/capplet.pyc
|
||||
lib/python1.5/site-packages/gnome/__init__.pyo
|
||||
lib/python1.5/site-packages/gnome/config.pyo
|
||||
lib/python1.5/site-packages/gnome/file.pyo
|
||||
lib/python1.5/site-packages/gnome/help.pyo
|
||||
lib/python1.5/site-packages/gnome/history.pyo
|
||||
lib/python1.5/site-packages/gnome/metadata.pyo
|
||||
lib/python1.5/site-packages/gnome/mime.pyo
|
||||
lib/python1.5/site-packages/gnome/score.pyo
|
||||
lib/python1.5/site-packages/gnome/triggers.pyo
|
||||
lib/python1.5/site-packages/gnome/url.pyo
|
||||
lib/python1.5/site-packages/gnome/ui.pyo
|
||||
lib/python1.5/site-packages/gnome/uiconsts.pyo
|
||||
lib/python1.5/site-packages/gnome/xmhtml.pyo
|
||||
lib/python1.5/site-packages/gnome/zvt.pyo
|
||||
lib/python1.5/site-packages/gnome/affine.pyo
|
||||
lib/python1.5/site-packages/gnome/applet.pyo
|
||||
lib/python1.5/site-packages/gnome/capplet.pyo
|
||||
lib/python1.5/site-packages/_gnomemodule.so
|
||||
lib/python1.5/site-packages/_gnomeuimodule.so
|
||||
lib/python1.5/site-packages/_zvtmodule.so
|
||||
lib/python1.5/site-packages/_gtkxmhtmlmodule.so
|
||||
lib/python1.5/site-packages/_appletmodule.so
|
||||
lib/python1.5/site-packages/_cappletmodule.so
|
||||
lib/python1.5/site-packages/_gladegnomemodule.so
|
||||
lib/python1.5/site-packages/gettext.py
|
||||
lib/python1.5/site-packages/gettext.pyc
|
||||
lib/python1.5/site-packages/gettext.pyo
|
||||
@dirrm lib/python1.5/site-packages/gnome
|
Loading…
Reference in a new issue