Remove ruby-rb-gsl; it has renamed to ruby-gsl after all.

This commit is contained in:
taca 2013-03-11 12:33:23 +00:00
parent 8ef1a28882
commit 263262d459
6 changed files with 0 additions and 444 deletions

View file

@ -1,2 +0,0 @@
Ruby/GSL is a ruby interface to the GSL (GNU Scientific Library), for
numerical computing with Ruby.

View file

@ -1,31 +0,0 @@
# $NetBSD: Makefile,v 1.12 2012/09/11 23:04:33 asau Exp $
DISTNAME= rb-gsl-1.14.7
CATEGORIES= math ruby
MASTER_SITES= http://rubyforge.org/frs/download.php/74341/
EXTRACT_SUFX= .tgz
MAINTAINER= minskim@NetBSD.org
HOMEPAGE= http://rb-gsl.rubyforge.org/
COMMENT= Ruby interface to the GNU Scientific Library
LICENSE= gnu-gpl-v2
USE_RUBY_SETUP= yes
USE_TOOLS= pax
CONFIGURE_ARGS+= --siteruby=${PREFIX}/${RUBY_VENDORLIB_BASE} \
--siterubyver=${PREFIX}/${RUBY_VENDORLIB} \
--siterubyverarch=${PREFIX}/${RUBY_VENDORARCHLIB}
REPLACE_RUBY_DIRS= examples
INSTALLATION_DIRS= ${RUBY_DOC}/gsl ${RUBY_EG}/gsl
.include "../../lang/ruby/modules.mk"
.include "../../math/gsl/buildlink3.mk"
post-install:
${INSTALL_DATA} ${WRKSRC}/README ${DESTDIR}${PREFIX}/${RUBY_DOC}/gsl
cd ${WRKSRC}/examples; pax -rw . ${DESTDIR}${PREFIX}/${RUBY_EG}/gsl
.include "../../mk/bsd.pkg.mk"

View file

@ -1,356 +0,0 @@
@comment $NetBSD: PLIST,v 1.6 2010/12/04 04:09:57 taca Exp $
${RUBY_VENDORLIB}/gsl.rb
${RUBY_VENDORLIB}/gsl/gnuplot.rb
${RUBY_VENDORLIB}/gsl/oper.rb
${RUBY_VENDORARCHLIB}/rb_gsl.${RUBY_DLEXT}
${RUBY_VENDORLIB}/ool.rb
${RUBY_VENDORLIB}/ool/conmin.rb
${RUBY_VENDORLIB}/rbgsl.rb
${RUBY_DOC}/gsl/README
${RUBY_EG}/gsl/alf/alf.gp
${RUBY_EG}/gsl/alf/alf.rb
${RUBY_EG}/gsl/blas/blas.rb
${RUBY_EG}/gsl/blas/dnrm2.rb
${RUBY_EG}/gsl/blas/level1.rb
${RUBY_EG}/gsl/blas/level2.rb
${RUBY_EG}/gsl/blas/level3.rb
${RUBY_EG}/gsl/bspline.rb
${RUBY_EG}/gsl/cdf.rb
${RUBY_EG}/gsl/cheb.rb
${RUBY_EG}/gsl/combination.rb
${RUBY_EG}/gsl/complex/RC-lpf.rb
${RUBY_EG}/gsl/complex/add.rb
${RUBY_EG}/gsl/complex/coerce.rb
${RUBY_EG}/gsl/complex/complex.rb
${RUBY_EG}/gsl/complex/fpmi.rb
${RUBY_EG}/gsl/complex/functions.rb
${RUBY_EG}/gsl/complex/michelson.rb
${RUBY_EG}/gsl/complex/mul.rb
${RUBY_EG}/gsl/complex/oscillator.rb
${RUBY_EG}/gsl/complex/set.rb
${RUBY_EG}/gsl/const/physconst.rb
${RUBY_EG}/gsl/const/travel.rb
${RUBY_EG}/gsl/deriv/demo.rb
${RUBY_EG}/gsl/deriv/deriv.rb
${RUBY_EG}/gsl/deriv/diff.rb
${RUBY_EG}/gsl/dht.rb
${RUBY_EG}/gsl/dirac.rb
${RUBY_EG}/gsl/eigen/eigen.rb
${RUBY_EG}/gsl/eigen/herm.rb
${RUBY_EG}/gsl/eigen/narray.rb
${RUBY_EG}/gsl/eigen/nonsymm.rb
${RUBY_EG}/gsl/eigen/nonsymmv.rb
${RUBY_EG}/gsl/eigen/qhoscillator.gp
${RUBY_EG}/gsl/eigen/qhoscillator.rb
${RUBY_EG}/gsl/eigen/vander.rb
${RUBY_EG}/gsl/fft/fft.rb
${RUBY_EG}/gsl/fft/fft2.rb
${RUBY_EG}/gsl/fft/forward.rb
${RUBY_EG}/gsl/fft/forward2.rb
${RUBY_EG}/gsl/fft/radix2.rb
${RUBY_EG}/gsl/fft/real-halfcomplex.rb
${RUBY_EG}/gsl/fft/real-halfcomplex2.rb
${RUBY_EG}/gsl/fft/realradix2.rb
${RUBY_EG}/gsl/fft/sunspot.dat
${RUBY_EG}/gsl/fft/sunspot.rb
${RUBY_EG}/gsl/fit/expdata.dat
${RUBY_EG}/gsl/fit/expfit.rb
${RUBY_EG}/gsl/fit/gaussfit.rb
${RUBY_EG}/gsl/fit/gaussian_2peaks.rb
${RUBY_EG}/gsl/fit/hillfit.rb
${RUBY_EG}/gsl/fit/lognormal.rb
${RUBY_EG}/gsl/fit/lorentzfit.rb
${RUBY_EG}/gsl/fit/multifit.rb
${RUBY_EG}/gsl/fit/ndlinear.rb
${RUBY_EG}/gsl/fit/nonlinearfit.rb
${RUBY_EG}/gsl/fit/plot.gp
${RUBY_EG}/gsl/fit/polyfit.rb
${RUBY_EG}/gsl/fit/powerfit.rb
${RUBY_EG}/gsl/fit/sigmoidfit.rb
${RUBY_EG}/gsl/fit/sinfit.rb
${RUBY_EG}/gsl/fit/wlinear.rb
${RUBY_EG}/gsl/fresnel.rb
${RUBY_EG}/gsl/function/function.rb
${RUBY_EG}/gsl/function/log.rb
${RUBY_EG}/gsl/function/min.rb
${RUBY_EG}/gsl/function/sin.rb
${RUBY_EG}/gsl/function/synchrotron.rb
${RUBY_EG}/gsl/gallery/butterfly.rb
${RUBY_EG}/gsl/gallery/cayley.rb
${RUBY_EG}/gsl/gallery/cornu.rb
${RUBY_EG}/gsl/gallery/eight.rb
${RUBY_EG}/gsl/gallery/koch.rb
${RUBY_EG}/gsl/gallery/lemniscate.rb
${RUBY_EG}/gsl/gallery/polar.rb
${RUBY_EG}/gsl/gallery/rgplot/cossin.rb
${RUBY_EG}/gsl/gallery/rgplot/rgplot.replaced
${RUBY_EG}/gsl/gallery/rgplot/roesller.rb
${RUBY_EG}/gsl/gallery/roesller.rb
${RUBY_EG}/gsl/gallery/scarabaeus.rb
${RUBY_EG}/gsl/histogram/cauchy.rb
${RUBY_EG}/gsl/histogram/cauchy.sh
${RUBY_EG}/gsl/histogram/exponential.rb
${RUBY_EG}/gsl/histogram/gauss.rb
${RUBY_EG}/gsl/histogram/gsl-histogram.rb
${RUBY_EG}/gsl/histogram/histo2d.rb
${RUBY_EG}/gsl/histogram/histo3d.rb
${RUBY_EG}/gsl/histogram/histogram-pdf.rb
${RUBY_EG}/gsl/histogram/histogram.rb
${RUBY_EG}/gsl/histogram/integral.rb
${RUBY_EG}/gsl/histogram/poisson.rb
${RUBY_EG}/gsl/histogram/power.rb
${RUBY_EG}/gsl/histogram/rebin.rb
${RUBY_EG}/gsl/histogram/smp.dat
${RUBY_EG}/gsl/histogram/xexp.rb
${RUBY_EG}/gsl/integration/ahmed.rb
${RUBY_EG}/gsl/integration/cosmology.rb
${RUBY_EG}/gsl/integration/friedmann.gp
${RUBY_EG}/gsl/integration/friedmann.rb
${RUBY_EG}/gsl/integration/gamma-zeta.rb
${RUBY_EG}/gsl/integration/integration.rb
${RUBY_EG}/gsl/integration/qag.rb
${RUBY_EG}/gsl/integration/qag2.rb
${RUBY_EG}/gsl/integration/qag3.rb
${RUBY_EG}/gsl/integration/qagi.rb
${RUBY_EG}/gsl/integration/qagi2.rb
${RUBY_EG}/gsl/integration/qagiu.rb
${RUBY_EG}/gsl/integration/qagp.rb
${RUBY_EG}/gsl/integration/qags.rb
${RUBY_EG}/gsl/integration/qawc.rb
${RUBY_EG}/gsl/integration/qawf.rb
${RUBY_EG}/gsl/integration/qawo.rb
${RUBY_EG}/gsl/integration/qaws.rb
${RUBY_EG}/gsl/integration/qng.rb
${RUBY_EG}/gsl/interp/demo.gp
${RUBY_EG}/gsl/interp/demo.rb
${RUBY_EG}/gsl/interp/interp.rb
${RUBY_EG}/gsl/interp/points
${RUBY_EG}/gsl/interp/spline.rb
${RUBY_EG}/gsl/jacobi/deriv.rb
${RUBY_EG}/gsl/jacobi/integrate.rb
${RUBY_EG}/gsl/jacobi/interp.rb
${RUBY_EG}/gsl/jacobi/jacobi.rb
${RUBY_EG}/gsl/linalg/HH.rb
${RUBY_EG}/gsl/linalg/HH_narray.rb
${RUBY_EG}/gsl/linalg/LQ_solve.rb
${RUBY_EG}/gsl/linalg/LU.rb
${RUBY_EG}/gsl/linalg/LU2.rb
${RUBY_EG}/gsl/linalg/LU_narray.rb
${RUBY_EG}/gsl/linalg/PTLQ.rb
${RUBY_EG}/gsl/linalg/QR.rb
${RUBY_EG}/gsl/linalg/QRPT.rb
${RUBY_EG}/gsl/linalg/QR_solve.rb
${RUBY_EG}/gsl/linalg/QR_solve_narray.rb
${RUBY_EG}/gsl/linalg/SV.rb
${RUBY_EG}/gsl/linalg/SV_narray.rb
${RUBY_EG}/gsl/linalg/SV_solve.rb
${RUBY_EG}/gsl/linalg/chol.rb
${RUBY_EG}/gsl/linalg/chol_narray.rb
${RUBY_EG}/gsl/linalg/complex.rb
${RUBY_EG}/gsl/linalg/invert_narray.rb
${RUBY_EG}/gsl/math/const.rb
${RUBY_EG}/gsl/math/elementary.rb
${RUBY_EG}/gsl/math/functions.rb
${RUBY_EG}/gsl/math/inf_nan.rb
${RUBY_EG}/gsl/math/minmax.rb
${RUBY_EG}/gsl/math/power.rb
${RUBY_EG}/gsl/math/test.rb
${RUBY_EG}/gsl/matrix/a.dat
${RUBY_EG}/gsl/matrix/add.rb
${RUBY_EG}/gsl/matrix/b.dat
${RUBY_EG}/gsl/matrix/cat.rb
${RUBY_EG}/gsl/matrix/colvectors.rb
${RUBY_EG}/gsl/matrix/complex.rb
${RUBY_EG}/gsl/matrix/det.rb
${RUBY_EG}/gsl/matrix/diagonal.rb
${RUBY_EG}/gsl/matrix/get_all.rb
${RUBY_EG}/gsl/matrix/hilbert.rb
${RUBY_EG}/gsl/matrix/iterator.rb
${RUBY_EG}/gsl/matrix/matrix.rb
${RUBY_EG}/gsl/matrix/minmax.rb
${RUBY_EG}/gsl/matrix/mul.rb
${RUBY_EG}/gsl/matrix/rand.rb
${RUBY_EG}/gsl/matrix/read.rb
${RUBY_EG}/gsl/matrix/rowcol.rb
${RUBY_EG}/gsl/matrix/set.rb
${RUBY_EG}/gsl/matrix/set_all.rb
${RUBY_EG}/gsl/matrix/view.rb
${RUBY_EG}/gsl/matrix/view_all.rb
${RUBY_EG}/gsl/matrix/write.rb
${RUBY_EG}/gsl/min.rb
${RUBY_EG}/gsl/monte/miser.rb
${RUBY_EG}/gsl/monte/monte.rb
${RUBY_EG}/gsl/monte/plain.rb
${RUBY_EG}/gsl/monte/vegas.rb
${RUBY_EG}/gsl/multimin/bundle.rb
${RUBY_EG}/gsl/multimin/cqp.rb
${RUBY_EG}/gsl/multimin/fdfminimizer.rb
${RUBY_EG}/gsl/multimin/fminimizer.rb
${RUBY_EG}/gsl/multiroot/demo.rb
${RUBY_EG}/gsl/multiroot/fdfsolver.rb
${RUBY_EG}/gsl/multiroot/fsolver.rb
${RUBY_EG}/gsl/multiroot/fsolver2.rb
${RUBY_EG}/gsl/multiroot/fsolver3.rb
${RUBY_EG}/gsl/narray/histogram.rb
${RUBY_EG}/gsl/narray/mandel.rb
${RUBY_EG}/gsl/narray/narray.rb
${RUBY_EG}/gsl/narray/narray2.rb
${RUBY_EG}/gsl/narray/sf.rb
${RUBY_EG}/gsl/ntuple/create.rb
${RUBY_EG}/gsl/ntuple/project.rb
${RUBY_EG}/gsl/odeiv/binarysystem.gp
${RUBY_EG}/gsl/odeiv/binarysystem.rb
${RUBY_EG}/gsl/odeiv/demo.gp
${RUBY_EG}/gsl/odeiv/demo.rb
${RUBY_EG}/gsl/odeiv/demo2.gp
${RUBY_EG}/gsl/odeiv/duffing.rb
${RUBY_EG}/gsl/odeiv/frei1.rb
${RUBY_EG}/gsl/odeiv/frei2.rb
${RUBY_EG}/gsl/odeiv/legendre.rb
${RUBY_EG}/gsl/odeiv/odeiv.rb
${RUBY_EG}/gsl/odeiv/odeiv2.rb
${RUBY_EG}/gsl/odeiv/oscillator.rb
${RUBY_EG}/gsl/odeiv/sedov.rb
${RUBY_EG}/gsl/odeiv/whitedwarf.gp
${RUBY_EG}/gsl/odeiv/whitedwarf.rb
${RUBY_EG}/gsl/ool/conmin.rb
${RUBY_EG}/gsl/ool/gencan.rb
${RUBY_EG}/gsl/ool/pgrad.rb
${RUBY_EG}/gsl/ool/spg.rb
${RUBY_EG}/gsl/pdf/bernoulli.rb
${RUBY_EG}/gsl/pdf/beta.rb
${RUBY_EG}/gsl/pdf/binomiral.rb
${RUBY_EG}/gsl/pdf/cauchy.rb
${RUBY_EG}/gsl/pdf/chisq.rb
${RUBY_EG}/gsl/pdf/exponential.rb
${RUBY_EG}/gsl/pdf/exppow.rb
${RUBY_EG}/gsl/pdf/fdist.rb
${RUBY_EG}/gsl/pdf/flat.rb
${RUBY_EG}/gsl/pdf/gamma.rb
${RUBY_EG}/gsl/pdf/gauss-tail.rb
${RUBY_EG}/gsl/pdf/gauss.rb
${RUBY_EG}/gsl/pdf/geometric.rb
${RUBY_EG}/gsl/pdf/gumbel.rb
${RUBY_EG}/gsl/pdf/hypergeometric.rb
${RUBY_EG}/gsl/pdf/landau.rb
${RUBY_EG}/gsl/pdf/laplace.rb
${RUBY_EG}/gsl/pdf/logarithmic.rb
${RUBY_EG}/gsl/pdf/logistic.rb
${RUBY_EG}/gsl/pdf/lognormal.rb
${RUBY_EG}/gsl/pdf/neg-binomiral.rb
${RUBY_EG}/gsl/pdf/pareto.rb
${RUBY_EG}/gsl/pdf/pascal.rb
${RUBY_EG}/gsl/pdf/poisson.rb
${RUBY_EG}/gsl/pdf/rayleigh-tail.rb
${RUBY_EG}/gsl/pdf/rayleigh.rb
${RUBY_EG}/gsl/pdf/tdist.rb
${RUBY_EG}/gsl/pdf/weibull.rb
${RUBY_EG}/gsl/permutation/ex1.rb
${RUBY_EG}/gsl/permutation/permutation.rb
${RUBY_EG}/gsl/poly/bell.rb
${RUBY_EG}/gsl/poly/bessel.rb
${RUBY_EG}/gsl/poly/cheb.rb
${RUBY_EG}/gsl/poly/cheb_II.rb
${RUBY_EG}/gsl/poly/cubic.rb
${RUBY_EG}/gsl/poly/demo.rb
${RUBY_EG}/gsl/poly/eval.rb
${RUBY_EG}/gsl/poly/eval_derivs.rb
${RUBY_EG}/gsl/poly/fit.rb
${RUBY_EG}/gsl/poly/hermite.rb
${RUBY_EG}/gsl/poly/poly.rb
${RUBY_EG}/gsl/poly/quadratic.rb
${RUBY_EG}/gsl/random/diffusion.rb
${RUBY_EG}/gsl/random/gaussian.rb
${RUBY_EG}/gsl/random/generator.rb
${RUBY_EG}/gsl/random/hdsobol.rb
${RUBY_EG}/gsl/random/poisson.rb
${RUBY_EG}/gsl/random/qrng.rb
${RUBY_EG}/gsl/random/randomwalk.rb
${RUBY_EG}/gsl/random/randomwalk2d.rb
${RUBY_EG}/gsl/random/rayleigh.rb
${RUBY_EG}/gsl/random/rng.rb
${RUBY_EG}/gsl/random/rngextra.rb
${RUBY_EG}/gsl/roots/bisection.rb
${RUBY_EG}/gsl/roots/brent.rb
${RUBY_EG}/gsl/roots/demo.rb
${RUBY_EG}/gsl/roots/newton.rb
${RUBY_EG}/gsl/roots/recombination.gp
${RUBY_EG}/gsl/roots/recombination.rb
${RUBY_EG}/gsl/roots/steffenson.rb
${RUBY_EG}/gsl/sf/ShiChi.rb
${RUBY_EG}/gsl/sf/SiCi.rb
${RUBY_EG}/gsl/sf/airy_Ai.rb
${RUBY_EG}/gsl/sf/airy_Bi.rb
${RUBY_EG}/gsl/sf/bessel_IK.rb
${RUBY_EG}/gsl/sf/bessel_JY.rb
${RUBY_EG}/gsl/sf/beta_inc.rb
${RUBY_EG}/gsl/sf/clausen.rb
${RUBY_EG}/gsl/sf/dawson.rb
${RUBY_EG}/gsl/sf/debye.rb
${RUBY_EG}/gsl/sf/dilog.rb
${RUBY_EG}/gsl/sf/ellint.rb
${RUBY_EG}/gsl/sf/expint.rb
${RUBY_EG}/gsl/sf/fermi.rb
${RUBY_EG}/gsl/sf/gamma_inc_P.rb
${RUBY_EG}/gsl/sf/gegenbauer.rb
${RUBY_EG}/gsl/sf/hyperg.rb
${RUBY_EG}/gsl/sf/laguerre.rb
${RUBY_EG}/gsl/sf/lambertW.rb
${RUBY_EG}/gsl/sf/legendre_P.rb
${RUBY_EG}/gsl/sf/lngamma.rb
${RUBY_EG}/gsl/sf/psi.rb
${RUBY_EG}/gsl/sf/sphbessel.gp
${RUBY_EG}/gsl/sf/sphbessel.rb
${RUBY_EG}/gsl/sf/synchrotron.rb
${RUBY_EG}/gsl/sf/transport.rb
${RUBY_EG}/gsl/sf/zetam1.rb
${RUBY_EG}/gsl/siman.rb
${RUBY_EG}/gsl/sort/heapsort.rb
${RUBY_EG}/gsl/sort/heapsort_vector_complex.rb
${RUBY_EG}/gsl/sort/sort.rb
${RUBY_EG}/gsl/sort/sort2.rb
${RUBY_EG}/gsl/stats/mean.rb
${RUBY_EG}/gsl/stats/statistics.rb
${RUBY_EG}/gsl/stats/test.rb
${RUBY_EG}/gsl/sum.rb
${RUBY_EG}/gsl/tamu_anova.rb
${RUBY_EG}/gsl/vector/a.dat
${RUBY_EG}/gsl/vector/add.rb
${RUBY_EG}/gsl/vector/b.dat
${RUBY_EG}/gsl/vector/c.dat
${RUBY_EG}/gsl/vector/collect.rb
${RUBY_EG}/gsl/vector/compare.rb
${RUBY_EG}/gsl/vector/complex.rb
${RUBY_EG}/gsl/vector/complex_get_all.rb
${RUBY_EG}/gsl/vector/complex_set_all.rb
${RUBY_EG}/gsl/vector/complex_view_all.rb
${RUBY_EG}/gsl/vector/connect.rb
${RUBY_EG}/gsl/vector/decimate.rb
${RUBY_EG}/gsl/vector/diff.rb
${RUBY_EG}/gsl/vector/filescan.rb
${RUBY_EG}/gsl/vector/floor.rb
${RUBY_EG}/gsl/vector/get_all.rb
${RUBY_EG}/gsl/vector/gnuplot.rb
${RUBY_EG}/gsl/vector/graph.rb
${RUBY_EG}/gsl/vector/histogram.rb
${RUBY_EG}/gsl/vector/linspace.rb
${RUBY_EG}/gsl/vector/log.rb
${RUBY_EG}/gsl/vector/logic.rb
${RUBY_EG}/gsl/vector/logspace.rb
${RUBY_EG}/gsl/vector/minmax.rb
${RUBY_EG}/gsl/vector/mul.rb
${RUBY_EG}/gsl/vector/narray.rb
${RUBY_EG}/gsl/vector/read.rb
${RUBY_EG}/gsl/vector/set.rb
${RUBY_EG}/gsl/vector/set_all.rb
${RUBY_EG}/gsl/vector/smpv.dat
${RUBY_EG}/gsl/vector/test.rb
${RUBY_EG}/gsl/vector/test_gslblock.rb
${RUBY_EG}/gsl/vector/vector.rb
${RUBY_EG}/gsl/vector/view.rb
${RUBY_EG}/gsl/vector/view_all.rb
${RUBY_EG}/gsl/vector/where.rb
${RUBY_EG}/gsl/vector/write.rb
${RUBY_EG}/gsl/vector/zip.rb
${RUBY_EG}/gsl/wavelet/ecg.dat
${RUBY_EG}/gsl/wavelet/wavelet1.rb

View file

@ -1,7 +0,0 @@
$NetBSD: distinfo,v 1.7 2011/05/10 11:23:48 taca Exp $
SHA1 (rb-gsl-1.14.7.tgz) = 2ce82d5e6d03dea2e0b27165fb91a8981e190f7a
RMD160 (rb-gsl-1.14.7.tgz) = 90661a3eae170c70fe4994ef87a0199d95fd4aed
Size (rb-gsl-1.14.7.tgz) = 614583 bytes
SHA1 (patch-ext_matrix__complex.c) = 97c93f34b794866366f74269b14e2b7179e6440e
SHA1 (patch-ext_vector__complex.c) = 83913d55f40ca6539344acf7a60a88e312eab9c7

View file

@ -1,24 +0,0 @@
$NetBSD: patch-ext_matrix__complex.c,v 1.1 2011/05/10 11:23:48 taca Exp $
Avoid the same function name on new gsl.
--- ext/matrix_complex.c.orig 2010-11-10 21:43:10.000000000 +0000
+++ ext/matrix_complex.c
@@ -1520,7 +1520,7 @@ static VALUE rb_gsl_matrix_complex_indge
}
-static int gsl_matrix_complex_equal(const gsl_matrix_complex *m1,
+static int _gsl_matrix_complex_equal(const gsl_matrix_complex *m1,
const gsl_matrix_complex *m2, double eps)
{
gsl_complex z1, z2;
@@ -1555,7 +1555,7 @@ static VALUE rb_gsl_matrix_complex_equal
Data_Get_Struct(obj, gsl_matrix_complex, m1);
CHECK_MATRIX_COMPLEX(argv[0]);
Data_Get_Struct(argv[0], gsl_matrix_complex, m2);
- ret = gsl_matrix_complex_equal(m1, m2, eps);
+ ret = _gsl_matrix_complex_equal(m1, m2, eps);
if (ret == 1) return Qtrue;
else return Qfalse;
}

View file

@ -1,24 +0,0 @@
$NetBSD: patch-ext_vector__complex.c,v 1.1 2011/05/10 11:23:48 taca Exp $
Avoid the same function name on new gsl.
--- ext/vector_complex.c.orig 2011-02-14 22:59:45.000000000 +0000
+++ ext/vector_complex.c
@@ -1986,7 +1986,7 @@ static VALUE rb_gsl_vector_complex_zip(i
return ary;
}
-static int gsl_vector_complex_equal(const gsl_vector_complex *v1,
+static int _gsl_vector_complex_equal(const gsl_vector_complex *v1,
const gsl_vector_complex *v2, double eps)
{
gsl_complex z1, z2;
@@ -2019,7 +2019,7 @@ static VALUE rb_gsl_vector_complex_equal
Data_Get_Struct(obj, gsl_vector_complex, v1);
CHECK_VECTOR_COMPLEX(argv[0]);
Data_Get_Struct(argv[0], gsl_vector_complex, v2);
- ret = gsl_vector_complex_equal(v1, v2, eps);
+ ret = _gsl_vector_complex_equal(v1, v2, eps);
if (ret == 1) return Qtrue;
else return Qfalse;
}