NetBSD port.

This commit is contained in:
augustss 1997-10-28 23:59:56 +00:00
parent 2ca7e351d1
commit 2675f4331b
3 changed files with 113 additions and 10 deletions

View file

@ -1,18 +1,24 @@
# $NetBSD: Makefile,v 1.2 1997/10/28 23:59:56 augustss Exp $
# New ports collection makefile for: mpg123
# Version required: 0.59k
# Date created: 25 June 1997
# Whom: Carey Jones <mcj@acquiesce.org>
#
# $Id: Makefile,v 1.1.1.1 1997/10/28 23:18:38 augustss Exp $
# Version required: mpg123-0.59k
# Date created: 97-10-25
# Whom: augustss@cs.chalmers.se
#
DISTNAME= mpg123-0.59k
DISTNAME= mpg123-0.59k
CATEGORIES= audio
MASTER_SITES= ftp://ftp.tu-clausthal.de/pub/unix/audio/mpg123/
MASTER_SITES= http://ftp.tu-clausthal.de/pub/unix/audio/mpg123/
MAINTAINER= mcj@acquiesce.org
MAINTAINER= augustss@cs.chalmers.se
ALL_TARGET= freebsd
MAN1= mpg123.1
.if (${MACHINE_ARCH} == "i386")
ALL_TARGET= netbsd-i386
.else
ALL_TARGET= netbsd
.endif
MAKE_FLAGS+= PREFIX="${PREFIX}"
.include <bsd.port.mk>

View file

@ -0,0 +1,97 @@
diff -u ../mpg123-0.59k/Makefile ./Makefile
--- ../mpg123-0.59k/Makefile Sun Jul 13 08:44:41 1997
+++ ./Makefile Sat Oct 25 22:20:55 1997
@@ -73,6 +79,22 @@
#CFLAGS='-pg -DI386_ASSEM -DREAL_IS_FLOAT -DLINUX -Wall -O2 -m486 -funroll-all-loops -finline-functions -ffast-math' mpg123
#CFLAGS='-DI386_ASSEM -O2 -DREAL_IS_FLOAT -DLINUX -Wall -g'
#CFLAGS='-DI386_ASSEM -DREAL_IS_FLOAT -DLINUX -Wall -O2 -m486 -fomit-frame-pointer -funroll-all-loops -finline-functions -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2'
+
+netbsd-i386:
+ $(MAKE) CC=cc LDFLAGS= \
+ OBJECTS='decode_i386.o dct64_i386.o getbits_.o' \
+ CFLAGS='-Wall -ansi -pedantic -O4 -m486 -fomit-frame-pointer \
+ -funroll-all-loops -ffast-math -DROT_I386 \
+ -DI386_ASSEM -DREAL_IS_FLOAT -DUSE_MMAP -DNETBSD' \
+ mpg123
+
+netbsd:
+ $(MAKE) CC=cc LDFLAGS= \
+ OBJECTS='decode.o dct64.o' \
+ CFLAGS='-Wall -ansi -pedantic -O4 -fomit-frame-pointer \
+ -funroll-all-loops -ffast-math \
+ -DREAL_IS_FLOAT -DUSE_MMAP -DNETBSD' \
+ mpg123
freebsd:
$(MAKE) CC=cc LDFLAGS= \
diff -u ../mpg123-0.59k/audio.c ./audio.c
--- ../mpg123-0.59k/audio.c Sun Jul 13 00:12:01 1997
+++ ./audio.c Sat Oct 25 22:22:16 1997
@@ -214,7 +214,11 @@
return 0;
}
-#elif defined(SOLARIS) || defined(SUNOS)
+#elif defined(SOLARIS) || defined(SUNOS) || defined(NETBSD)
+
+#ifdef NETBSD
+#include <sys/ioctl.h>
+#endif
#include <sys/filio.h>
#ifdef SUNOS
@@ -258,9 +262,7 @@
return -1;
}
- if(ioctl(ai->fn, AUDIO_GETINFO, &ainfo) == -1)
- return -1;
-
+ AUDIO_INITINFO(&ainfo);
switch(ai->output)
{
case AUDIO_OUT_INTERNAL_SPEAKER:
@@ -305,8 +307,7 @@
if(ai->rate != -1)
{
- if(ioctl(ai->fn, AUDIO_GETINFO, &ainfo) == -1)
- return -1;
+ AUDIO_INITINFO(&ainfo);
ainfo.play.sample_rate = ai->rate;
if(ioctl(ai->fn, AUDIO_SETINFO, &ainfo) == -1)
return -1;
@@ -319,8 +320,7 @@
{
audio_info_t ainfo;
- if(ioctl(ai->fn, AUDIO_GETINFO, &ainfo) == -1)
- return -1;
+ AUDIO_INITINFO(&ainfo);
ainfo.play.channels = ai->channels;
if(ioctl(ai->fn, AUDIO_SETINFO, &ainfo) == -1)
return -1;
@@ -331,8 +331,7 @@
{
audio_info_t ainfo;
- if(ioctl(ai->fn, AUDIO_GETINFO, &ainfo) == -1)
- return -1;
+ AUDIO_INITINFO(&ainfo);
switch(ai->format) {
case -1:
diff -u ../mpg123-0.59k/audio.h ./audio.h
--- ../mpg123-0.59k/audio.h Sun Jul 13 08:11:14 1997
+++ ./audio.h Sat Oct 25 22:18:01 1997
@@ -11,7 +11,7 @@
#define AUDIO_FORMAT_ULAW_8 0x8
#define AUDIO_FORMAT_ALAW_8 0x10
-#if defined(HPUX) || defined(SUNOS) || defined(SOLARIS) || defined(VOXWARE)
+#if defined(HPUX) || defined(SUNOS) || defined(SOLARIS) || defined(VOXWARE) || defined(NETBSD)
#define AUDIO_USES_FD
#endif
Common subdirectories: ../mpg123-0.59k/jukebox and ./jukebox
Only in .: ut

View file

@ -1,2 +1,2 @@
bin/mpg123
man/man1/mpg123.1.gz
man/man1/mpg123.1