ppunpack, a decompressor for Amiga PowerPacker files.

This commit is contained in:
tv 1999-05-23 02:01:25 +00:00
parent 88957c056b
commit 26a5e198f1
6 changed files with 51 additions and 0 deletions

View file

@ -0,0 +1,19 @@
# $NetBSD: Makefile,v 1.1.1.1 1999/05/23 02:01:25 tv Exp $
DISTNAME= ppsmall-1.0
PKGNAME= ppunpack-1.0
CATEGORIES= archivers
MASTER_SITES= ftp://ftp.germany.aminet.org/pub/aminet/misc/unix/
EXTRACT_SUFX= .tar.Z
MAINTAINER= packages@netbsd.org
WRKSRC= ${WRKDIR}/PPUnpack
MAKE_FLAGS= CC="${CC}" COPTS="${CFLAGS}"
ALL_TARGET= ppunpack
LICENSE= no-commercial-use
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ppunpack ${PREFIX}/bin/
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 1999/05/23 02:01:25 tv Exp $
MD5 (ppsmall-1.0.tar.Z) = 012c6685c386fbac129d54eb561d7ea8

View file

@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.1.1.1 1999/05/23 02:01:25 tv Exp $
--- depack.h.orig Sat May 22 21:55:32 1999
+++ depack.h Sat May 22 21:56:18 1999
@@ -4,8 +4,10 @@
* see accompanying file README for distribution information
*/
+#include <sys/types.h>
+
typedef unsigned char ubyte;
-typedef unsigned long ulong;
+#define ulong uint
extern ulong depackedlen(ubyte *packed, ulong plen);
extern void ppdepack(ubyte *packed, ubyte *depacked, ulong plen, ulong unplen);

View file

@ -0,0 +1 @@
Decompresses Amiga PowerPacker files

View file

@ -0,0 +1,10 @@
THIS SOURCE-CODE CAN BE USED FOR NON COMMERCIAL PURPOSES ONLY,
IN PPDECRUNCH OR TRACKER.
PLEASE CONTACT Nico Francois (nico.francois@scala.com) FOR ANY
OTHER USES.
ppunpack only unpacks PowerPacker data files. It is only intended
as an help for people who have to process Amiga-related files
on other machines, and don't want to download PowerPacked files to
an Amiga, uncompress the file, and upload it to the other machine.

View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 1999/05/23 02:01:25 tv Exp $
bin/ppunpack