Update to Poly/ML 5.4.1
Changes in Poly/ML Version 5.4 Major New Features * Major rewrite of the X86 code-generator and combining the 32 and 64-bit versions into a single module. It now supports the floating point instructions. * Changes to the way functions with polymorphic equality are handled to eliminate the "structural equality" code. * Uses the GMP library if that is available when Poly/ML is built otherwise falls back to the old Poly/ML code. Minor Additions and Changes * Added a SingleAssignment structure * Support for the Itanium processor using the interpreted version. * Various bug fixes.
This commit is contained in:
parent
652290d392
commit
26be040688
4 changed files with 27 additions and 23 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.2 2009/12/13 23:26:25 asau Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2012/03/22 20:48:43 asau Exp $
|
||||
|
||||
DISTNAME= polyml.5.3
|
||||
PKGNAME= polyml-5.3
|
||||
DISTNAME= polyml.5.4.1
|
||||
PKGNAME= polyml-5.4.1
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=polyml/}
|
||||
|
||||
|
@ -17,6 +17,7 @@ PKG_DESTDIR_SUPPORT= user-destdir
|
|||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_LANGUAGES= c c++
|
||||
TEST_TARGET= tests
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2009/12/13 23:26:25 asau Exp $
|
||||
$NetBSD: distinfo,v 1.3 2012/03/22 20:48:43 asau Exp $
|
||||
|
||||
SHA1 (polyml.5.3.tar.gz) = a037cd8cf4ce4a43b685b0e0d80f3f1e20d7c9fa
|
||||
RMD160 (polyml.5.3.tar.gz) = d9a806945437c147cc41407bd596b2c435ecc21e
|
||||
Size (polyml.5.3.tar.gz) = 5289077 bytes
|
||||
SHA1 (patch-aa) = 90fc5b96f17080732343ffdefc4cad57cd0f8ff8
|
||||
SHA1 (polyml.5.4.1.tar.gz) = 85998ff7b290fae821a23fa5303b012ccea07ea1
|
||||
RMD160 (polyml.5.4.1.tar.gz) = 7f3916f306f1fa24afb5b7cbb77bac98c9e4ab24
|
||||
Size (polyml.5.4.1.tar.gz) = 6107319 bytes
|
||||
SHA1 (patch-libpolyml_elfexport.cpp) = b32d52ea2a0b00b15cab1ec3aff0dac84add1d56
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2009/12/13 23:26:26 asau Exp $
|
||||
|
||||
Use POSIX-portable make features.
|
||||
|
||||
--- libpolyml/Makefile.in.orig 2009-10-06 12:14:17.000000000 +0400
|
||||
+++ libpolyml/Makefile.in 2009-12-02 02:36:48.000000000 +0300
|
||||
@@ -744,7 +744,7 @@
|
||||
|
||||
# Special rule for x86 assembly code.
|
||||
x86asmtemp.S: x86asm.asm
|
||||
- sed -f $(srcdir)/masm2gas < $< > $@ || { rm -f $@; false; }
|
||||
+ sed -f $(srcdir)/masm2gas < x86asm.asm > $@ || { rm -f $@; false; }
|
||||
|
||||
# Special rule for Power PC. This is needed because of pecularities with MAC OS X.
|
||||
ppcasmtemp.s: power_assembly.S
|
18
lang/polyml/patches/patch-libpolyml_elfexport.cpp
Normal file
18
lang/polyml/patches/patch-libpolyml_elfexport.cpp
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-libpolyml_elfexport.cpp,v 1.1 2012/03/22 20:48:45 asau Exp $
|
||||
|
||||
--- libpolyml/elfexport.cpp.orig 2010-04-14 22:13:42.000000000 +0000
|
||||
+++ libpolyml/elfexport.cpp
|
||||
@@ -62,6 +62,13 @@
|
||||
#ifdef HAVE_SYS_ELF_386_H
|
||||
#include <sys/elf_386.h>
|
||||
#endif
|
||||
+#if defined(__NetBSD__) && defined(HOSTARCHITECTURE_X86_64)
|
||||
+#include <i386/elf_machdep.h>
|
||||
+#endif
|
||||
+#if defined(__DragonFly__) && (defined(HOSTARCHITECTURE_X86) || defined(HOSTARCHITECTURE_X86_64))
|
||||
+/* Missing definition taken from NetBSD: */
|
||||
+#define R_386_PC32 2
|
||||
+#endif
|
||||
#ifdef HAVE_STRING_H
|
||||
#include <string.h>
|
||||
#endif
|
Loading…
Reference in a new issue