Update to KDE SC 4.8.0

This commit is contained in:
markd 2012-03-19 11:28:48 +00:00
parent 3b2e39bd37
commit 26c5764deb
29 changed files with 1797 additions and 1193 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.36 2012/03/03 00:11:52 wiz Exp $
# $NetBSD: Makefile,v 1.37 2012/03/19 11:28:48 markd Exp $
DISTNAME= kdelibs-${_KDE_VERSION}
PKGREVISION= 12
PKGNAME= ${DISTNAME:S/-4/4-4/}
CATEGORIES= x11
COMMENT= Support libraries for the KDE integrated X11 desktop
@ -17,7 +17,7 @@ CONFLICTS= kdelibs-[0-9]*
CMAKE_DEPENDENCIES_REWRITE= _KDE_build/KDELibsDependencies.cmake
CMAKE_DEPENDENCIES_REWRITE+= _KDE_build/KDELibsDependenciesInternal.cmake
CMAKE_MODULE_PATH_OVERRIDE+= kjsembed/qtonly/CMakeLists.txt
CMAKE_MODULE_PATH_OVERRIDE+= kjsembed/qtonly/CMakeLists.txt
CMAKE_ARGS+= -DKDE_DISTRIBUTION_TEXT:STRING="NetBSD pkgsrc"
CMAKE_ARGS+= -DWITH_Avahi:BOOL=off
@ -50,12 +50,17 @@ SUBST_STAGE.kdelibsfix= pre-configure
SUBST_MESSAGE.kdelibsfix= Fixing hardcoded paths.
SUBST_FILES.kdelibsfix= \
kde3support/kdeui/k3sconfig.cpp \
kdeui/colors/kcolordialog.cpp \
kio/kssl/kopenssl.cpp
SUBST_SED.kdelibsfix= -e 's:@LOCALBASE@:${LOCALBASE}:g' -e 's:@X11BASE@:${X11BASE}:g'
SUBST_SED.kdelibsfix= -e 's:@LOCALBASE@:${LOCALBASE}:g'
# XXX this is an ugly hack to avoid the WRKDIR path in the installed cmake file
SUBST_CLASSES+= phononrelpath
SUBST_STAGE.phononrelpath= post-configure
SUBST_MESSAGE.phononrelpath= Fixing phonon RELWITHDEBINFO path
SUBST_FILES.phononrelpath= _KDE_build/CMakeFiles/Export/_usr/pkg/share/kde/apps/cmake/modules/KDELibs4LibraryTargets-relwithdebinfo.cmake
SUBST_SED.phononrelpath= -e 's:[^"]*/\.buildlink/lib/libphonon\.so::'
USE_TOOLS+= flex gmake
PLIST_VARS+= kgrantpty
.include "../../mk/bsd.prefs.mk"
@ -64,24 +69,19 @@ PLIST_VARS+= kgrantpty
DEPENDS+= zonetab-[0-9]*:../../time/zonetab
.endif
.if ${OPSYS} == "SunOS"
PLIST.kgrantpty= yes
.endif
LDFLAGS.SunOS+= -lintl
BUILDLINK_DEPMETHOD.qt4-tools= full
.include "../../meta-pkgs/kde4/kde4.mk"
BUILDLINK_API_DEPENDS.strigi+= strigi>=0.5.11
BUILDLINK_API_DEPENDS.soprano+= soprano>=2.3.0
BUILDLINK_API_DEPENDS.shared-desktop-ontologies+= shared-desktop-ontologies>=0.4
BUILDLINK_API_DEPENDS.soprano+= soprano>=2.5.60
BUILDLINK_API_DEPENDS.shared-desktop-ontologies+= shared-desktop-ontologies>=0.6.5
.include "../../archivers/bzip2/buildlink3.mk"
.include "../../archivers/xz/buildlink3.mk"
.include "../../sysutils/strigi/buildlink3.mk"
.include "../../textproc/soprano/buildlink3.mk"
.include "../../databases/shared-mime-info/buildlink3.mk"
.include "../../devel/libdbusmenu-qt/buildlink3.mk"
.include "../../devel/pcre/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
@ -93,12 +93,11 @@ BUILDLINK_API_DEPENDS.shared-desktop-ontologies+= shared-desktop-ontologies>=0.4
.include "../../multimedia/phonon/buildlink3.mk"
# Avahi ? rather than mDNSResponder
.include "../../devel/libdbusmenu-qt/buildlink3.mk"
.include "../../mk/fam.buildlink3.mk"
.include "../../net/mDNSResponder/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../security/polkit-qt/buildlink3.mk"
.include "../../security/qca2/buildlink3.mk"
.include "../../mk/fam.buildlink3.mk"
.include "../../textproc/aspell/buildlink3.mk"
.include "../../textproc/enchant/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
@ -108,6 +107,6 @@ BUILDLINK_API_DEPENDS.shared-desktop-ontologies+= shared-desktop-ontologies>=0.4
.include "../../x11/libXinerama/buildlink3.mk"
.include "../../x11/libXpm/buildlink3.mk"
.include "../../x11/libXtst/buildlink3.mk"
.include "../../mk/krb5.buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/bsd.pkg.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.16 2012/03/03 00:11:52 wiz Exp $
# $NetBSD: buildlink3.mk,v 1.17 2012/03/19 11:28:48 markd Exp $
BUILDLINK_TREE+= kdelibs
@ -10,8 +10,8 @@ BUILDLINK_ABI_DEPENDS.kdelibs?= kdelibs4>=4.5.5nb12
BUILDLINK_PKGSRCDIR.kdelibs?= ../../x11/kdelibs4
.include "../../archivers/bzip2/buildlink3.mk"
.include "../../devel/libdbusmenu-qt/buildlink3.mk"
.include "../../databases/shared-mime-info/buildlink3.mk"
.include "../../devel/libdbusmenu-qt/buildlink3.mk"
.include "../../devel/pcre/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/jasper/buildlink3.mk"

View file

@ -1,26 +1,18 @@
$NetBSD: distinfo,v 1.23 2012/01/23 08:14:02 joerg Exp $
$NetBSD: distinfo,v 1.24 2012/03/19 11:28:48 markd Exp $
SHA1 (kdelibs-4.5.5.tar.bz2) = 127a2b50fe31ff345e05660dd50f7c55ae78d854
RMD160 (kdelibs-4.5.5.tar.bz2) = 7c33afa12379119fbf7d70e8895c3f2ada9a2eba
Size (kdelibs-4.5.5.tar.bz2) = 13876521 bytes
SHA1 (patch-aa) = 7146107f78bbc618cf80479195581f29fc6b5977
SHA1 (patch-ab) = aec1140bef01199f067b079c30d95fea1814839d
SHA1 (patch-ac) = 55027a8e6502a938da7a7930e079b3ce21ad2322
SHA1 (patch-ad) = 2a0dfd3dda071654c89b8dda3db8885e2a55ba2b
SHA1 (patch-ag) = af1e58512984726a4efaf315bb958a9a529638b8
SHA1 (patch-ah) = b583dbe1b712984bbe002cc9143352729fba94ed
SHA1 (patch-aj) = 8520c322d4579e9485253c8e8b130669b0f8b618
SHA1 (patch-ak) = 03883c05a2a600737d98a889034a2fb9984a5d58
SHA1 (patch-al) = a3c48e8552ca39496134696f3d415a7b6a4db7d8
SHA1 (patch-am) = da04e0450885dc4bca38a4e9b91822746d936639
SHA1 (patch-an) = b5fe924970772bd8a5b420f8cc638ab8bf892c53
SHA1 (patch-cmake_modules_FindTaglib.cmake) = 97baf0e5c9f53a17582d89ee41cb4d99fbd15424
SHA1 (patch-kdeui_colors_kcolordialog.cpp) = f105006a778c42a93452fc4bf5d561aa62595a5c
SHA1 (patch-khtml_khtml_part.cpp) = f8f5977b03463b6de909881178abed3ba351364c
SHA1 (patch-kio_kio_scheduler.cpp) = a32f9dadf021115a819d4ff94bf63e6ee109c965
SHA1 (patch-kio_kio_scheduler.h) = b09d3fba61f68685037a6cfa62b58ab768de71c1
SHA1 (patch-kio_kssl_ksslcertificatebox.cpp) = 1f187968a49e251fbdbbf2569e4703ac05b474be
SHA1 (patch-kioslave_http_http.cpp) = abd6446120fab21cd30da3e9e1fdc00218802d89
SHA1 (patch-kjs_JSImmediate.h) = 29949739140d766362d308ece28c96aef593ed73
SHA1 (patch-kjs_lookup.h) = 7a66c3e79d8177cf46579e153fbafb0b1cae9551
SHA1 (patch-kjs_wtf_RefPtr.h) = ecf999e97edebdb53edeeffeee6200305ddacc3e
SHA1 (kdelibs-4.8.0.tar.bz2) = 5e4744405734e6c3ce572ef7d16054390692b38a
RMD160 (kdelibs-4.8.0.tar.bz2) = b5fd03eec81a390ea74d4713d6459b685352d362
Size (kdelibs-4.8.0.tar.bz2) = 13044553 bytes
SHA1 (patch-aa) = c3044205a964797a7718b7a7bd03bb99dd3ca37d
SHA1 (patch-ab) = 3f89ddfa9a6101a016128d82dbbd0e985e396cae
SHA1 (patch-ac) = 200391c0cf0a89ef43f0cb57e39d56eee51da505
SHA1 (patch-ad) = 08467b484f3df864d343d9151b13bedc4f001976
SHA1 (patch-ag) = 67561007567ba10f20d8e8572dd0a33c8139b7cd
SHA1 (patch-ah) = 368f4f641ce55257409137185357e796666ae42f
SHA1 (patch-aj) = 501e34c8fdf242c3718ecb26577ac5940d37fae5
SHA1 (patch-ak) = 73cc1bb149039d2fe3c05ee631426a8773f951c6
SHA1 (patch-al) = 5efa7d504fe75bec53837bfa062a4b3f910fd71f
SHA1 (patch-am) = b6c315d152d2c3d3c66ad85050549d0b39b263e5
SHA1 (patch-cmake_modules_FindTaglib.cmake) = be38479966da542343dd962c57f7e9d1be3e9ff4
SHA1 (patch-kdecore_localization_klocale_kde.cpp) = b8a513a0c51e65d7e604a88c1d0e3325be6ad688
SHA1 (patch-kdecore_util_kshareddatacache_p.h) = 6d064fe75fbecd489b0343960333864c717c0805

File diff suppressed because it is too large Load diff

10
x11/kdelibs4/hacks.mk Normal file
View file

@ -0,0 +1,10 @@
# $NetBSD: hacks.mk,v 1.1 2012/03/19 11:28:48 markd Exp $
.if ${OPSYS} == "NetBSD"
post-configure:
cp ${FILESDIR}/kshareddatacache.cpp ${WRKSRC}/kdecore/util/kshareddatacache.cpp
.endif
# fix up buildlinks failure to build link tree correctly
post-wrapper:
ln -s netbsd-g++ ${BUILDLINK_DIR}/qt4/mkspecs/default

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.1.1.1 2009/10/02 19:19:00 markd Exp $
$NetBSD: patch-aa,v 1.2 2012/03/19 11:28:49 markd Exp $
--- kded/CMakeLists.txt.orig 2008-12-11 05:12:28.000000000 +1300
--- kded/CMakeLists.txt.orig 2011-04-01 13:55:50.000000000 +0000
+++ kded/CMakeLists.txt
@@ -69,7 +69,7 @@ install(TARGETS kdontchangethehostname D
@@ -74,7 +74,7 @@ install(TARGETS kbuildsycoca4 ${INSTALL_
if (WIN32)
install( FILES applications.menu DESTINATION ${SHARE_INSTALL_PREFIX}/xdg/menus )
else (WIN32)

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.1.1.1 2009/10/02 19:19:00 markd Exp $
$NetBSD: patch-ab,v 1.2 2012/03/19 11:28:49 markd Exp $
--- kinit/autostart.cpp.orig 2008-02-28 00:58:51.000000000 +1300
--- kinit/autostart.cpp.orig 2011-04-01 13:55:51.000000000 +0000
+++ kinit/autostart.cpp
@@ -40,7 +40,7 @@ AutoStart::AutoStart()
@@ -39,7 +39,7 @@ AutoStart::AutoStart()
m_startList = new AutoStartList;
KGlobal::dirs()->addResourceType("xdgconf-autostart", NULL, "autostart/"); // xdg ones
KGlobal::dirs()->addResourceType("autostart", "xdgconf-autostart", "/"); // merge them

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ac,v 1.3 2010/04/10 02:45:05 markd Exp $
$NetBSD: patch-ac,v 1.4 2012/03/19 11:28:49 markd Exp $
--- kio/kssl/kopenssl.cpp.orig 2009-11-13 10:59:08.000000000 +0000
--- kio/kssl/kopenssl.cpp.orig 2011-04-01 13:55:51.000000000 +0000
+++ kio/kssl/kopenssl.cpp
@@ -236,7 +236,7 @@ void KOpenSSLProxy::destroy() {
delete x;

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.1.1.1 2009/10/02 19:19:00 markd Exp $
$NetBSD: patch-ad,v 1.2 2012/03/19 11:28:49 markd Exp $
--- kde3support/kdeui/k3sconfig.cpp.orig 2007-10-08 20:41:19.000000000 +1300
--- kde3support/kdeui/k3sconfig.cpp.orig 2011-04-01 13:55:50.000000000 +0000
+++ kde3support/kdeui/k3sconfig.cpp
@@ -464,6 +464,8 @@ void K3SpellConfig::getAvailDictsIspell
@@ -470,6 +470,8 @@ void K3SpellConfig::getAvailDictsIspell
// dictionary path
QFileInfo dir ("/usr/lib/ispell");
if (!dir.exists() || !dir.isDir())
@ -11,7 +11,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2009/10/02 19:19:00 markd Exp $
dir.setFile ("/usr/local/lib/ispell");
if (!dir.exists() || !dir.isDir())
dir.setFile ("/usr/local/share/ispell");
@@ -536,6 +538,8 @@ void K3SpellConfig::getAvailDictsAspell
@@ -542,6 +544,8 @@ void K3SpellConfig::getAvailDictsAspell
if (!dir.exists() || !dir.isDir())
dir.setFile ("/usr/lib" KDELIBSUFF "/aspell-0.60");
if (!dir.exists() || !dir.isDir())
@ -20,7 +20,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2009/10/02 19:19:00 markd Exp $
dir.setFile ("/usr/local/lib" KDELIBSUFF "/aspell");
if (!dir.exists() || !dir.isDir())
dir.setFile ("/usr/share/aspell");
@@ -620,6 +624,8 @@ K3SpellConfig::fillDicts( QComboBox* box
@@ -683,6 +687,8 @@ K3SpellConfig::fillDicts( QComboBox* box
// dictionary path
QFileInfo dir ("/usr/lib/ispell");
if (!dir.exists() || !dir.isDir())
@ -29,7 +29,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2009/10/02 19:19:00 markd Exp $
dir.setFile ("/usr/local/lib/ispell");
if (!dir.exists() || !dir.isDir())
dir.setFile ("/usr/local/share/ispell");
@@ -698,6 +704,8 @@ K3SpellConfig::fillDicts( QComboBox* box
@@ -760,6 +766,8 @@ K3SpellConfig::fillDicts( QComboBox* box
if (!dir.exists() || !dir.isDir())
dir.setFile ("/usr/lib" KDELIBSUFF "/aspell-0.60");
if (!dir.exists() || !dir.isDir())

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ag,v 1.1.1.1 2009/10/02 19:19:00 markd Exp $
$NetBSD: patch-ag,v 1.2 2012/03/19 11:28:49 markd Exp $
--- security/crypto/crypto.cpp.orig 2008-05-01 22:16:43.000000000 +1200
--- security/crypto/crypto.cpp.orig 2011-04-01 13:55:51.000000000 +0000
+++ security/crypto/crypto.cpp
@@ -2247,7 +2247,11 @@ bool KCryptoConfig::loadCiphers() {
@@ -2303,7 +2303,11 @@ bool KCryptoConfig::loadCiphers() {
unsigned int i;
SSL_CTX *ctx;
SSL *ssl;

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ah,v 1.1.1.1 2009/10/02 19:19:00 markd Exp $
$NetBSD: patch-ah,v 1.2 2012/03/19 11:28:49 markd Exp $
--- kpty/kptydevice.cpp.orig 2008-12-04 21:36:01.000000000 +1300
--- kpty/kptydevice.cpp.orig 2011-04-01 13:55:51.000000000 +0000
+++ kpty/kptydevice.cpp
@@ -42,7 +42,7 @@
@@ -44,7 +44,7 @@
# include <sys/time.h>
#endif

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aj,v 1.1.1.1 2009/10/02 19:19:00 markd Exp $
$NetBSD: patch-aj,v 1.2 2012/03/19 11:28:49 markd Exp $
From https://bugs.kde.org/show_bug.cgi?id=193215
--- kio/kssl/ksmimecrypto.cpp.orig 2008-05-21 23:08:14.000000000 +1200
--- kio/kssl/ksmimecrypto.cpp.orig 2011-04-01 13:55:51.000000000 +0000
+++ kio/kssl/ksmimecrypto.cpp
@@ -86,7 +86,7 @@ KSMIMECryptoPrivate::KSMIMECryptoPrivate

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ak,v 1.3 2010/04/11 13:55:49 markd Exp $
$NetBSD: patch-ak,v 1.4 2012/03/19 11:28:49 markd Exp $
--- kdecore/auth/ConfigureChecks.cmake.orig 2010-03-26 17:24:30.000000000 +0000
--- kdecore/auth/ConfigureChecks.cmake.orig 2011-04-01 13:55:50.000000000 +0000
+++ kdecore/auth/ConfigureChecks.cmake
@@ -198,7 +198,7 @@ if(KDE4_AUTH_HELPER_BACKEND_NAME STREQUA
@@ -202,7 +202,7 @@ if(KDE4_AUTH_HELPER_BACKEND_NAME STREQUA
# Install some files as well
install( FILES auth/backends/dbus/org.kde.auth.conf

View file

@ -1,8 +1,8 @@
$NetBSD: patch-al,v 1.1 2010/04/11 13:55:49 markd Exp $
$NetBSD: patch-al,v 1.2 2012/03/19 11:28:49 markd Exp $
--- cmake/modules/KDE4Macros.cmake.orig 2010-03-26 17:24:24.000000000 +0000
--- cmake/modules/KDE4Macros.cmake.orig 2011-04-01 13:55:50.000000000 +0000
+++ cmake/modules/KDE4Macros.cmake
@@ -1254,7 +1254,7 @@ function(KDE4_INSTALL_AUTH_HELPER_FILES
@@ -1293,7 +1293,7 @@ function(KDE4_INSTALL_AUTH_HELPER_FILES
configure_file(${_stubFilesDir}/dbus_policy.stub
${CMAKE_CURRENT_BINARY_DIR}/${HELPER_ID}.conf)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${HELPER_ID}.conf

View file

@ -1,6 +1,6 @@
$NetBSD: patch-am,v 1.1 2010/06/06 22:44:02 markd Exp $
$NetBSD: patch-am,v 1.2 2012/03/19 11:28:49 markd Exp $
--- kdecore/sycoca/ksycoca.cpp.orig 2010-01-19 23:15:27.000000000 +0000
--- kdecore/sycoca/ksycoca.cpp.orig 2011-04-01 13:56:18.000000000 +0000
+++ kdecore/sycoca/ksycoca.cpp
@@ -62,7 +62,7 @@
*/

View file

@ -1,16 +0,0 @@
$NetBSD: patch-an,v 1.2 2010/10/26 11:46:58 markd Exp $
--- kdecore/util/kshareddatacache.cpp.orig 2010-09-30 21:19:05.000000000 +0000
+++ kdecore/util/kshareddatacache.cpp
@@ -307,7 +307,10 @@ struct SharedMemory
// Initialize attributes, enable process-shared primitives, and setup
// the mutex.
if (pthread_mutexattr_init(&mutexAttr) == 0) {
- if (pthread_mutexattr_setpshared(&mutexAttr, PTHREAD_PROCESS_SHARED) != 0 ||
+ if (
+#ifdef _POSIX_THREAD_PROCESS_SHARED
+ pthread_mutexattr_setpshared(&mutexAttr, PTHREAD_PROCESS_SHARED) != 0 ||
+#endif
pthread_mutex_init(&lockMutex, &mutexAttr) != 0)
{
pthread_mutexattr_destroy(&mutexAttr);

View file

@ -1,13 +1,29 @@
$NetBSD: patch-cmake_modules_FindTaglib.cmake,v 1.1 2011/06/04 16:31:52 abs Exp $
$NetBSD: patch-cmake_modules_FindTaglib.cmake,v 1.2 2012/03/19 11:28:49 markd Exp $
--- cmake/modules/FindTaglib.cmake.orig 2008-07-22 00:05:18.000000000 +0000
Change the string comparision operator on the TAGLIB_VERSION to a
version comparision operator (since versions are being compared.)
--- cmake/modules/FindTaglib.cmake.orig 2011-07-27 18:34:31.000000000 +0000
+++ cmake/modules/FindTaglib.cmake
@@ -11,7 +11,7 @@
# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
@@ -29,10 +29,10 @@ if(TAGLIBCONFIG_EXECUTABLE)
if(NOT TAGLIB_MIN_VERSION)
- set(TAGLIB_MIN_VERSION "1.4")
+ set(TAGLIB_MIN_VERSION "1.10")
endif(NOT TAGLIB_MIN_VERSION)
exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --version RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_VERSION)
if(NOT WIN32)
- if(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
+ if(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
message(STATUS "TagLib version not found: version searched :${TAGLIB_MIN_VERSION}, found ${TAGLIB_VERSION}")
set(TAGLIB_FOUND FALSE)
- else(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
+ else(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --libs RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_LIBRARIES)
@@ -43,7 +43,7 @@ if(TAGLIBCONFIG_EXECUTABLE)
message(STATUS "Found taglib: ${TAGLIB_LIBRARIES}")
endif(TAGLIB_LIBRARIES AND TAGLIB_CFLAGS)
string(REGEX REPLACE " *-I" ";" TAGLIB_INCLUDES "${TAGLIB_CFLAGS}")
- endif(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
+ endif(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
mark_as_advanced(TAGLIB_CFLAGS TAGLIB_LIBRARIES TAGLIB_INCLUDES)
else(TAGLIBCONFIG_EXECUTABLE)

View file

@ -0,0 +1,13 @@
$NetBSD: patch-kdecore_localization_klocale_kde.cpp,v 1.1 2012/03/19 11:28:49 markd Exp $
--- kdecore/localization/klocale_kde.cpp.orig 2011-04-01 13:55:50.000000000 +0000
+++ kdecore/localization/klocale_kde.cpp
@@ -2516,7 +2516,7 @@ QByteArray KLocalePrivate::systemCodeset
codeset = nl_langinfo(CODESET);
- if ((codeset == "ANSI_X3.4-1968") || (codeset == "US-ASCII")) {
+ if ((codeset == "ANSI_X3.4-1968") || (codeset == "US-ASCII") || (codeset == "646")) {
// means ascii, "C"; QTextCodec doesn't know, so avoid warning
codeset = "ISO-8859-1";
}

View file

@ -0,0 +1,14 @@
$NetBSD: patch-kdecore_util_kshareddatacache_p.h,v 1.1 2012/03/19 11:28:49 markd Exp $
--- kdecore/util/kshareddatacache_p.h.orig 2011-04-01 13:56:18.000000000 +0000
+++ kdecore/util/kshareddatacache_p.h
@@ -311,7 +311,9 @@ static SharedLockId findBestSharedLock()
sem_t tempSemaphore;
QSharedPointer<KSDCLock> tempLock(0);
if (timeoutsSupported) {
+#ifdef KSDC_TIMEOUTS_SUPPORTED
tempLock = QSharedPointer<KSDCLock>(new semaphoreTimedLock(tempSemaphore));
+#endif
}
else {
tempLock = QSharedPointer<KSDCLock>(new semaphoreLock(tempSemaphore));

View file

@ -1,15 +0,0 @@
$NetBSD: patch-kdeui_colors_kcolordialog.cpp,v 1.1 2011/09/27 10:48:20 markd Exp $
Find rgb.txt in pkgsrc or native
--- kdeui/colors/kcolordialog.cpp.orig 2010-05-27 17:26:18.000000000 +0000
+++ kdeui/colors/kcolordialog.cpp
@@ -627,6 +627,8 @@ static const char * const *namedColorFil
#ifdef X11_RGBFILE
X11_RGBFILE, 0,
#endif
+ "@X11BASE@/share/X11/rgb.txt", 0,
+ "@X11BASE@/lib/X11/rgb.txt", 0,
"/usr/share/X11/rgb.txt", 0,
"/usr/X11R6/lib/X11/rgb.txt", 0,
"/usr/openwin/lib/X11/rgb.txt", 0, // for Solaris.

View file

@ -1,18 +0,0 @@
$NetBSD: patch-khtml_khtml_part.cpp,v 1.1 2011/04/11 10:11:42 markd Exp $
Fix for CVE-2011-1168.
--- khtml/khtml_part.cpp.orig 2010-08-27 08:09:16.000000000 +0000
+++ khtml/khtml_part.cpp
@@ -1803,7 +1803,10 @@ void KHTMLPart::htmlError( int errorCode
stream >> errorName >> techName >> description >> causes >> solutions;
QString url, protocol, datetime;
- url = Qt::escape( reqUrl.prettyUrl() );
+
+ // This is somewhat confusing, but we have to escape the externally-
+ // controlled URL twice: once for i18n, and once for HTML.
+ url = Qt::escape( Qt::escape( reqUrl.prettyUrl() ) );
protocol = reqUrl.protocol();
datetime = KGlobal::locale()->formatDateTime( QDateTime::currentDateTime(),
KLocale::LongDate );

View file

@ -1,41 +0,0 @@
$NetBSD: patch-kio_kio_scheduler.cpp,v 1.1 2012/01/18 22:03:24 abs Exp $
--- kio/kio/scheduler.cpp.orig 2010-07-07 17:08:31.000000000 +0000
+++ kio/kio/scheduler.cpp
@@ -865,6 +865,36 @@ void Scheduler::emitReparseSlaveConfigur
emit self()->reparseSlaveConfiguration( QString() );
}
+void Scheduler::slotSlaveDied(Slave* slave)
+{
+ schedulerPrivate->slotSlaveDied(slave);
+}
+
+void Scheduler::slotSlaveStatus(pid_t pid, const QByteArray& protocol, const QString& host, bool connected)
+{
+ schedulerPrivate->slotSlaveStatus(pid, protocol, host, connected);
+}
+
+void Scheduler::slotReparseSlaveConfiguration(const QString& prot)
+{
+ schedulerPrivate->slotReparseSlaveConfiguration(prot);
+}
+
+void Scheduler::slotSlaveConnected()
+{
+ schedulerPrivate->slotSlaveConnected();
+}
+
+void Scheduler::slotSlaveError(int error, const QString& errorMsg)
+{
+ schedulerPrivate->slotSlaveError(error, errorMsg);
+}
+
+void Scheduler::slotUnregisterWindow(QObject* obj)
+{
+ schedulerPrivate->slotUnregisterWindow(obj);
+}
+
void SchedulerPrivate::slotReparseSlaveConfiguration(const QString &proto)
{

View file

@ -1,38 +0,0 @@
$NetBSD: patch-kio_kio_scheduler.h,v 1.1 2012/01/18 22:03:24 abs Exp $
--- kio/kio/scheduler.h.orig 2010-02-03 08:50:40.000000000 +0000
+++ kio/kio/scheduler.h
@@ -29,6 +29,8 @@
#include <QtGui/QWidgetList>
#include <sys/types.h> // pid_t
+class QDBusMessage;
+
namespace KIO {
class Slave;
@@ -278,16 +280,17 @@ namespace KIO {
static Scheduler *self();
- Q_PRIVATE_SLOT(schedulerPrivate, void slotSlaveDied(KIO::Slave *slave))
- Q_PRIVATE_SLOT(schedulerPrivate, void slotSlaveStatus(pid_t pid, const QByteArray &protocol,
- const QString &host, bool connected))
+ private Q_SLOTS:
+ void slotSlaveDied(KIO::Slave *slave);
+ void slotSlaveStatus(pid_t pid, const QByteArray &protocol,
+ const QString &host, bool connected);
// connected to D-Bus signal:
- Q_PRIVATE_SLOT(schedulerPrivate, void slotReparseSlaveConfiguration(const QString &))
+ void slotReparseSlaveConfiguration(const QString &);
+ void slotSlaveConnected();
+ void slotSlaveError(int error, const QString &errorMsg);
+ void slotUnregisterWindow(QObject *);
- Q_PRIVATE_SLOT(schedulerPrivate, void slotSlaveConnected())
- Q_PRIVATE_SLOT(schedulerPrivate, void slotSlaveError(int error, const QString &errorMsg))
- Q_PRIVATE_SLOT(schedulerPrivate, void slotUnregisterWindow(QObject *))
private:
friend class SchedulerPrivate;
SchedulerPrivate *const d;

View file

@ -1,17 +0,0 @@
$NetBSD: patch-kio_kssl_ksslcertificatebox.cpp,v 1.1 2011/11/20 02:08:10 markd Exp $
don't interpret html tags. KDE Security Advisory 20111003-1
--- kio/kssl/ksslcertificatebox.cpp.orig 2008-05-21 11:08:14.000000000 +0000
+++ kio/kssl/ksslcertificatebox.cpp
@@ -36,6 +36,10 @@ KSslCertificateBox::KSslCertificateBox(Q
d(new KSslCertificateBoxPrivate())
{
d->ui.setupUi(this);
+ // No fooling us with html tags
+ Q_FOREACH(QLabel* label, qFindChildren<QLabel *>(this)) {
+ label->setTextFormat(Qt::PlainText);
+ }
}

View file

@ -1,64 +0,0 @@
$NetBSD: patch-kioslave_http_http.cpp,v 1.1 2011/11/20 02:08:10 markd Exp $
don't interpret html tags. KDE Security Advisory 20111003-1
commit 90607b28d21fefc43657ca08b889bdb174c31fab
Author: David Faure <faure@kde.org>
Date: Wed Sep 28 17:26:47 2011 +0200
Use HTML escaping on texts that come from the website
Interestingly enough, this is yet another use case for moving Qt::escape
to QtCore, which I made a merge request for.
(cherry picked from commit 86622e4db182f4b914169f72ebd1e66d708e9f87)
diff --git a/kioslave/http/http.cpp b/kioslave/http/http.cpp
index 33f4cb1..6447a02 100644
--- kioslave/http/http.cpp
+++ kioslave/http/http.cpp
@@ -99,6 +99,27 @@
//authentication handlers
#include "httpauthentication.cpp"
+// KDE5 TODO (QT5) : use QString::htmlEscape or whatever https://qt.gitorious.org/qt/qtbase/merge_requests/56
+// ends up with.
+static QString htmlEscape(const QString &plain)
+{
+ QString rich;
+ rich.reserve(int(plain.length() * 1.1));
+ for (int i = 0; i < plain.length(); ++i) {
+ if (plain.at(i) == QLatin1Char('<'))
+ rich += QLatin1String("&lt;");
+ else if (plain.at(i) == QLatin1Char('>'))
+ rich += QLatin1String("&gt;");
+ else if (plain.at(i) == QLatin1Char('&'))
+ rich += QLatin1String("&amp;");
+ else if (plain.at(i) == QLatin1Char('"'))
+ rich += QLatin1String("&quot;");
+ else
+ rich += plain.at(i);
+ }
+ rich.squeeze();
+ return rich;
+}
// see filenameFromUrl(): a sha1 hash is 160 bits
static const int s_hashedUrlBits = 160; // this number should always be divisible by eight
@@ -3410,7 +3431,7 @@ endParsing:
authinfo.url = reqUrl;
authinfo.keepPassword = true;
authinfo.comment = i18n("<b>%1</b> at <b>%2</b>",
- authinfo.realmValue, authinfo.url.host());
+ htmlEscape(authinfo.realmValue), authinfo.url.host());
if (!openPasswordDialog(authinfo, errorMsg)) {
if (sendErrorPageNotification()) {
@@ -5122,7 +5143,7 @@ void HTTPProtocol::proxyAuthenticationForSocket(const QNetworkProxy &proxy, QAut
"to access any sites.");
info.keepPassword = true;
info.commentLabel = i18n("Proxy:");
- info.comment = i18n("<b>%1</b> at <b>%2</b>", info.realmValue, m_request.proxyUrl.host());
+ info.comment = i18n("<b>%1</b> at <b>%2</b>", htmlEscape(info.realmValue), m_request.proxyUrl.host());
const bool dataEntered = openPasswordDialog(info, i18n("Proxy Authentication Failed."));
if (!dataEntered) {
kDebug(7103) << "looks like the user canceled proxy authentication.";

View file

@ -1,11 +0,0 @@
--- kjs/JSImmediate.h.orig 2010-05-16 22:04:04.000000000 +0200
+++ kjs/JSImmediate.h 2011-10-24 17:26:02.608429864 +0200
@@ -33,7 +33,7 @@
#endif
#include <stdlib.h>
-#if PLATFORM(SOLARIS_OS)
+#if PLATFORM(SOLARIS_OS) && COMPILER(GCC) && (__GNUC__ <= 4 && __GNUC_MINOR__ < 6)
static inline int signbit(double x)
{
return (x<0.0) ? 1 : 0;

View file

@ -1,12 +0,0 @@
$NetBSD: patch-kjs_lookup.h,v 1.1 2012/01/23 08:14:02 joerg Exp $
--- kjs/lookup.h.orig 2012-01-22 20:17:34.000000000 +0000
+++ kjs/lookup.h
@@ -23,6 +23,7 @@
#ifndef _KJSLOOKUP_H_
#define _KJSLOOKUP_H_
+#include "JSVariableObject.h"
#include "interpreter.h"
#include "identifier.h"
#include "object.h"

View file

@ -1,12 +0,0 @@
$NetBSD: patch-kjs_wtf_RefPtr.h,v 1.1 2012/01/23 08:14:02 joerg Exp $
--- kjs/wtf/RefPtr.h.orig 2012-01-22 20:08:54.000000000 +0000
+++ kjs/wtf/RefPtr.h
@@ -24,6 +24,7 @@
#include <algorithm>
#include "AlwaysInline.h"
+#include "PassRefPtr.h"
namespace WTF {