Update to 0.8.10, provided by Min Sik Kim in PR pkg/24049.

Changes since 0.8:


* 0.8.1 Major feature enhancement masked as minor number release
	+ added real Microsoft-like $FIftiMain index-based
	global search. The searches are as fast as possible now.
	- removed the 'Case sensitive' checkbox because index
	search can't use it anyway.
	+ added support for 'javascript:fullSize' URLs.
	+ beautified the font dialog a bit.
	+ fixed empty title in the titlebar bug.
	+ refined the synchronization between the contents tree and
	the wxHtmlWindow displayed page.


* 0.8.2 Bug fixes and improvements:
	+ added 'find in page' code (wxWindows 2.5.x only).
	+ added 'copy text' code (wxWindows 2.5 only).
	+ added a 'find in page' dialog that hopefully pops up
	on Ctrl-F :) (wxWindows 2.5.x only)
	+ added a popup menu with common options (back, forward,
	copy selection, find in page) that pops up when the user
	right clicks the HTML window.
	+ beautified the tree control and enabled variable sizes
	for the tree items.


* 0.8.3 Bug fixes:
	+ fixed a relative path bug (i.e. for file paths like
	../directory/file) both for HTML pages and images (had to
	override wxHtmlWindow::OnOpeningURL()).
	+ made the fonts change if necessary so that alternative
	encodings can be used (such as Russian or Chinese).


* 0.8.4 Minor bugfix:
	+ corrected a bug that crashed xchm if the user tried
	to open a .chm file that is not present on disk.


* 0.8.5 Major bugfixes:
	+ made xCHM properly handle weird charset languages
	(Russian, Chinese) properly even when xCHM is being linked
	with the GTK2/Unicode version of wxWindows.


* 0.8.6 Minor bugfixes:
	+ corrected a bug that made xCHM refuse to load pages
	with /absolute/paths.
	+ corrected a bug that made xCHM refuse to load pages
	with ./in/current/dir paths.


* 0.8.7 Minor feature enhancements:
	+ the contents panel sash position persists between sessions.
	+ decreased the default application font size from 14 to 12.
	+ added opened files history support.


* 0.8.8 Major feature enhancements:
	+ all the wxListBox widgets have been replaced with
	wxListCtrl derived controls.
	+ added real-time searchable index support via a new 'Index'
	panel (status / selected index word changes as you type).
	+ suppressed unhelpful error messages while loading a page.
	+ hacked around wxWindows file system handler bug.
	GetMimeTypeFromExt() couldn't figure out that pages that
	ended in ".HTM" (as opposed to lowercase ".htm") are of
	"text/html" MIME type.


* 0.8.9 Bugfix release:
	+ checking for the u_intXX_t types with autoconf.
	+ the detection of the book title, home page, index
	and contents files is reliable.
	+ applied FreeBSD port patch.


* 0.8.10 Bugfix / enhancements release:
	+ fixed a horizontal scrollbar repainting bug that occured
	in the search and index tabs.
	+ added Chanler White Mac OS X patch to be able to launch
	open a .chm file by double-clicking on it on Mac OS X.
This commit is contained in:
xtraeme 2004-01-14 01:59:54 +00:00
parent 5ec190a6b3
commit 26d96e2364
3 changed files with 19 additions and 6 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.3 2004/01/10 14:25:42 recht Exp $
# $NetBSD: Makefile,v 1.4 2004/01/14 01:59:54 xtraeme Exp $
#
DISTNAME= xchm-0.8
PKGREVISION= 2
DISTNAME= xchm-0.8.10
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xchm/}

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/01/06 15:36:18 wiz Exp $
$NetBSD: distinfo,v 1.2 2004/01/14 01:59:54 xtraeme Exp $
SHA1 (xchm-0.8.tar.gz) = 3bb2df138e7db4c2cb216c69574ad0fefd7ff1d5
Size (xchm-0.8.tar.gz) = 103893 bytes
SHA1 (xchm-0.8.10.tar.gz) = a5ace834258a0ecc596d286fd13397f107218e1c
Size (xchm-0.8.10.tar.gz) = 118834 bytes
SHA1 (patch-aa) = f40c371db038b66f896b17bf0f510e1d4f819249

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2004/01/14 01:59:54 xtraeme Exp $
--- configure.orig 2004-01-14 02:51:24.000000000 +0100
+++ configure 2004-01-14 02:51:41.000000000 +0100
@@ -1515,7 +1515,7 @@
fi
REZ_FLAGS="`$WX_CONFIG_PATH --rezflags`"
-if test "x$REZ_FLAGS" == "x" -o "x$REZ_FLAGS" == "x#"; then
+if test "x$REZ_FLAGS" = "x" -o "x$REZ_FLAGS" = "x#"; then
REZ_COMMAND=""
else
REZ_COMMAND="$REZ_FLAGS xchm"