Fix installation with gcc3.
Install documentation into share/doc instead of share/doc/html. Add missing files to PLIST. Bump PKGREVISION to 2.
This commit is contained in:
parent
d80b7341c4
commit
26e1898141
4 changed files with 40 additions and 19 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.4 2004/02/26 22:44:09 abs Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2004/09/10 20:23:46 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= DQS-3.3.2
|
||||
PKGNAME= dqs-3.3.2
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= parallel
|
||||
MASTER_SITES= http://www.go.dlr.de/fresh/unix/src/misc/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -14,7 +14,7 @@ COMMENT= Distributed queueing system
|
|||
|
||||
WRKSRC= ${WRKDIR}/DQS3
|
||||
USE_PKGINSTALL= yes
|
||||
DOCDIR= ${PREFIX}/share/doc/html/dqs
|
||||
DOCDIR= ${PREFIX}/share/doc/dqs
|
||||
DOCS= Image16.gif Image17.gif Image18.gif Image19.gif Image20.gif \
|
||||
Image21.gif Image22.gif Image23.gif InstMaint.html \
|
||||
Refernce.html UserGuide.html error_msg.htm
|
||||
|
|
|
@ -1,4 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2004/02/26 22:44:09 abs Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2004/09/10 20:23:46 wiz Exp $
|
||||
bin/PVM_CLEAN
|
||||
bin/dqs_times332
|
||||
bin/dqs_execd332
|
||||
bin/dqs_options332
|
||||
bin/dqs_random332
|
||||
|
@ -13,18 +15,20 @@ bin/qmove332
|
|||
bin/qrls332
|
||||
bin/qstat332
|
||||
bin/qsub332
|
||||
share/doc/html/dqs/Image16.gif
|
||||
share/doc/html/dqs/Image17.gif
|
||||
share/doc/html/dqs/Image18.gif
|
||||
share/doc/html/dqs/Image19.gif
|
||||
share/doc/html/dqs/Image20.gif
|
||||
share/doc/html/dqs/Image21.gif
|
||||
share/doc/html/dqs/Image22.gif
|
||||
share/doc/html/dqs/Image23.gif
|
||||
share/doc/html/dqs/InstMaint.html
|
||||
share/doc/html/dqs/Refernce.html
|
||||
share/doc/html/dqs/UserGuide.html
|
||||
share/doc/html/dqs/error_msg.htm
|
||||
share/doc/dqs/Image16.gif
|
||||
share/doc/dqs/Image17.gif
|
||||
share/doc/dqs/Image18.gif
|
||||
share/doc/dqs/Image19.gif
|
||||
share/doc/dqs/Image20.gif
|
||||
share/doc/dqs/Image21.gif
|
||||
share/doc/dqs/Image22.gif
|
||||
share/doc/dqs/Image23.gif
|
||||
share/doc/dqs/InstMaint.html
|
||||
share/doc/dqs/Refernce.html
|
||||
share/doc/dqs/UserGuide.html
|
||||
share/doc/dqs/error_msg.htm
|
||||
share/examples/dqs/conf_file
|
||||
share/examples/dqs/key_file
|
||||
share/examples/dqs/resolve_file
|
||||
@dirrm share/examples/dqs
|
||||
@dirrm share/doc/dqs
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.3 2004/07/10 15:14:57 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.4 2004/09/10 20:23:46 wiz Exp $
|
||||
|
||||
SHA1 (DQS-3.3.2.tgz) = fbb165cc058dcbda8bcfa6dbead78e2f1a4f031e
|
||||
Size (DQS-3.3.2.tgz) = 1498996 bytes
|
||||
|
@ -7,4 +7,4 @@ SHA1 (patch-ab) = c3b1c4561f450b5c0628eb4d84f40c7850c1fb84
|
|||
SHA1 (patch-ac) = d6aee87bc936376a9023a80990af77578cdf9552
|
||||
SHA1 (patch-ad) = dcc151f4648da1beabe9191e77e25c8792a65391
|
||||
SHA1 (patch-ae) = d048393c1a6c98e66049aeca67ffda49d6e40593
|
||||
SHA1 (patch-af) = 3fa9dbf3a57b0b82c8cffb3db2534a7fe51bab41
|
||||
SHA1 (patch-af) = ede6336939be8f2c8dd7d5a13f96f6e5b40b5a41
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-af,v 1.1 2004/07/10 15:14:57 wiz Exp $
|
||||
$NetBSD: patch-af,v 1.2 2004/09/10 20:23:46 wiz Exp $
|
||||
|
||||
--- SRC/Makefile.orig 1999-07-02 17:06:53.000000000 +0200
|
||||
+++ SRC/Makefile
|
||||
|
@ -11,3 +11,20 @@ $NetBSD: patch-af,v 1.1 2004/07/10 15:14:57 wiz Exp $
|
|||
# rm -f Makefile.c
|
||||
@$(MAKE) -f Makefile.typ $@
|
||||
|
||||
@@ -123,14 +123,14 @@ clean :
|
||||
rm -f Makefile.c
|
||||
cp $(PROTO) Makefile.c
|
||||
echo "#define `../UTIL/config.guess 1`" | sed s/\\./_/g | sed s/-/_/g > Makefile.h
|
||||
- $(CC) -E Makefile.c | sed 's/\/ /\//g' | sed 's/ \//\//g' | sed 's/ ( BIN_DIR )/(BIN_DIR)/g' > Makefile.typ
|
||||
+ $(CC) -E Makefile.c | sed 's/ / /g' | sed 's/\/ /\//g' | sed 's/ \//\//g' | sed 's/ ( BIN_DIR )/(BIN_DIR)/g' > Makefile.typ
|
||||
@$(MAKE) -f Makefile.typ $@
|
||||
|
||||
.DEFAULT :
|
||||
rm -f Makefile.c
|
||||
cp $(PROTO) Makefile.c
|
||||
echo "#define `../UTIL/config.guess`" | sed s/\\./_/g | sed s/-/_/g > Makefile.h
|
||||
- $(CC) -E Makefile.c | sed 's/\/ /\//g' | sed 's/ \//\//g' | sed 's/ ( BIN_DIR )/(BIN_DIR)/g' > Makefile.typ
|
||||
+ $(CC) -E Makefile.c | sed 's/ / /g' | sed 's/\/ /\//g' | sed 's/ \//\//g' | sed 's/ ( BIN_DIR )/(BIN_DIR)/g' > Makefile.typ
|
||||
# rm -f Makefile.c
|
||||
@$(MAKE) -f Makefile.typ $@
|
||||
|
||||
|
|
Loading…
Reference in a new issue