net/bind912: fix an error when reloading configuration
Fix an error when reloading configuration. There is on more check to "directory" in option statement is writable. Bump PKGREVISION.
This commit is contained in:
parent
d415557a81
commit
26e33d0ad9
3 changed files with 23 additions and 6 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.10 2019/04/30 02:46:16 taca Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2019/05/02 13:31:07 taca Exp $
|
||||
|
||||
DISTNAME= bind-${BIND_VERSION}
|
||||
PKGNAME= ${DISTNAME:S/-P/pl/}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.isc.org/isc/bind9/${BIND_VERSION}/
|
||||
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.7 2019/04/30 02:46:16 taca Exp $
|
||||
$NetBSD: distinfo,v 1.8 2019/05/02 13:31:07 taca Exp $
|
||||
|
||||
SHA1 (bind-9.12.4-P1.tar.gz) = e1406e294aee810e32f93d60bd45b15b5d1f76e9
|
||||
RMD160 (bind-9.12.4-P1.tar.gz) = b656fbd38b80fc59bcd592803671e80825e6e24a
|
||||
SHA512 (bind-9.12.4-P1.tar.gz) = 1c07f6e10cb9fd499c4231e8290da94da1f5f4294c664635eac82bdb10be9a01119208fe2c15f5d28f50e3c2cdec7b553851b7676b65792f3f21de071587297d
|
||||
Size (bind-9.12.4-P1.tar.gz) = 7914907 bytes
|
||||
SHA1 (patch-bin_named_server.c) = dee624cc8a664abe74959ab40cea53d85872f672
|
||||
SHA1 (patch-bin_named_server.c) = fc54c9014104bfb0c73ec59e2a490de51a5e5b78
|
||||
SHA1 (patch-bin_pkcs11_pkcs11-keygen.c) = d953bf48aadcdf7e95975d335167cc50f54ef91e
|
||||
SHA1 (patch-bin_tests_system_metadata_tests.sh) = d01a492d0b7738760bdbff714248e279a78fef28
|
||||
SHA1 (patch-config.threads.in) = 8341bdb11888d3efdde5f115de91b1f46aa40bd0
|
||||
|
|
|
@ -1,11 +1,27 @@
|
|||
$NetBSD: patch-bin_named_server.c,v 1.1 2019/04/30 02:46:16 taca Exp $
|
||||
$NetBSD: patch-bin_named_server.c,v 1.2 2019/05/02 13:31:07 taca Exp $
|
||||
|
||||
* Disable checking working directory is writable as BIND_USER in NetBSD
|
||||
base system.
|
||||
|
||||
--- bin/named/server.c.orig 2019-04-06 01:27:27.000000000 +0000
|
||||
+++ bin/named/server.c
|
||||
@@ -8760,6 +8760,7 @@ load_configuration(const char *filename,
|
||||
@@ -6297,6 +6297,7 @@ directory_callback(const char *clausenam
|
||||
"option 'directory' contains relative path '%s'",
|
||||
directory);
|
||||
|
||||
+#if 0
|
||||
if (!isc_file_isdirwritable(directory)) {
|
||||
isc_log_write(named_g_lctx, NAMED_LOGCATEGORY_GENERAL,
|
||||
NAMED_LOGMODULE_SERVER, ISC_LOG_ERROR,
|
||||
@@ -6304,6 +6305,7 @@ directory_callback(const char *clausenam
|
||||
directory);
|
||||
return (ISC_R_NOPERM);
|
||||
}
|
||||
+#endif
|
||||
|
||||
result = isc_dir_chdir(directory);
|
||||
if (result != ISC_R_SUCCESS) {
|
||||
@@ -8760,6 +8762,7 @@ load_configuration(const char *filename,
|
||||
named_os_changeuser();
|
||||
}
|
||||
|
||||
|
@ -13,7 +29,7 @@ $NetBSD: patch-bin_named_server.c,v 1.1 2019/04/30 02:46:16 taca Exp $
|
|||
/*
|
||||
* Check that the working directory is writable.
|
||||
*/
|
||||
@@ -8770,6 +8771,7 @@ load_configuration(const char *filename,
|
||||
@@ -8770,6 +8773,7 @@ load_configuration(const char *filename,
|
||||
result = ISC_R_NOPERM;
|
||||
goto cleanup;
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue