Don't strip -Wl flag on the apxs command line. Bump revision.

This commit is contained in:
joerg 2013-03-02 17:52:33 +00:00
parent f5782f58a1
commit 26f2f87217
3 changed files with 19 additions and 6 deletions

View file

@ -1,11 +1,11 @@
# $NetBSD: Makefile,v 1.203 2012/10/28 06:30:09 asau Exp $
# $NetBSD: Makefile,v 1.204 2013/03/02 17:52:33 joerg Exp $
#
# This pkg does not compile in mod_ssl, only the `mod_ssl EAPI' (a set of
# code hooks that allow mod_ssl to be compiled separately later, if desired).
DISTNAME= apache_1.3.42
PKGNAME= ${DISTNAME:S/_/-/}
PKGREVISION= 3
PKGREVISION= 4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE:=httpd/} \
${MASTER_SITE_APACHE:=httpd/old/}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.62 2012/05/29 20:23:12 joerg Exp $
$NetBSD: distinfo,v 1.63 2013/03/02 17:52:33 joerg Exp $
SHA1 (apache_1.3.42.tar.gz) = b3f8575d855132bc243d79af59ae2a318e7e2c53
RMD160 (apache_1.3.42.tar.gz) = a1573bd04e17cad5d67388cfe08b7f26e06a9ee1
@ -17,7 +17,7 @@ SHA1 (patch-ae) = 1654cdaa58622b7572ab9190928854e80e8c88c7
SHA1 (patch-af) = 4eb5041f2ae8f1d434abbcab416d25739a0979e8
SHA1 (patch-ag) = e29d1d4934a7490e9c51e338375d4d1cc9e93304
SHA1 (patch-ah) = 7c7ad1c09a1c849129313bb272106a1dcd2abf7b
SHA1 (patch-ai) = 80e35b111e3cbdebf5dc7a8265f454caab791f50
SHA1 (patch-ai) = 249dd6367c8a0d31568dd09acf2be6dc49ce9673
SHA1 (patch-aj) = ac7337b51d7d4ca25cef4020961736404ec79f01
SHA1 (patch-ak) = 1be52fb5fca6c05c7cf489de541e0d52383ee43a
SHA1 (patch-al) = 07eb4aab03e646184379d13cdf7176e95f1c1ac8

View file

@ -1,8 +1,21 @@
$NetBSD: patch-ai,v 1.11 2008/02/23 05:16:34 obache Exp $
$NetBSD: patch-ai,v 1.12 2013/03/02 17:52:33 joerg Exp $
--- src/support/apxs.pl.orig 2008-02-23 04:22:56.000000000 +0000
+++ src/support/apxs.pl
@@ -424,8 +424,7 @@ if ($opt_i or $opt_e) {
@@ -371,11 +371,7 @@ if ($opt_c) {
$opt = '';
my ($opt_Wl, $opt_L, $opt_l);
foreach $opt_Wl (@opt_W) {
- if ($CFG_LD_SHLIB !~ m/gcc$/) {
- $opt .= " $1" if ($opt_Wl =~ m|^\s*l,(.*)$|);
- } else {
- $opt .= " -W$opt_Wl";
- }
+ $opt .= " -W$opt_Wl";
}
foreach $opt_L (@opt_L) {
if ($^O ne "MSWin32") {
@@ -424,8 +420,7 @@ if ($opt_i or $opt_e) {
if ($^O ne "MSWin32") {
$t =~ s|^.+/([^/]+)$|$1|;
if ($opt_i) {