meld: update to 3.22.1.

2024-02-18 meld 3.22.1
======================

  Fixes:

   * Work around layout sizing issue (Kai Willadsen)
   * Fix broken search context (t-gergely)
   * Fix issues with pane contents swapping missing warnings and incorrectly
     handling blank or version-controlled panes (Helly Guo)
   * Fix go-to-line accelerator conflict with previous-conflict (Kai Willadsen)
   * Fix unintended requirement on Adwaita cursors (Kai Willadsen)
   * Fix incorrect cut/copy/paste sensitivity on pane change (Kai Willadsen)
   * Fix multi-row selection in folder and version control view (Kai Willadsen)
   * Fix missing pull/push version control icons (Kai Willadsen)
   * Refresh highlighting theme when dark theme preference changes (Kai
     Willadsen)
   * Remove filter and conflict buttons from new comparison tab (Kai Willadsen)
   * Fix scroll not working in file action gutter (Kai Willadsen)
   * Fix line number rendering when changing font sizes (Kai Willadsen)
   * Fix overview map not redrawing on text wrap toggle (Kai Willadsen)
   * Set minimum width for notebook labels (Kai Willadsen)
   * Improve notebook label ellipsization (Kai Willadsen)
   * Fix Meson byte-compilation support with DESTDIR (Kai Willadsen)

   * Issues fixed: #709, #713, #715, #724, #726, #729, #733, #736, #767, #769,
                   #780, #785, #787, #795, #796, #796, #797, #798
This commit is contained in:
wiz 2024-02-25 15:16:04 +00:00
parent a2d6d8e999
commit 26f81bbd01
4 changed files with 8 additions and 40 deletions

View File

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.135 2023/11/14 14:01:38 wiz Exp $
# $NetBSD: Makefile,v 1.136 2024/02/25 15:16:04 wiz Exp $
DISTNAME= meld-3.22.0
PKGREVISION= 11
DISTNAME= meld-3.22.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/meld/${PKGVERSION_NOREV:R}/}
EXTRACT_SUFX= .tar.xz

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.44 2023/07/21 06:54:29 wiz Exp $
@comment $NetBSD: PLIST,v 1.45 2024/02/25 15:16:04 wiz Exp $
bin/meld
${PYSITELIB}/meld/__init__.py
${PYSITELIB}/meld/__init__.pyc
@ -337,6 +337,7 @@ share/locale/hu/LC_MESSAGES/meld.mo
share/locale/id/LC_MESSAGES/meld.mo
share/locale/it/LC_MESSAGES/meld.mo
share/locale/ja/LC_MESSAGES/meld.mo
share/locale/ka/LC_MESSAGES/meld.mo
share/locale/ko/LC_MESSAGES/meld.mo
share/locale/nb/LC_MESSAGES/meld.mo
share/locale/ne/LC_MESSAGES/meld.mo

View File

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.69 2022/12/19 07:09:00 wiz Exp $
$NetBSD: distinfo,v 1.70 2024/02/25 15:16:04 wiz Exp $
BLAKE2s (meld-3.22.0.tar.xz) = c1b26cef3ea87c693d2b20d927251fada8ce3835e114792ba199553586531448
SHA512 (meld-3.22.0.tar.xz) = 4cc1c9a76379401c1f116292bb4730301ec0f2413cdab7b463ed519ea7ee0ee86143a9c83a13f1ef09860aad192c04769d111bfb1eb10b5e1bc81fb44c530526
Size (meld-3.22.0.tar.xz) = 674212 bytes
SHA1 (patch-meson__post__install.py) = ce20b2f3b64ce8c9e4a048e026c5c82dc463e26d
BLAKE2s (meld-3.22.1.tar.xz) = c8987037388254991f9247d0ceb1ccbb2233f1664a43915e1290f59071ce4d12
SHA512 (meld-3.22.1.tar.xz) = 7cb4c64a8134d02ee629c5459d5361c8ee1b1fb80efb02b9f3d2c577ecb69dca2ff66b90affb479682b7fceda41c60717ef859d93e3b93070a84901ae772b2cd
Size (meld-3.22.1.tar.xz) = 675984 bytes

View File

@ -1,31 +0,0 @@
$NetBSD: patch-meson__post__install.py,v 1.1 2022/12/19 07:09:00 wiz Exp $
Fix bytecode compilation in DESTDIR.
https://gitlab.gnome.org/GNOME/meld/-/commit/469ecdc5d48f1e1ef18d81b24a6717cfe93cc3d6
--- meson_post_install.py.orig 2022-09-04 04:26:14.000000000 +0000
+++ meson_post_install.py
@@ -1,8 +1,9 @@
#!/usr/bin/env python3
+import os
+from os import environ
import sys
from compileall import compile_dir
-from os import environ, path
from subprocess import call
if not environ.get('DESTDIR', ''):
@@ -18,5 +19,11 @@ if not environ.get('DESTDIR', ''):
# Byte-compilation is enabled by passing the site-packages path to this script
if len(sys.argv) > 1:
print('Byte-compiling Python module...')
+ destdir = os.getenv("DESTDIR", "")
python_source_install_path = sys.argv[1]
- compile_dir(path.join(python_source_install_path, 'meld'), optimize=1)
+ if destdir:
+ # The install path here will be absolute, so we can't use join()
+ install_path = destdir + os.path.sep + python_source_install_path
+ else:
+ install_path = python_source_install_path
+ compile_dir(os.path.join(install_path, "meld"), optimize=1)