Update mercurial to 3.6.3:

This is a regularly-scheduled bugfix release.

    cmdutil: use crecordmod.checkcurses
    copyfile: add an optional parameter to copy other stat data
    crecord: stop raising error.Abort if curses is not found (issue5008)
    dirstate: don't write repo.currenttransaction to repo.dirstate if repo
    dockerlib: short form for non-unique uid/gid for CentOS 5 compat (issue4977)
    merge: while checking for unknown files don't follow symlinks (issue5027)
    mq: use fallback patch name if no alpha-numeric in summary line (issue5025)
    parsers: fix parse_dirstate to check len before unpacking header (issue4979)
    paths: include #fragment again
    push: restore old behavior of default-push (issue5000)
    record: don't dereference symlinks while copying over stat data
    revlog: seek to end of file before writing (issue4943)
    ui: try to handle $$ more robustly in prompts (issue4970)
This commit is contained in:
wiz 2016-01-03 16:53:30 +00:00
parent 8cb7712bf3
commit 2724c4f11a
4 changed files with 8 additions and 43 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.8 2015/12/21 13:19:17 richard Exp $
# $NetBSD: Makefile,v 1.9 2016/01/03 16:53:30 wiz Exp $
DISTNAME= mercurial-${VERSION}
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
CATEGORIES= devel scm
MASTER_SITES= https://mercurial.selenic.com/release/

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile.version,v 1.27 2015/12/05 21:25:38 adam Exp $
# $NetBSD: Makefile.version,v 1.28 2016/01/03 16:53:30 wiz Exp $
VERSION= 3.6.2
VERSION= 3.6.3
PYTHON_VERSIONS_INCOMPATIBLE= 33 34 35 # not yet ported as of 3.4.1
# see also http://mercurial.selenic.com/wiki/SupportedPythonVersions

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.28 2015/12/21 13:19:17 richard Exp $
$NetBSD: distinfo,v 1.29 2016/01/03 16:53:30 wiz Exp $
SHA1 (mercurial-3.6.2.tar.gz) = 1dbf5d9d42f70f1fb0b26f8e659a1b7879bc1533
RMD160 (mercurial-3.6.2.tar.gz) = 0671aa8429befbc9b049cb640a54d4c810103f56
SHA512 (mercurial-3.6.2.tar.gz) = 2ad780174a30c39a1482d597466523a133b8c62a3a0eb9ac3b183082e279fc624998a9ffa520abafe5f7afc7d9f4600f443ad4dfa1003bd7fdc6b713040091ed
Size (mercurial-3.6.2.tar.gz) = 4518349 bytes
SHA1 (patch-mercurial_revlog.py) = 2c6ba5325480d6a6c025e00fe7903eb007069e1f
SHA1 (mercurial-3.6.3.tar.gz) = c0d04574dde8df133d990c61274e419f4208a05a
RMD160 (mercurial-3.6.3.tar.gz) = 087fe8f521f6c17e097895b64601c0755f0344ba
SHA512 (mercurial-3.6.3.tar.gz) = e5b39e5456a35e19f2ac02838946305023de957590c5aa2828f7c37e9b5f6f2e6376526d0845ebd1ca198860425d11e208b3c36e12e189e0b02871e9c91aad9a
Size (mercurial-3.6.3.tar.gz) = 4521749 bytes

View file

@ -1,33 +0,0 @@
$NetBSD: patch-mercurial_revlog.py,v 1.1 2015/12/21 13:19:17 richard Exp $
https://bz.mercurial-scm.org/show_bug.cgi?id=4943
--- mercurial/revlog.py.orig 2015-12-02 02:18:26.000000000 +0000
+++ mercurial/revlog.py
@@ -13,6 +13,7 @@ and O(changes) merge between branches.
# import stuff from node for others to import from revlog
import collections
+import os
from node import bin, hex, nullid, nullrev
from i18n import _
import ancestor, mdiff, parsers, error, util, templatefilters
@@ -1426,6 +1427,20 @@ class revlog(object):
return node
def _writeentry(self, transaction, ifh, dfh, entry, data, link, offset):
+ # Files opened in a+ mode have inconsistent behavior on various
+ # platforms. Windows requires that a file positioning call be made
+ # when the file handle transitions between reads and writes. See
+ # 3686fa2b8eee and the mixedfilemodewrapper in windows.py. On other
+ # platforms, Python or the platform itself can be buggy. Some versions
+ # of Solaris have been observed to not append at the end of the file
+ # if the file was seeked to before the end. See issue4943 for more.
+ #
+ # We work around this issue by inserting a seek() before writing.
+ # Note: This is likely not necessary on Python 3.
+ ifh.seek(0, os.SEEK_END)
+ if dfh:
+ dfh.seek(0, os.SEEK_END)
+
curr = len(self) - 1
if not self._inline:
transaction.add(self.datafile, offset)