Add colortail-0.3.0: colour-able replacement for tail(1)
Colortail works like the standard tail but it can optionally read a color config file where it's specified expressions that results in colors. It can be used to quickly get an overview of interesting activity by ie. colorize those brightred or some other color of your choose. Examples of the color configuration files are in $PREFIX/share/examples/colortail. XXX patch-aa replaced to work around a bug in this program that assumes non posix/ansi semantics of fgetc(): clearerr() must be used after EOF from fgetc() to read any new data.
This commit is contained in:
parent
898c40328a
commit
27443d97cd
8 changed files with 77 additions and 0 deletions
24
misc/colortail/Makefile
Normal file
24
misc/colortail/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/01/24 03:53:06 hubertf Exp $
|
||||
# FreeBSD Id: ports/misc/colortail/Makefile,v 1.10 2000/06/28 17:20:27 alex Exp
|
||||
|
||||
DISTNAME= colortail-0.3.0
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://www.student.hk-r.se/~pt98jan/
|
||||
|
||||
MAINTAINER= zuntum@eik.pl
|
||||
HOMEPAGE= http://www.student.hk-r.se/~pt98jan/colortail.html
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--datadir=${PREFIX}/share/examples/colortail
|
||||
DESCR_SRC= ${WRKDIR}/.DESCR_SRC
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/colortail
|
||||
cd ${WRKSRC}/example-conf/ && \
|
||||
${INSTALL_DATA} conf.kernel conf.messages conf.secure \
|
||||
conf.xferlog conf.daemon ${PREFIX}/share/examples/colortail
|
||||
${SED} \
|
||||
-e 's|@PREFIX@|${PREFIX}|' \
|
||||
<${PKGDIR}/DESCR >${DESCR_SRC}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
misc/colortail/files/md5
Normal file
3
misc/colortail/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2001/01/24 03:53:06 hubertf Exp $
|
||||
|
||||
MD5 (colortail-0.3.0.tar.gz) = 2589d3e372080f4052d1cc0d6550508f
|
4
misc/colortail/files/patch-sum
Normal file
4
misc/colortail/files/patch-sum
Normal file
|
@ -0,0 +1,4 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2001/01/24 03:53:06 hubertf Exp $
|
||||
|
||||
MD5 (patch-aa) = 4566f54d1b615346d046a1c13a096f94
|
||||
MD5 (patch-ab) = 8aca23aca5547e8c77ae5684c86ad695
|
16
misc/colortail/patches/patch-aa
Normal file
16
misc/colortail/patches/patch-aa
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/01/24 03:53:06 hubertf Exp $
|
||||
|
||||
--- TailFile.cc.orig Wed Jan 24 04:44:29 2001
|
||||
+++ TailFile.cc
|
||||
@@ -417,7 +417,10 @@
|
||||
int ch = fgetc(m_file);
|
||||
|
||||
// add the character to the string
|
||||
- m_follow_buffer->put(ch);
|
||||
+ if (ch == EOF)
|
||||
+ clearerr(m_file); // required by POSIX and ANSI
|
||||
+ else
|
||||
+ m_follow_buffer->put(ch);
|
||||
|
||||
// check if return
|
||||
if (ch == '\n')
|
14
misc/colortail/patches/patch-ab
Normal file
14
misc/colortail/patches/patch-ab
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2001/01/24 03:53:06 hubertf Exp $
|
||||
|
||||
--- CfgFileParser.h.old Wed Jun 21 12:55:57 2000
|
||||
+++ CfgFileParser.h Wed Jun 21 12:56:09 2000
|
||||
@@ -24,7 +24,9 @@
|
||||
#include "config.h"
|
||||
|
||||
#include <sys/types.h>
|
||||
+#if !defined(__NetBSD__)
|
||||
#include <regex.h>
|
||||
+#endif
|
||||
#include <fstream.h>
|
||||
|
||||
#ifdef HAVE_GNUREGEX_H
|
1
misc/colortail/pkg/COMMENT
Normal file
1
misc/colortail/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
colour-able replacement for tail(1)
|
7
misc/colortail/pkg/DESCR
Normal file
7
misc/colortail/pkg/DESCR
Normal file
|
@ -0,0 +1,7 @@
|
|||
Colortail works like the standard tail but it can optionally read
|
||||
a color config file where it's specified expressions that results in colors.
|
||||
It can be used to quickly get an overview of interesting activity by
|
||||
ie. colorize those brightred or some other color of your choose.
|
||||
|
||||
Examples of the color configuration files are
|
||||
in @PREFIX@/share/examples/colortail.
|
8
misc/colortail/pkg/PLIST
Normal file
8
misc/colortail/pkg/PLIST
Normal file
|
@ -0,0 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/01/24 03:53:06 hubertf Exp $
|
||||
bin/colortail
|
||||
share/examples/colortail/conf.daemon
|
||||
share/examples/colortail/conf.kernel
|
||||
share/examples/colortail/conf.messages
|
||||
share/examples/colortail/conf.secure
|
||||
share/examples/colortail/conf.xferlog
|
||||
@dirrm share/examples/colortail
|
Loading…
Reference in a new issue