Patch a configure script to use valid C++, because the package's build

system runs it with CC set to "c++". Should fix the clang build.
This commit is contained in:
dholland 2011-09-12 05:01:15 +00:00
parent 6e48ef6120
commit 275f18215b
2 changed files with 19 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.18 2007/02/09 20:32:38 drochner Exp $
$NetBSD: distinfo,v 1.19 2011/09/12 05:01:15 dholland Exp $
SHA1 (daapd-0.2.4b.tgz) = 0903303f155c19ae12cdc78be05799508156a16b
RMD160 (daapd-0.2.4b.tgz) = 899b37b3872623ef918f7faa4eb8bad2dfc5b369
@ -8,3 +8,4 @@ SHA1 (patch-ac) = 0a4e3dfb010bbf2cc01843987c970548cb4c646f
SHA1 (patch-ad) = 05a61ced18d5b0827ade7e6b3341430ff9b9e89d
SHA1 (patch-ae) = 3433d7e944999e10690ccdda1d49d3c711671446
SHA1 (patch-af) = 1a453dde4dd7d33061a500729b9ef5d89e850133
SHA1 (patch-libhttpd_configure) = 91a7a942a078bda76582cbdf0cc1d3ae8b7029cb

View file

@ -0,0 +1,17 @@
$NetBSD: patch-libhttpd_configure,v 1.1 2011/09/12 05:01:15 dholland Exp $
Since the package makefiles configure and build this library with a
C++ compiler (even though AFAICT it's C code) the configure script had
better use a valid C++ test program to see if the compiler works.
--- libhttpd/configure~ 2006-03-05 13:39:37.000000000 +0000
+++ libhttpd/configure
@@ -662,7 +662,7 @@ cat > conftest.$ac_ext << EOF
#line 663 "configure"
#include "confdefs.h"
-main(){return(0);}
+int main(){return(0);}
EOF
if { (eval echo configure:668: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
ac_cv_prog_cc_works=yes