Fix building with Clang (C++ syntax error)
This commit is contained in:
parent
c266913277
commit
276b49296d
2 changed files with 17 additions and 1 deletions
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.5 2011/04/11 19:57:54 gls Exp $
|
||||
$NetBSD: distinfo,v 1.6 2011/09/21 12:54:16 adam Exp $
|
||||
|
||||
SHA1 (suphp-0.7.1.tar.gz) = 9eb82b62b5f71c01d7d8b2510c685141b78e54f5
|
||||
RMD160 (suphp-0.7.1.tar.gz) = e5e7e71494af322c3ab33d6a35fbcf96334c098c
|
||||
Size (suphp-0.7.1.tar.gz) = 386521 bytes
|
||||
SHA1 (patch-src_SmartPtr.hpp) = 91c20832b140d6fa49ddb2a6fa9b616ff7fc565d
|
||||
|
|
15
www/ap2-suphp/patches/patch-src_SmartPtr.hpp
Normal file
15
www/ap2-suphp/patches/patch-src_SmartPtr.hpp
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_SmartPtr.hpp,v 1.1 2011/09/21 12:54:16 adam Exp $
|
||||
|
||||
Fix C++ syntax
|
||||
|
||||
--- src/SmartPtr.hpp.orig 2011-09-21 12:48:02.000000000 +0000
|
||||
+++ src/SmartPtr.hpp
|
||||
@@ -150,7 +150,7 @@ namespace suPHP {
|
||||
template<class T>
|
||||
const SmartPtr<T>& suPHP::SmartPtr<T>::operator=(
|
||||
const SmartPtr<T>& ref) {
|
||||
- this.reset(ref.ptr);
|
||||
+ this->reset(ref.ptr);
|
||||
return *this;
|
||||
}
|
||||
|
Loading…
Reference in a new issue