gdbm is in disabled_module_list, yet if it's found on the system
the module gets built anyway. Don't do that.
This commit is contained in:
parent
408ee38f52
commit
27ad56e620
2 changed files with 18 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.8 2009/04/11 19:42:23 snj Exp $
|
||||
$NetBSD: distinfo,v 1.9 2009/07/24 14:50:33 schmonz Exp $
|
||||
|
||||
SHA1 (Python-2.5.4.tar.bz2) = 0f2e819d6381f72f26c734e00a6780b3933ea404
|
||||
RMD160 (Python-2.5.4.tar.bz2) = 3a76c83464c3b1c38a60351ab054e33ac7195663
|
||||
|
@ -14,7 +14,7 @@ SHA1 (patch-ai) = a89bee00860910f53a23b1c670d9c091846a03c1
|
|||
SHA1 (patch-aj) = a75d680a6b8b1ad3c9222dcb841f4fb10db6d16d
|
||||
SHA1 (patch-ak) = 948362c15ad59abeef46971f9b870b70655a62c7
|
||||
SHA1 (patch-al) = 6247e3f85d555bae7850befbd7bfffbb233cecb3
|
||||
SHA1 (patch-am) = 7985a6e2edd3eef86bd2833a36818e3e1e315a25
|
||||
SHA1 (patch-am) = 8910340d0a54ac0a053d50199e0dd77162c3b613
|
||||
SHA1 (patch-an) = 17b4e17b3b562c29a050e9bb20447084ce82b8ab
|
||||
SHA1 (patch-ao) = 9bbd5561c010e0a1ab8e0a70d27a5f77fd2089d2
|
||||
SHA1 (patch-ap) = b864db92761c843a91374663bd2dbcfa57b317cf
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-am,v 1.2 2009/04/11 19:42:23 snj Exp $
|
||||
$NetBSD: patch-am,v 1.3 2009/07/24 14:50:33 schmonz Exp $
|
||||
|
||||
--- setup.py.orig 2008-10-16 11:58:19.000000000 -0700
|
||||
+++ setup.py 2009-03-20 15:01:44.000000000 -0700
|
||||
--- setup.py.orig 2008-10-16 14:58:19.000000000 -0400
|
||||
+++ setup.py
|
||||
@@ -15,7 +15,7 @@ from distutils.command.install import in
|
||||
from distutils.command.install_lib import install_lib
|
||||
|
||||
|
@ -364,6 +364,19 @@ $NetBSD: patch-am,v 1.2 2009/04/11 19:42:23 snj Exp $
|
|||
elif (self.compiler.find_library_file(lib_dirs, 'gdbm')
|
||||
and find_file("gdbm/ndbm.h", inc_dirs, []) is not None):
|
||||
exts.append( Extension('dbm', ['dbmmodule.c'],
|
||||
@@ -899,9 +692,9 @@ class PyBuildExt(build_ext):
|
||||
libraries=dblibs))
|
||||
|
||||
# Anthony Baxter's gdbm module. GNU dbm(3) will require -lgdbm:
|
||||
- if (self.compiler.find_library_file(lib_dirs, 'gdbm')):
|
||||
- exts.append( Extension('gdbm', ['gdbmmodule.c'],
|
||||
- libraries = ['gdbm'] ) )
|
||||
+ #if (self.compiler.find_library_file(lib_dirs, 'gdbm')):
|
||||
+ # exts.append( Extension('gdbm', ['gdbmmodule.c'],
|
||||
+ # libraries = ['gdbm'] ) )
|
||||
|
||||
# Unix-only modules
|
||||
if platform not in ['mac', 'win32']:
|
||||
@@ -1536,8 +1329,8 @@ def main():
|
||||
ext_modules=[Extension('_struct', ['_struct.c'])],
|
||||
|
||||
|
|
Loading…
Reference in a new issue