kio: Build and test fixes.

This commit is contained in:
jperkin 2022-05-11 09:17:57 +00:00
parent 20364c8406
commit 27ae2b3315
4 changed files with 46 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.61 2022/04/25 04:34:43 markd Exp $
# $NetBSD: Makefile,v 1.62 2022/05/11 09:17:57 jperkin Exp $
DISTNAME= kio-${KF5VER}
CATEGORIES= devel
@ -11,6 +11,9 @@ LICENSE= gnu-lgpl-v2.1
USE_TOOLS+= msgmerge gmake
TEST_TARGET= test
TEST_ENV+= LD_LIBRARY_PATH=${WRKSRC}/_KDE_build/bin
LDFLAGS.SunOS+= -lsocket
SUBST_CLASSES+= xdg

View file

@ -1,7 +1,9 @@
$NetBSD: distinfo,v 1.17 2022/04/25 04:34:43 markd Exp $
$NetBSD: distinfo,v 1.18 2022/05/11 09:17:57 jperkin Exp $
BLAKE2s (kio-5.93.0.tar.xz) = 9a66c32f1e321b6c10064d780cc1f919ecab2ee72f33468fb074b44b1ca84f19
SHA512 (kio-5.93.0.tar.xz) = d7f1f5ed834dbdc4919dd90def14561e4a8cd1c7f31f0a8b1bb62cb9009509ee2649ed17147bd2197067149942eb65938c41cd3605c9463f7d2cc109d7688747
Size (kio-5.93.0.tar.xz) = 3327996 bytes
SHA1 (patch-autotests_kcoredirlister__benchmark.cpp) = b0d8c7543c15682f4f1699e9db2cba560a7ab5c2
SHA1 (patch-src_core_kmountpoint.cpp) = 463809efb317c5eb721209504521a0c0013b0442
SHA1 (patch-src_filewidgets_kurlnavigator.cpp) = a6a459fdbeaa7e07b2596079c8f5f4a6789fd0eb
SHA1 (patch-src_ioslaves_file_file__unix.cpp) = 30db3f02a507b7a4f561eeccba955c96e07c2c7d

View file

@ -0,0 +1,15 @@
$NetBSD: patch-autotests_kcoredirlister__benchmark.cpp,v 1.1 2022/05/11 09:17:57 jperkin Exp $
Avoid ambiguous function call.
--- autotests/kcoredirlister_benchmark.cpp.orig 2022-04-02 10:22:23.000000000 +0000
+++ autotests/kcoredirlister_benchmark.cpp
@@ -16,6 +16,8 @@
#include <algorithm>
#include <random>
+using std::pow;
+
// BEGIN Global variables
const QString fileNameArg = QLatin1String("/home/user/Folder1/SubFolder2/a%1.txt");
// to check with 10, 100, 1000, ... KFileItem

View file

@ -0,0 +1,24 @@
$NetBSD: patch-src_ioslaves_file_file__unix.cpp,v 1.3 2022/05/11 09:17:57 jperkin Exp $
Fix HAVE_DIRENT_D_TYPE type.
--- src/ioslaves/file/file_unix.cpp.orig 2022-04-02 10:22:23.000000000 +0000
+++ src/ioslaves/file/file_unix.cpp
@@ -1088,7 +1088,7 @@ void FileProtocol::listDir(const QUrl &u
// qDebug() << "========= LIST " << url << "details=" << details << " =========";
UDSEntry entry;
-#ifndef HAVE_DIRENT_D_TYPE
+#if !HAVE_DIRENT_D_TYPE
QT_STATBUF st;
#endif
QT_DIRENT *ep;
@@ -1109,7 +1109,7 @@ void FileProtocol::listDir(const QUrl &u
*/
if (details == KIO::StatBasic) {
entry.fastInsert(KIO::UDSEntry::UDS_NAME, filename);
-#ifdef HAVE_DIRENT_D_TYPE
+#if HAVE_DIRENT_D_TYPE
entry.fastInsert(KIO::UDSEntry::UDS_FILE_TYPE, (ep->d_type == DT_DIR) ? S_IFDIR : S_IFREG);
const bool isSymLink = (ep->d_type == DT_LNK);
#else