Fix gunixmounts.c build on OSF/1

This commit is contained in:
tnn 2008-05-29 12:41:35 +00:00
parent 1cf122ddf3
commit 27c1967802
2 changed files with 14 additions and 9 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.97 2008/05/19 19:08:36 tnn Exp $
$NetBSD: distinfo,v 1.98 2008/05/29 12:41:35 tnn Exp $
SHA1 (glib-2.16.3.tar.bz2) = f73fd53130a46f21ff4ee9faa69b9956787c571e
RMD160 (glib-2.16.3.tar.bz2) = 72260f5f9022ee3f97b79b5705ad6117adc279fd
@ -15,6 +15,6 @@ SHA1 (patch-ai) = e615c6b37cc9d6247940023aefb7bf75bcddc7a5
SHA1 (patch-aj) = a8c4e79113828e6dadf0b158777bb860aa44de3e
SHA1 (patch-ak) = 4eee3ce549ba0972ab5d5d8166d37d2b61320e68
SHA1 (patch-al) = aa2dbd63d53298aab3a30ec6d27e836717c960e3
SHA1 (patch-ba) = 43dda2f4d89a82e645ef8f24d62f13ca9e4ddd9d
SHA1 (patch-ba) = cea071d6477035e0a57636efe272e120ff6d40ee
SHA1 (patch-ca) = e6d852bd79bae271245c94f2d083671bd52af71c
SHA1 (patch-cb) = 0a58d38bc6361f9d5f6f66f83f2f000e812f0507

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ba,v 1.1 2008/04/10 12:13:49 drochner Exp $
$NetBSD: patch-ba,v 1.2 2008/05/29 12:41:35 tnn Exp $
--- gio/gunixmounts.c.orig 2008-04-01 15:51:11.000000000 +0200
--- gio/gunixmounts.c.orig 2008-04-08 05:47:30.000000000 +0200
+++ gio/gunixmounts.c
@@ -561,7 +561,11 @@ get_mtab_monitor_file (void)
static GList *
@ -14,17 +14,22 @@ $NetBSD: patch-ba,v 1.1 2008/04/10 12:13:49 drochner Exp $
int num_mounts, i;
GUnixMountEntry *mount_entry;
GList *return_list;
@@ -579,8 +583,13 @@ _g_get_unix_mounts (void)
@@ -578,8 +582,18 @@ _g_get_unix_mounts (void)
mount_entry->mount_path = g_strdup (mntent[i].f_mntonname);
mount_entry->device_path = g_strdup (mntent[i].f_mntfromname);
+#if defined(__digital__)
+ mount_entry->filesystem_type = g_strdup ("unknown");
+#else
mount_entry->filesystem_type = g_strdup (mntent[i].f_fstypename);
+#ifdef __NetBSD__
+#endif
+#if defined(__NetBSD__)
+ if (mntent[i].f_flag & MNT_RDONLY)
+ mount_entry->is_read_only = TRUE;
+#elif defined(__digital__)
+ if (mntent[i].f_flags & M_RDONLY)
+#else
if (mntent[i].f_flags & MNT_RDONLY)
mount_entry->is_read_only = TRUE;
+#endif
mount_entry->is_read_only = TRUE;
mount_entry->is_system_internal =
guess_system_internal (mount_entry->mount_path,