Update to 2.54, provided by Julio Merino in PR 18354.

* Major changes in Autoconf 2.54                       -*- outline -*-

** Executables

- autoreconf no longer changes the version of the gettext/po/intl
  support files. It now adds the files the correspond to the
  AM_GNU_GETTEXT_VERSION declared in configure.ac.

  Warning: It now relies on the 'autopoint' program, which is part
  of GNU gettext 0.11.4 and newer.

  Please note that you need to have a GNU gettext version that
  corresponds at least to the AM_GNU_GETTEXT_VERSION declared
  in configure.ac. You can upgrade to newer GNU gettext versions,
  though, without needing to change configure.ac.

- The -I DIR or --include=DIR option now appends DIR to the include path
  instead of prepending; this is for consistency with other GNU tools.
  The new -B DIR or --prepend-include=DIR option has the old behavior.

** Macros

- AC_OUTPUT
  Now handles all the gory details about LIBOBJS and LTLIBOBJS.
  Please, remove lines such as

	# This is necessary so that .o files in LIBOBJS are also
	# built via the ANSI2KNR-filtering rules.
	LIBOBJS=`echo $LIBOBJS|sed 's/\.o /\$U.o /g;s/\.o$/\$U.o/'`

  and read the `AC_LIBOBJ vs LIBOBJS' section.  Do not define U in
  your Makefiles either.

- AC_CONFIG_LINKS now makes copies if it can't make links.

- AC_FUNC_FNMATCH now tests only for POSIX compatibility, reverting to
  Autoconf 2.13 behavior.  The new macro AC_FUNC_FNMATCH_GNU also
  tests for GNU extensions to fnmatch, and replaces fnmatch if needed.

- AC_FUNC_SETVBUF_REVERSED no longer fails when cross-compiling.

- AC_PROG_CC_STDC is integrated into AC_PROG_CC.

- AC_PROG_F77 default search no longer includes cf77 and cfg77.

- New macros

  AC_C_BACKSLASH_A, AC_CONFIG_LIBOBJ_DIR, AC_GNU_SOURCE,
  AC_PROG_EGREP, AC_PROG_FGREP, AC_REPLACE_FNMATCH,
  AC_FUNC_FNMATCH_GNU, AC_FUNC_REALLOC, AC_TYPE_MBSTATE_T.

- AC_FUNC_GETLOADAVG
  looks for getloadavg.c in the CONFIG_LIBOBJ_DIR.

- AC_FUNC_MALLOC
  Now defines HAVE_MALLOC to 0 if `malloc' does not work, and asks
  for an AC_LIBOBJ replacement.

** Bug fixes

- Spurious complaints from `m4_bmatch' about invalid regular
  expressions are suppressed.

- Empty top_builddirs are properly handled.

- AC_CHECK_MEMBER works correctly when the member is an aggregate.

- AC_PATH_PROG
  Now colon in the optional path arguments are properly handled.

** Improved portability

- Both Autoconf the package, and the scripts it produces, should run
  more reliably with Zsh.  Bear in mind it is the default Bourne shell
  on Darwin.

- Autoconf and the scripts it produces no longer assume the existence of
  the obsolescent commands egrep and fgrep.

** Documentation

- Limitations of Make
  More of them.

- GNATS
  The GNATS base has moved to
  http://bugs.gnu.org/cgi-bin/gnatsweb.pl?database=autoconf

** Misc.

- config.log
  Now contains the list of ouput variables and files (AC_SUBST,
  AC_SUBST_FILES).
This commit is contained in:
wiz 2002-09-25 19:13:41 +00:00
parent ee14456b37
commit 27ddcd25e6
3 changed files with 5 additions and 38 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.9 2002/08/28 04:38:07 jlam Exp $
# $NetBSD: Makefile,v 1.10 2002/09/25 19:13:41 wiz Exp $
DISTNAME= autoconf-2.53
PKGREVISION= 1
DISTNAME= autoconf-2.54
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU:=autoconf/}

View file

@ -1,5 +1,4 @@
$NetBSD: distinfo,v 1.4 2002/05/08 11:03:16 wiz Exp $
$NetBSD: distinfo,v 1.5 2002/09/25 19:13:41 wiz Exp $
SHA1 (autoconf-2.53.tar.gz) = a9fe8460b4ed6f279f3d3f8a73eb39b19e93dc98
Size (autoconf-2.53.tar.gz) = 990527 bytes
SHA1 (patch-aa) = b9f12e698a6393749f8a9029d452c094a29ee8f8
SHA1 (autoconf-2.54.tar.gz) = 5126d0f011a5c45f211ec7304739bd3e335bf37d
Size (autoconf-2.54.tar.gz) = 1038536 bytes

View file

@ -1,31 +0,0 @@
$NetBSD: patch-aa,v 1.1 2002/05/08 11:03:17 wiz Exp $
--- doc/autoconf.texi.orig Fri Mar 8 13:57:41 2002
+++ doc/autoconf.texi
@@ -413,7 +413,7 @@
* Changed Quotation:: Broken code which used to work
* New Macros:: Interaction with foreign macros
* Hosts and Cross-Compilation:: Bugward compatibility kludges
-* AC_LIBOBJ vs. LIBOBJS::
+* AC_LIBOBJ vs LIBOBJS::
Generating Test Suites with Autotest
@@ -11838,7 +11838,7 @@
* Changed Quotation:: Broken code which used to work
* New Macros:: Interaction with foreign macros
* Hosts and Cross-Compilation:: Bugward compatibility kludges
-* AC_LIBOBJ vs. LIBOBJS:: LIBOBJS is a forbidden token
+* AC_LIBOBJ vs LIBOBJS:: LIBOBJS is a forbidden token
@end menu
@node Changed Quotation
@@ -12081,7 +12081,7 @@
@end example
-@node AC_LIBOBJ vs. LIBOBJS
+@node AC_LIBOBJ vs LIBOBJS
@subsection @code{AC_LIBOBJ} vs. @code{LIBOBJS}
Up to Autoconf 2.13, the replacement of functions was triggered via the