py-psutil: updated to 5.9.4
5.9.4 ===== 2022-11-07 **Enhancements** - 2102_: use Limited API when building wheels with CPython 3.6+ on Linux, macOS and Windows. This allows to use pre-built wheels in all future versions of cPython 3. (patch by Matthieu Darbois) **Bug fixes** - 2077_, [Windows]: Use system-level values for `virtual_memory()`_. (patch by Daniel Widdis) - 2156_, [Linux]: compilation may fail on very old gcc compilers due to missing ``SPEED_UNKNOWN`` definition. (patch by Amir Rossert) - 2010_, [macOS]: on MacOS, arm64 ``IFM_1000_TX`` and ``IFM_1000_T`` are the same value, causing a build failure. (patch by Lawrence D'Anna)
This commit is contained in:
parent
c2c95afb45
commit
2809dfb830
4 changed files with 28 additions and 9 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.47 2022/11/02 13:08:21 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.48 2022/11/08 08:50:20 adam Exp $
|
||||
|
||||
DISTNAME= psutil-5.9.3
|
||||
DISTNAME= psutil-5.9.4
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= sysutils python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=p/psutil/}
|
||||
|
@ -10,6 +10,9 @@ HOMEPAGE= https://github.com/giampaolo/psutil
|
|||
COMMENT= Cross-platform process and system utilities module for Python
|
||||
LICENSE= modified-bsd
|
||||
|
||||
# from wheel.bdist_wheel import bdist_wheel
|
||||
BUILD_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
|
||||
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 27
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.16 2022/09/05 08:31:14 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.17 2022/11/08 08:50:20 adam Exp $
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
|
@ -32,8 +32,8 @@ ${PYSITELIB}/psutil/_psposix.pyo
|
|||
${PYSITELIB}/psutil/_pssunos.py
|
||||
${PYSITELIB}/psutil/_pssunos.pyc
|
||||
${PYSITELIB}/psutil/_pssunos.pyo
|
||||
${PYSITELIB}/psutil/_psutil_${SYSTEM}.so
|
||||
${PYSITELIB}/psutil/_psutil_posix.so
|
||||
${PYSITELIB}/psutil/_psutil_${SYSTEM}.abi3.so
|
||||
${PYSITELIB}/psutil/_psutil_posix.abi3.so
|
||||
${PYSITELIB}/psutil/_pswindows.py
|
||||
${PYSITELIB}/psutil/_pswindows.pyc
|
||||
${PYSITELIB}/psutil/_pswindows.pyo
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.48 2022/11/02 13:08:21 adam Exp $
|
||||
$NetBSD: distinfo,v 1.49 2022/11/08 08:50:20 adam Exp $
|
||||
|
||||
BLAKE2s (psutil-5.9.3.tar.gz) = 5fe5a94dae604ccfdd4d44ce979c3711c66250cf70df330e31d308634cbab032
|
||||
SHA512 (psutil-5.9.3.tar.gz) = d226364b416823783058f19c06dae4ac1ea03f061646f01ea6953ded8fbb89aed92aa743c9e55181e4d57101f7dbbb78336043e1fc7a3bd62ff82b19f0a4efae
|
||||
Size (psutil-5.9.3.tar.gz) = 483579 bytes
|
||||
BLAKE2s (psutil-5.9.4.tar.gz) = c692420fa2ab1df6be71d2464c16b19e07a9e6205aca62b8030aeb12b6297c9c
|
||||
SHA512 (psutil-5.9.4.tar.gz) = ff8d6213b153b5a3428e4f65ddbc41cb1f37caae4acab02760632107d95a50a74d3ee563f0cb2d623b37cdddd16425d2084e7f841e4a46af8988a7676f6975e6
|
||||
Size (psutil-5.9.4.tar.gz) = 485825 bytes
|
||||
SHA1 (patch-setup.py) = 56d575ea7e1e6d8b9c56d45c191e41e8d50c2a08
|
||||
|
|
15
sysutils/py-psutil/patches/patch-setup.py
Normal file
15
sysutils/py-psutil/patches/patch-setup.py
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-setup.py,v 1.6 2022/11/08 08:50:20 adam Exp $
|
||||
|
||||
Enable limited API on all platforms.
|
||||
|
||||
--- setup.py.orig 2022-11-08 08:46:24.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -109,7 +109,7 @@ def get_version():
|
||||
VERSION = get_version()
|
||||
macros.append(('PSUTIL_VERSION', int(VERSION.replace('.', ''))))
|
||||
|
||||
-if bdist_wheel and CP36_PLUS and (MACOS or LINUX or WINDOWS):
|
||||
+if bdist_wheel and CP36_PLUS:
|
||||
py_limited_api = {"py_limited_api": True}
|
||||
macros.append(('Py_LIMITED_API', '0x03060000'))
|
||||
else:
|
Loading…
Reference in a new issue