Update semantic to 1.4.2.

Approximate set of changes:

* Added namespaces support to the C/C++ grammar.
* New Non-recursive parser by David Ponce <david@dponce.com>
* Variables no longer contain an explicit constant flag.
* Modifiers field for variable, function, and types is now an association
  list.
* Analyzizes via type information the local context
* Provides smart completion information
* Speedbar mode for using analysis information.
* Generates objects representing a browsable class structure
  which links parents and subclasses and externally defined
  methods into an easilly navigated (programatically) structure.
* Speedbar interface to browser structure (simple)
* semantic-load.el simplifies installation.
* Added partial reparseing of buffers where only token contents have changed.
* Added `semantic-show-dirty-mode'.
* Added `semantic-show-unmatched-syntax-mode'
* Added `semantic-auto-reparse-mode'
* Added new tool, `semanticdb'.
  Semanticdb caches token lists between sessions with a specific file.

And more.

Use emacs.mk.
This commit is contained in:
uebayasi 2003-01-11 08:56:33 +00:00
parent 1109488378
commit 283fd270f3
4 changed files with 93 additions and 76 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.5 2002/02/18 15:14:15 seb Exp $
# $NetBSD: Makefile,v 1.6 2003/01/11 08:56:33 uebayasi Exp $
#
DISTNAME= semantic-1.4beta5
DISTNAME= semantic-1.4.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=cedet/}
@ -9,23 +9,18 @@ MAINTAINER= cjones@netbsd.org
HOMEPAGE= http://cedet.sourceforge.net/semantic.shtml
COMMENT= Lexer, parser-generator, and parser written for Emacs
DEPENDS+= speedbar-0.13a:../../editors/speedbar
DEPENDS+= eieio-0.16:../../lang/eieio
DEPENDS+= speedbar>=0.13:../../editors/speedbar
DEPENDS+= eieio>=0.17rc3:../../lang/eieio
.include "../../mk/bsd.prefs.mk"
.include "../../mk/emacs.mk"
.if defined(USE_XEMACS)
DEPENDS+= xemacs-[0-9]*:../../editors/xemacs
EMACS= xemacs
LISPDIR= lib/xemacs/xemacs-packages/lisp/semantic
.else
DEPENDS+= emacs-[0-9]*:../../editors/emacs
.if ${EMACS_FLAVOR} == "emacs"
EMACS= emacs
LISPDIR= share/emacs/site-lisp/semantic
.else
EMACS= xemacs
.endif
BUILD_ENV+= EMACS=${EMACS}
PLIST_SUBST+= LISPDIR=${LISPDIR}
NO_CONFIGURE= # set
USE_GMAKE= # set
@ -33,18 +28,28 @@ USE_GMAKE= # set
INFO_FILES= semantic.info
OTHER_INFO= semantic.info-1 semantic.info-2
SRCS= semantic.el semantic-util.el semantic-bnf.el semantic-ctxt.el \
semantic-c.el semantic-el.el semantic-java.el semantic-make.el \
semantic-scm.el semantic-texi.el semantic-imenu.el \
semantic-sb.el working.el semanticdb.el document.el \
document-vars.el sformat.el senator.el
AUXFILES= c.bnf make.bnf java.bnf scheme.bnf semantic-load.el
# XXX cd ${WRKSRC}; ${MAKE} -V semantic_LISP
SRCS= semantic.el semantic-util.el semantic-bnf.el semantic-ctxt.el
# XXX cd ${WRKSRC}; ${MAKE} -V Languages_LISP
SRCS+= semantic-c.el semantic-el.el semantic-java.el semantic-make.el \
semantic-scm.el semantic-texi.el
# XXX cd ${WRKSRC}; ${MAKE} -V tools_LISP
SRCS+= semantic-imenu.el semantic-sb.el working.el semanticdb.el document.el \
document-vars.el sformat.el semantic-chart.el semantic-util-modes.el \
semantic-analyze.el semantic-ia.el semantic-cb.el semantic-ia-sb.el
# XXX cd ${WRKSRC}; ${MAKE} -V senator_LISP
SRCS+= senator.el
# XXX cd ${WRKSRC}; ${MAKE} -V init_LISP
AUXFILES= semantic-load.el
# XXX cd ${WRKSRC}; ${MAKE} -V aux_AUX
AUXFILES+= c.bnf make.bnf java.bnf scheme.bnf
do-install:
${INSTALL_DATA_DIR} ${PREFIX}/${LISPDIR}
${INSTALL_DATA_DIR} ${EMACS_LISPPREFIX}/semantic
cd ${WRKSRC} && ${INSTALL_DATA} ${SRCS} ${SRCS:.el=.elc} \
${PREFIX}/${LISPDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${AUXFILES} ${PREFIX}/${LISPDIR}
${EMACS_LISPPREFIX}/semantic
cd ${WRKSRC} && ${INSTALL_DATA} ${AUXFILES} ${EMACS_LISPPREFIX}/semantic
cd ${WRKSRC} && ${INSTALL_DATA} ${INFO_FILES} ${OTHER_INFO} \
${PREFIX}/info

View file

@ -1,48 +1,60 @@
@comment $NetBSD: PLIST,v 1.2 2002/02/18 15:14:15 seb Exp $
${LISPDIR}/semantic.el
${LISPDIR}/semantic.elc
${LISPDIR}/semantic-util.el
${LISPDIR}/semantic-util.elc
${LISPDIR}/semantic-bnf.el
${LISPDIR}/semantic-bnf.elc
${LISPDIR}/semantic-ctxt.el
${LISPDIR}/semantic-ctxt.elc
${LISPDIR}/semantic-c.el
${LISPDIR}/semantic-c.elc
${LISPDIR}/semantic-el.el
${LISPDIR}/semantic-el.elc
${LISPDIR}/semantic-java.el
${LISPDIR}/semantic-java.elc
${LISPDIR}/semantic-make.el
${LISPDIR}/semantic-make.elc
${LISPDIR}/semantic-scm.el
${LISPDIR}/semantic-scm.elc
${LISPDIR}/semantic-texi.el
${LISPDIR}/semantic-texi.elc
${LISPDIR}/semantic-imenu.el
${LISPDIR}/semantic-imenu.elc
${LISPDIR}/semantic-sb.el
${LISPDIR}/semantic-sb.elc
${LISPDIR}/working.el
${LISPDIR}/working.elc
${LISPDIR}/semanticdb.el
${LISPDIR}/semanticdb.elc
${LISPDIR}/document.el
${LISPDIR}/document.elc
${LISPDIR}/document-vars.el
${LISPDIR}/document-vars.elc
${LISPDIR}/sformat.el
${LISPDIR}/sformat.elc
${LISPDIR}/senator.el
${LISPDIR}/senator.elc
${LISPDIR}/c.bnf
${LISPDIR}/make.bnf
${LISPDIR}/java.bnf
${LISPDIR}/scheme.bnf
${LISPDIR}/semantic-load.el
@comment $NetBSD: PLIST,v 1.3 2003/01/11 08:56:33 uebayasi Exp $
@unexec ${INSTALL_INFO} --delete %D/info/semantic.info %D/info/dir
info/semantic.info
info/semantic.info-1
info/semantic.info-2
@exec ${INSTALL_INFO} %D/info/semantic.info %D/info/dir
@dirrm ${LISPDIR}
${EMACS_LISPPREFIX}/semantic/document-vars.el
${EMACS_LISPPREFIX}/semantic/document-vars.elc
${EMACS_LISPPREFIX}/semantic/document.el
${EMACS_LISPPREFIX}/semantic/document.elc
${EMACS_LISPPREFIX}/semantic/semantic-analyze.el
${EMACS_LISPPREFIX}/semantic/semantic-analyze.elc
${EMACS_LISPPREFIX}/semantic/semantic-bnf.el
${EMACS_LISPPREFIX}/semantic/semantic-bnf.elc
${EMACS_LISPPREFIX}/semantic/semantic-c.el
${EMACS_LISPPREFIX}/semantic/semantic-c.elc
${EMACS_LISPPREFIX}/semantic/semantic-cb.el
${EMACS_LISPPREFIX}/semantic/semantic-cb.elc
${EMACS_LISPPREFIX}/semantic/semantic-chart.el
${EMACS_LISPPREFIX}/semantic/semantic-chart.elc
${EMACS_LISPPREFIX}/semantic/semantic-ctxt.el
${EMACS_LISPPREFIX}/semantic/semantic-ctxt.elc
${EMACS_LISPPREFIX}/semantic/semantic-el.el
${EMACS_LISPPREFIX}/semantic/semantic-el.elc
${EMACS_LISPPREFIX}/semantic/semantic-ia-sb.el
${EMACS_LISPPREFIX}/semantic/semantic-ia-sb.elc
${EMACS_LISPPREFIX}/semantic/semantic-ia.el
${EMACS_LISPPREFIX}/semantic/semantic-ia.elc
${EMACS_LISPPREFIX}/semantic/semantic-imenu.el
${EMACS_LISPPREFIX}/semantic/semantic-imenu.elc
${EMACS_LISPPREFIX}/semantic/semantic-java.el
${EMACS_LISPPREFIX}/semantic/semantic-java.elc
${EMACS_LISPPREFIX}/semantic/semantic-make.el
${EMACS_LISPPREFIX}/semantic/semantic-make.elc
${EMACS_LISPPREFIX}/semantic/semantic-sb.el
${EMACS_LISPPREFIX}/semantic/semantic-sb.elc
${EMACS_LISPPREFIX}/semantic/semantic-scm.el
${EMACS_LISPPREFIX}/semantic/semantic-scm.elc
${EMACS_LISPPREFIX}/semantic/semantic-texi.el
${EMACS_LISPPREFIX}/semantic/semantic-texi.elc
${EMACS_LISPPREFIX}/semantic/semantic-util-modes.el
${EMACS_LISPPREFIX}/semantic/semantic-util-modes.elc
${EMACS_LISPPREFIX}/semantic/semantic-util.el
${EMACS_LISPPREFIX}/semantic/semantic-util.elc
${EMACS_LISPPREFIX}/semantic/semantic.el
${EMACS_LISPPREFIX}/semantic/semantic.elc
${EMACS_LISPPREFIX}/semantic/semanticdb.el
${EMACS_LISPPREFIX}/semantic/semanticdb.elc
${EMACS_LISPPREFIX}/semantic/senator.el
${EMACS_LISPPREFIX}/semantic/senator.elc
${EMACS_LISPPREFIX}/semantic/sformat.el
${EMACS_LISPPREFIX}/semantic/sformat.elc
${EMACS_LISPPREFIX}/semantic/working.el
${EMACS_LISPPREFIX}/semantic/working.elc
${EMACS_LISPPREFIX}/semantic/c.bnf
${EMACS_LISPPREFIX}/semantic/make.bnf
${EMACS_LISPPREFIX}/semantic/java.bnf
${EMACS_LISPPREFIX}/semantic/scheme.bnf
${EMACS_LISPPREFIX}/semantic/semantic-load.el
@dirrm ${EMACS_LISPPREFIX}/semantic

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.3 2002/02/18 15:14:16 seb Exp $
$NetBSD: distinfo,v 1.4 2003/01/11 08:56:33 uebayasi Exp $
SHA1 (semantic-1.4beta5.tar.gz) = 10e6e41a13c79cb1e84aae99b072557d63e3f105
Size (semantic-1.4beta5.tar.gz) = 177179 bytes
SHA1 (patch-aa) = 281922cbbbd09783ad581acfb59244a2ec5abbe8
SHA1 (semantic-1.4.2.tar.gz) = a8898745055319de676c61a5d529d4dfb6eb2878
Size (semantic-1.4.2.tar.gz) = 313881 bytes
SHA1 (patch-aa) = 7747913d4db505d1bc287b1d9bd986cbfaf53c7a

View file

@ -1,12 +1,12 @@
$NetBSD: patch-aa,v 1.1 2002/02/18 15:14:16 seb Exp $
$NetBSD: patch-aa,v 1.2 2003/01/11 08:56:33 uebayasi Exp $
--- Makefile.orig Wed May 16 13:40:27 2001
--- Makefile.orig Tue Dec 31 19:17:40 2002
+++ Makefile
@@ -21,7 +21,6 @@
LOADPATH=
misc_AUX=INSTALL NEWS
@@ -19,7 +19,6 @@
senator_LISP=senator.el
misc_AUX=INSTALL NEWS ChangeLog
info_TEXINFOS=semantic.texi
-MAKEINFO=makeinfo
aux_AUX=c.bnf make.bnf java.bnf scheme.bnf
VERSION=1.4beta5
DISTDIR=semantic-$(VERSION)
VERSION=1.4.2
DISTDIR=$(top)semantic-$(VERSION)