Fix 6 year+ old type in configure by adding missing hyphen for -Wl,-R.
Fix main declaration for X11 test. Always use C++ and C99 compatible inline specifier.
This commit is contained in:
parent
a9584df29f
commit
28419fa645
3 changed files with 37 additions and 5 deletions
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.24 2012/04/27 14:37:37 hauke Exp $
|
||||
$NetBSD: distinfo,v 1.25 2012/12/21 15:06:31 joerg Exp $
|
||||
|
||||
SHA1 (xemacs-21.5.27.tar.gz) = 55fc3e9c8fe3cac92791ffe1a0870aeae1baf0b8
|
||||
RMD160 (xemacs-21.5.27.tar.gz) = ee0caff8730c999d37aa3a19b19f23d5756837ad
|
||||
Size (xemacs-21.5.27.tar.gz) = 15042023 bytes
|
||||
SHA1 (patch-aa) = 5e099de33676099916771080c606046ca9acdac6
|
||||
SHA1 (patch-ab) = c105e7333e5ed64eac1e99d49551e5bf75c0bc03
|
||||
SHA1 (patch-ab) = a08798d080167fbdc213d5eda2bd75f271c66792
|
||||
SHA1 (patch-ac) = 9a480bf587e1b7e3fb15724433ca706f1848182e
|
||||
SHA1 (patch-ad) = 244ddfebb25ccca7b34b308cced61f256b50d0a7
|
||||
SHA1 (patch-ae) = 902a375f974e06eb5d67b69deadead98c625d97a
|
||||
|
@ -17,4 +17,5 @@ SHA1 (patch-ak) = c8a3369efdd4af32b1a65cdb3d798724d63b3ed5
|
|||
SHA1 (patch-al) = 33000a300de6358c0ba3260708d6d625dcd625a2
|
||||
SHA1 (patch-am) = 0ccbead4be5da92e73a15432ff1b063da13cf0b4
|
||||
SHA1 (patch-an) = f382865087f011ea3806d707cbf784fac81ad746
|
||||
SHA1 (patch-src_config.h.in) = 8032e1a040b46131763d40e625a1b7e841f9b233
|
||||
SHA1 (patch-src_glyphs-eimage.c) = a382113190a65d27747a90e58294a41f3bb6df42
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-ab,v 1.6 2006/10/14 02:24:46 rillig Exp $
|
||||
$NetBSD: patch-ab,v 1.7 2012/12/21 15:06:31 joerg Exp $
|
||||
|
||||
--- configure.orig 2006-05-16 06:16:04.000000000 +0200
|
||||
+++ configure 2006-10-14 04:23:09.000000000 +0200
|
||||
--- configure.orig 2006-05-16 04:16:04.000000000 +0000
|
||||
+++ configure
|
||||
@@ -4415,7 +4415,7 @@ case "$ac_cv_build" in
|
||||
case "${ac_cv_build}" in
|
||||
i[3-9]86-*-netbsd*) machine=intel386 ;;
|
||||
|
@ -20,6 +20,24 @@ $NetBSD: patch-ab,v 1.6 2006/10/14 02:24:46 rillig Exp $
|
|||
xe_check_libs="${try_dash_r}/no/such/file-or-directory"
|
||||
|
||||
if test "$GCC" = "yes"; then
|
||||
@@ -18572,7 +18572,7 @@ cat confdefs.h >>conftest.$ac_ext
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
#include <X11/Intrinsic.h>
|
||||
- int main(int c, char *v) { return c>1 ? XlibSpecificationRelease : 0; }
|
||||
+ int main(int c, char **v) { return c>1 ? XlibSpecificationRelease : 0; }
|
||||
_ACEOF
|
||||
rm -f conftest$ac_exeext
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -38829,7 +38829,7 @@ _ACEOF
|
||||
cat confdefs.h >>conftest.$ac_ext
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
-int main(int c,char *v){return 0;}
|
||||
+int main(int c,char **v){return 0;}
|
||||
_ACEOF
|
||||
rm -f conftest$ac_exeext
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -39670,7 +39670,7 @@ fi
|
||||
if test "$have_vdb_mach" = yes ; then
|
||||
echo " Using mach exception mechanism as vdb fault handler."
|
||||
|
|
13
editors/xemacs-current/patches/patch-src_config.h.in
Normal file
13
editors/xemacs-current/patches/patch-src_config.h.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-src_config.h.in,v 1.1 2012/12/21 15:06:31 joerg Exp $
|
||||
|
||||
--- src/config.h.in.orig 2012-12-21 10:42:05.000000000 +0000
|
||||
+++ src/config.h.in
|
||||
@@ -1066,7 +1066,7 @@ extern "C" {
|
||||
Use `inline static' to define inline functions in .c files.
|
||||
See the Internals manual for examples and more information. */
|
||||
|
||||
-#if defined (__cplusplus) || ! defined (__GNUC__)
|
||||
+#if 1
|
||||
# define INLINE_HEADER inline static
|
||||
#elif defined (DONT_EXTERN_INLINE_HEADER_FUNCTIONS)
|
||||
# define INLINE_HEADER inline
|
Loading…
Reference in a new issue