- Update to 1.2.1 - ok'ed jlam@
- This incorporates security fixes from SuSE to address the issues they found From the ChangeLog: > 02/04/2005 jcalcote@novell.com > Incorporated various bug fixes from SuSE and others. > Updated Autotools files for version 1.5+
This commit is contained in:
parent
c96dd5c4a1
commit
28583edea3
10 changed files with 57 additions and 97 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.25 2005/05/22 20:08:25 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.26 2005/05/26 20:14:21 adrianp Exp $
|
||||
|
||||
DISTNAME= openslp-1.2.0
|
||||
PKGREVISION= 1
|
||||
DISTNAME= openslp-1.2.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=openslp/}
|
||||
|
||||
|
@ -35,11 +34,21 @@ RCD_SCRIPTS= slpd
|
|||
.include "../../mk/automake.mk"
|
||||
|
||||
post-extract:
|
||||
${FIND} ${WRKSRC} -name "CVS" -print | ${XARGS} ${RM} -rf
|
||||
${RM} -fr ${WRKSRC}/doc/html/UsersGuide/.xvpics
|
||||
@${FIND} ${WRKSRC} -name "CVS" -print | ${XARGS} ${RM} -rf
|
||||
@${RM} -fr ${WRKSRC}/doc/html/UsersGuide/.xvpics
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && ${ACLOCAL} && ${AUTOHEADER} && ${AUTOCONF} && \
|
||||
@cd ${WRKSRC} && ${ACLOCAL} && ${AUTOHEADER} && ${AUTOCONF} && \
|
||||
${LOCALBASE}/bin/libtoolize && ${AUTOMAKE} --add-missing
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/openslp
|
||||
@cd ${WRKSRC}/doc && ${PAX} -rw . ${PREFIX}/share/doc/openslp
|
||||
@${FIND} ${PREFIX}/share/doc/openslp | ${XARGS} ${CHOWN} \
|
||||
${SHAREOWN}:${SHAREGRP}
|
||||
@${FIND} ${PREFIX}/share/doc/openslp -type f | ${XARGS} ${CHMOD} \
|
||||
${SHAREMODE}
|
||||
@${FIND} ${PREFIX}/share/doc/openslp -type d | ${XARGS} ${CHMOD} \
|
||||
${PKGDIRMODE}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.7 2004/11/27 04:41:12 jlam Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.8 2005/05/26 20:14:21 adrianp Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
OPENSLP_BUILDLINK3_MK:= ${OPENSLP_BUILDLINK3_MK}+
|
||||
|
@ -12,7 +12,7 @@ BUILDLINK_PACKAGES+= openslp
|
|||
|
||||
.if !empty(OPENSLP_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.openslp+= openslp>=1.0.1
|
||||
BUILDLINK_RECOMMENDED.openslp+= openslp>=1.2.0
|
||||
BUILDLINK_RECOMMENDED.openslp+= openslp>=1.2.1
|
||||
BUILDLINK_PKGSRCDIR.openslp?= ../../net/openslp
|
||||
.endif # OPENSLP_BUILDLINK3_MK
|
||||
|
||||
|
|
|
@ -1,11 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.11 2005/02/24 12:13:58 agc Exp $
|
||||
$NetBSD: distinfo,v 1.12 2005/05/26 20:14:21 adrianp Exp $
|
||||
|
||||
SHA1 (openslp-1.2.0.tar.gz) = 3525c74b1f8a56fe96fbca24c603bbe43028cc2b
|
||||
RMD160 (openslp-1.2.0.tar.gz) = e5b85553e26dab31ab137cf13988f2ed8d29b335
|
||||
Size (openslp-1.2.0.tar.gz) = 548410 bytes
|
||||
SHA1 (patch-ac) = 7f051530c654d92139ea03f8e33cd8f87720133f
|
||||
SHA1 (patch-ad) = 6b1f63d5ad1a6893fbf402f897700e4fa01ce161
|
||||
SHA1 (patch-ae) = 805c12cceaf338f2d5fcc5b47ef68ebe11d0a046
|
||||
SHA1 (patch-af) = 7f62a8532f14370415def8e0fa59c4ca7c6c9c4c
|
||||
SHA1 (patch-ag) = 6cf63c299bd04854df7e3272c1f3036c82ff5337
|
||||
SHA1 (patch-ah) = b14ae256a2041664ed0691b8901c986cccd7c169
|
||||
SHA1 (openslp-1.2.1.tar.gz) = 47ab19154084d2b467f09525f5351e9ab7193cf9
|
||||
RMD160 (openslp-1.2.1.tar.gz) = a31d516ba784ad893a740946082fe5e0f15a37ea
|
||||
Size (openslp-1.2.1.tar.gz) = 886195 bytes
|
||||
SHA1 (patch-ac) = 031177b9334b570e1021887ae2bdf56f4ba02c48
|
||||
SHA1 (patch-ae) = 1332580b2d9cb3e2e5c5da219c1036b9701161e5
|
||||
SHA1 (patch-ah) = f15c497b19f4bfc4efbd5cce0b50932733115824
|
||||
SHA1 (patch-ai) = 11baa3ef891677f1df78f75b93001580ff450e13
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1 2004/11/27 04:41:12 jlam Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2005/05/26 20:14:21 adrianp Exp $
|
||||
|
||||
--- configure.in.orig 2004-02-04 15:07:33.000000000 -0500
|
||||
--- configure.in.orig 2005-05-26 19:42:13.000000000 +0100
|
||||
+++ configure.in
|
||||
@@ -155,7 +155,7 @@ dnl ************************************
|
||||
@@ -159,7 +159,7 @@ dnl ************************************
|
||||
dnl Checks for header files.
|
||||
dnl ***********************************************************************
|
||||
AC_STDC_HEADERS
|
||||
-AC_HAVE_HEADERS(string.h sys/types.h stdint.h netinet/in.h)
|
||||
+AC_HAVE_HEADERS(string.h sys/types.h stdint.h netinet/in.h bits/ioctls.h)
|
||||
AC_HEADER_STDC
|
||||
-AC_CHECK_HEADERS(string.h sys/types.h stdint.h netinet/in.h)
|
||||
+AC_CHECK_HEADERS(string.h sys/types.h stdint.h netinet/in.h bits/ioctls.h)
|
||||
|
||||
dnl ***********************************************************************
|
||||
dnl Checks for data types.
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2004/11/27 04:41:12 jlam Exp $
|
||||
|
||||
--- common/slp_dhcp.c.orig 2003-02-12 17:18:16.000000000 -0500
|
||||
+++ common/slp_dhcp.c
|
||||
@@ -66,7 +66,9 @@
|
||||
#include <sys/socket.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <net/if_arp.h>
|
||||
+#if HAVE_BITS_IOCTLS_H
|
||||
#include <bits/ioctls.h>
|
||||
+#endif
|
||||
#include <sys/time.h>
|
||||
#endif
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ae,v 1.1 2004/11/27 04:41:12 jlam Exp $
|
||||
$NetBSD: patch-ae,v 1.2 2005/05/26 20:14:21 adrianp Exp $
|
||||
|
||||
--- common/slp_attr_l.l.orig 2002-05-10 01:23:43.000000000 -0400
|
||||
--- common/slp_attr_l.l.orig 2005-05-26 20:00:07.000000000 +0100
|
||||
+++ common/slp_attr_l.l
|
||||
@@ -82,9 +82,9 @@ int slp_attr_wrap(void);
|
||||
|
||||
|
@ -9,7 +9,7 @@ $NetBSD: patch-ae,v 1.1 2004/11/27 04:41:12 jlam Exp $
|
|||
-void slp_attr_close_lexer(unsigned int handle);
|
||||
+void slp_attr_close_lexer(unsigned long handle);
|
||||
|
||||
-uint slp_attr_init_lexer(char *s);
|
||||
-unsigned int slp_attr_init_lexer(char *s);
|
||||
+unsigned long slp_attr_init_lexer(char *s);
|
||||
|
||||
|
||||
|
@ -23,11 +23,11 @@ $NetBSD: patch-ae,v 1.1 2004/11/27 04:41:12 jlam Exp $
|
|||
{
|
||||
memset(&buf[0], 0x00, 2052);
|
||||
strncpy(&buf[0], s, 2052);
|
||||
- return((uint)yy_scan_buffer(&buf[0], strlen(s) + 2));
|
||||
- return((unsigned int)yy_scan_buffer(&buf[0], strlen(s) + 2));
|
||||
+ return((unsigned long)yy_scan_buffer(&buf[0], strlen(s) + 2));
|
||||
}
|
||||
|
||||
-void attr_close_lexer(uint handle)
|
||||
-void attr_close_lexer(unsigned int handle)
|
||||
+void attr_close_lexer(unsigned long handle)
|
||||
{
|
||||
// assert(handle != 0);
|
||||
|
|
|
@ -1,36 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.1 2004/11/27 04:41:12 jlam Exp $
|
||||
|
||||
--- common/slp_filter_l.l.orig 2002-05-10 01:23:43.000000000 -0400
|
||||
+++ common/slp_filter_l.l
|
||||
@@ -76,9 +76,9 @@ static char buf[2052];
|
||||
|
||||
void slp_filter_error(char *, ...);
|
||||
|
||||
-void slp_filter_close_lexer(unsigned int handle);
|
||||
+void slp_filter_close_lexer(unsigned long handle);
|
||||
|
||||
-unsigned int slp_filter_init_lexer(const char *s);
|
||||
+unsigned long slp_filter_init_lexer(const char *s);
|
||||
|
||||
%}
|
||||
|
||||
@@ -150,16 +150,16 @@ not_reserved [^()\&|!=<>~\n]
|
||||
|
||||
%%
|
||||
|
||||
-void filter_close_lexer(unsigned int handle)
|
||||
+void filter_close_lexer(unsigned long handle)
|
||||
{
|
||||
yy_delete_buffer((YY_BUFFER_STATE)handle);
|
||||
}
|
||||
|
||||
-unsigned int slp_filter_init_lexer(const char *s)
|
||||
+unsigned long slp_filter_init_lexer(const char *s)
|
||||
{
|
||||
memset(&buf[0], 0x00, 2052);
|
||||
strncpy(&buf[0], s, 2048);
|
||||
- return((uint)yy_scan_buffer(&buf[0], strlen(s) + 2));
|
||||
+ return((unsigned long)yy_scan_buffer(&buf[0], strlen(s) + 2));
|
||||
}
|
||||
|
||||
void slp_filter_error(char *s, ...)
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.1 2004/11/27 04:41:12 jlam Exp $
|
||||
|
||||
--- common/slp_spi.c.orig 2002-09-10 00:38:25.000000000 -0400
|
||||
+++ common/slp_spi.c
|
||||
@@ -267,9 +267,9 @@ SLPSpiHandle SLPSpiOpen(const char* spif
|
||||
fp = fopen(spifile,"r");
|
||||
if(fp)
|
||||
{
|
||||
- result = xmalloc(sizeof(structSLPSpiHandle));
|
||||
+ result = xmalloc(sizeof(*result));
|
||||
if(result == 0) return 0;
|
||||
- memset(result, 0, sizeof(structSLPSpiHandle));
|
||||
+ memset(result, 0, sizeof(*result));
|
||||
|
||||
result->spifile = xstrdup(spifile);
|
||||
result->cacheprivate = cacheprivate;
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ah,v 1.1 2004/11/27 05:08:35 jlam Exp $
|
||||
$NetBSD: patch-ah,v 1.2 2005/05/26 20:14:21 adrianp Exp $
|
||||
|
||||
--- common/Makefile.am.orig 2003-02-13 00:19:57.000000000 -0500
|
||||
--- common/Makefile.am.orig 2005-05-26 20:10:45.000000000 +0100
|
||||
+++ common/Makefile.am
|
||||
@@ -21,6 +21,7 @@ libcommonlibslp_la_SOURCES = \
|
||||
slp_xmalloc.c \
|
||||
|
|
19
net/openslp/patches/patch-ai
Normal file
19
net/openslp/patches/patch-ai
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-ai,v 1.1 2005/05/26 20:14:21 adrianp Exp $
|
||||
|
||||
--- Makefile.am.orig 2005-02-25 21:37:57.000000000 +0000
|
||||
+++ Makefile.am
|
||||
@@ -21,10 +21,10 @@ install-data-local:
|
||||
if [ -f $$file ]; then true; \
|
||||
else cp -f $(srcdir)/etc/slp.spi $(DESTDIR)$(sysconfdir); \
|
||||
fi
|
||||
- rm -rf $(DESTDIR)$(DOC_DIR)
|
||||
- mkdir -p $(DESTDIR)$(DOC_DIR)
|
||||
- cp -r $(srcdir)/doc/* $(DESTDIR)$(DOC_DIR)
|
||||
- rm -rf `find $(DESTDIR)$(DOC_DIR) -name CVS`
|
||||
+# rm -rf $(DESTDIR)$(DOC_DIR)
|
||||
+# mkdir -p $(DESTDIR)$(DOC_DIR)
|
||||
+# cp -r $(srcdir)/doc/* $(DESTDIR)$(DOC_DIR)
|
||||
+# rm -rf `find $(DESTDIR)$(DOC_DIR) -name CVS`
|
||||
|
||||
dist-hook:
|
||||
-rm -rf `find $(distdir)/doc -name CVS`
|
Loading…
Reference in a new issue