Linux has <endian.h> not <sys/endian.h>.

This commit is contained in:
sbd 2013-04-01 09:26:07 +00:00
parent b3d75efb83
commit 2863ecee3f
2 changed files with 9 additions and 7 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.6 2012/03/02 15:32:02 hans Exp $
$NetBSD: distinfo,v 1.7 2013/04/01 09:26:07 sbd Exp $
SHA1 (electric-7.00.tar.gz) = 782652b078e81060928eadfae364cd74da07788e
RMD160 (electric-7.00.tar.gz) = c57a2e0a32e40d435e125cad6dfc5c1b98e9067b
Size (electric-7.00.tar.gz) = 4474722 bytes
SHA1 (patch-aa) = ca3aa5c28eef818dce61055daeedc1b7d2e9a8a7
SHA1 (patch-ab) = 368810e1dfc1a25cd450f7a3efa74a64b33d9c33
SHA1 (patch-ab) = 088f1318a39692534ebbf7313893a6420d49523f
SHA1 (patch-ac) = fac49d88feab792ff665686e9e4fc8a29caab471
SHA1 (patch-ad) = 6be5c47ead4bf023ef6215d7bce496a2f7abb5b0
SHA1 (patch-ae) = 095e56c085ae77d0615134b070082f6599a95280

View file

@ -1,12 +1,12 @@
$NetBSD: patch-ab,v 1.3 2012/03/02 15:32:02 hans Exp $
$NetBSD: patch-ab,v 1.4 2013/04/01 09:26:07 sbd Exp $
- not all !sparcs are little endian.
- don't assume /usr/local
--- src/include/config.h.orig Fri Jul 16 01:59:53 2004
--- src/include/config.h.orig 2004-07-16 01:59:53.000000000 +0000
+++ src/include/config.h
@@ -32,6 +32,19 @@
@@ -32,6 +32,21 @@
#ifndef _CONFIG_H_
#define _CONFIG_H_ 1
@ -19,6 +19,8 @@ $NetBSD: patch-ab,v 1.3 2012/03/02 15:32:02 hans Exp $
+#else
+#define BYTE_ORDER LITTLE_ENDIAN
+#endif
+#elif defined(__linux__)
+#include <endian.h>
+#else
+#include <sys/endian.h>
+#endif
@ -26,7 +28,7 @@ $NetBSD: patch-ab,v 1.3 2012/03/02 15:32:02 hans Exp $
/********************* MACHINE DETERMINATION *********************/
/* determine if it is Macintosh OS */
@@ -135,7 +148,7 @@
@@ -135,7 +150,7 @@
# ifndef USEQT
# include <X11/Intrinsic.h>
# endif
@ -35,7 +37,7 @@ $NetBSD: patch-ab,v 1.3 2012/03/02 15:32:02 hans Exp $
# define BYTES_SWAPPED 1 /* bytes are MSB first */
# endif
# define DIRSEP '/' /* directory separator */
@@ -143,31 +145,19 @@
@@ -143,31 +158,19 @@
# define MACFSTAG(x) 0
# define NONFILECH '?' /* character that cannot be in file name */
# define CADRCFILENAME x_(".cadrc") /* CAD startup file */