Fix build with newer GCC

This commit is contained in:
joerg 2011-11-24 14:08:05 +00:00
parent f63d786163
commit 287e312d76
7 changed files with 79 additions and 1 deletions

View file

@ -1,6 +1,12 @@
$NetBSD: distinfo,v 1.12 2008/04/27 06:36:02 wiz Exp $
$NetBSD: distinfo,v 1.13 2011/11/24 14:08:05 joerg Exp $
SHA1 (grhino-0.16.0.tar.gz) = ca76895fc2370995e4942aec98e4359ce5549925
RMD160 (grhino-0.16.0.tar.gz) = f91415e5263eec3837a2a0cb06b610f0ba64668f
Size (grhino-0.16.0.tar.gz) = 1172321 bytes
SHA1 (patch-aa) = 762ad3cffe3ab40a070cdf89f06d5b302a963965
SHA1 (patch-aiai.cc) = 01c99b4d16c9ead4a0c95c8e91a8111c59f9446d
SHA1 (patch-book.cc) = a120f2c718c85666dfe6acd76bb3b49a8e5863fa
SHA1 (patch-game.cc) = d6c0a2036653d1920f4b0ea9f770c00fd1718ada
SHA1 (patch-gen__book.cc) = 9cefade318b76df658d0d5959cc6378f5275a971
SHA1 (patch-gen__pattern.cc) = 90ef9ca71921e0a1bd86dcb5aacdad7a4d0aa360
SHA1 (patch-log__proc.h) = 058fc9c9052a5126c0de137ad0087c667bb663c4

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aiai.cc,v 1.1 2011/11/24 14:08:05 joerg Exp $
--- aiai.cc.orig 2011-11-24 01:17:40.000000000 +0000
+++ aiai.cc
@@ -29,6 +29,7 @@
#include <sys/wait.h>
#include <unistd.h>
#include <string.h>
+#include <stdlib.h>
#include <exception>
#include <stdexcept>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-book.cc,v 1.1 2011/11/24 14:08:05 joerg Exp $
--- book.cc.orig 2011-11-24 01:11:40.000000000 +0000
+++ book.cc
@@ -25,6 +25,7 @@
#include "rand.h"
#include "gtstream.h"
+#include <cstdlib>
#include <vector>
#include <iostream>
#include <stdexcept>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-game.cc,v 1.1 2011/11/24 14:08:05 joerg Exp $
--- game.cc.orig 2011-11-24 01:12:02.000000000 +0000
+++ game.cc
@@ -37,6 +37,7 @@
#include <sys/stat.h>
#include <unistd.h>
#include <fcntl.h>
+#include <stdlib.h>
#ifdef _
# undef _

View file

@ -0,0 +1,12 @@
$NetBSD: patch-gen__book.cc,v 1.1 2011/11/24 14:08:05 joerg Exp $
--- gen_book.cc.orig 2011-11-24 01:15:36.000000000 +0000
+++ gen_book.cc
@@ -20,6 +20,7 @@
#include "config.h"
+#include <cstring>
#include <fstream>
#include <sstream>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-gen__pattern.cc,v 1.1 2011/11/24 14:08:05 joerg Exp $
--- gen_pattern.cc.orig 2011-11-24 01:16:59.000000000 +0000
+++ gen_pattern.cc
@@ -23,6 +23,7 @@
#include <fstream>
#include <sstream>
+#include <string.h>
#include <math.h>
#include <unistd.h>
#include <fcntl.h>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-log__proc.h,v 1.1 2011/11/24 14:08:05 joerg Exp $
--- log_proc.h.orig 2011-11-24 01:12:41.000000000 +0000
+++ log_proc.h
@@ -25,6 +25,7 @@
#include <string>
#include <fstream>
#include <iomanip>
+#include <cstdlib>
#include "board.h"
#include "order.h"