Make this package build after the mk/wrapper changes.

Make sure that a temporary library name buffer is nul-terminated.
PKGREVISION++.
This commit is contained in:
kristerw 2004-10-08 23:33:35 +00:00
parent 24ad996db4
commit 28952648de
4 changed files with 38 additions and 17 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.8 2003/07/17 21:48:55 grant Exp $
# $NetBSD: Makefile,v 1.9 2004/10/08 23:33:35 kristerw Exp $
#
DISTNAME= dync-1.1
PKGREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.westley.demon.co.uk/src/

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2001/04/20 13:52:10 agc Exp $
$NetBSD: distinfo,v 1.3 2004/10/08 23:33:35 kristerw Exp $
SHA1 (dync-1.1.tar.gz) = 58e3412a2980574d935e64f72eb45f8d017b961c
Size (dync-1.1.tar.gz) = 24222 bytes
SHA1 (patch-aa) = 69bdfaddaa9a295182f971b23b4b948f8812cf74
SHA1 (patch-ab) = 4464e7c734461fd1c305e8cc7c788d52450821e9
SHA1 (patch-aa) = 0d83133b2b08ed625cd33af141b3373c6a90c3be
SHA1 (patch-ab) = 384f40628562c10741988d77043af73a7f5b66d9

View file

@ -1,16 +1,7 @@
$NetBSD: patch-aa,v 1.2 2000/08/24 22:55:21 wiz Exp $
$NetBSD: patch-aa,v 1.3 2004/10/08 23:33:35 kristerw Exp $
--- Makefile.in.orig Thu Aug 13 16:12:55 1998
+++ Makefile.in
@@ -15,7 +15,7 @@
CFLAGS= @CFLAGS@ -I. -I$(srcdir) -I$(INCDIR) \
-DCC_CMD=\"@CC_CMD@\" -DLDCONFIG_CMD=\"@LDCONFIG@\" -DLD_CMD=\"@LD@\" \
-DGREP_CMD=\"@GREP@\" -DFILE_CMD=\"@FILE_CMD@\"
-LIBS= @LIBS@
+LIBS= -Wl,-R. @LIBS@
OBJS= dync.o
EXE= dync
+++ Makefile.in Sat Oct 9 01:25:39 2004
@@ -32,8 +32,9 @@
@./$(EXE) -f tests/1.c root > tests/1.out
@diff tests/1.exp tests/1.out

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ab,v 1.1 2000/08/24 22:55:22 wiz Exp $
$NetBSD: patch-ab,v 1.2 2004/10/08 23:33:35 kristerw Exp $
--- dync.c.orig Thu Aug 13 17:21:13 1998
+++ dync.c
+++ dync.c Sat Oct 9 01:21:37 2004
@@ -147,7 +147,7 @@
{
char cmd[MaxCmdLen];
@ -11,3 +11,32 @@ $NetBSD: patch-ab,v 1.1 2000/08/24 22:55:22 wiz Exp $
}
/* print usage message and die */
@@ -166,8 +166,9 @@
main(int argc, char **argv)
{
char mainname[MaxFileNameLen];
- char basename[MaxFileNameLen];
+ char basename[MaxFileNameLen] = {0, };
char libname[MaxFileNameLen];
+ char fulllibname[MaxFileNameLen];
char file[MaxFileNameLen];
char cflags[MaxCmdLen];
char cmd[MaxCmdLen];
@@ -261,9 +262,15 @@
}
}
+ /* create absolute path to the shared lib */
+ if (getcwd(fulllibname, sizeof(fulllibname)) == NULL)
+ die("can't get working directory pathname");
+ strncat(fulllibname, "/", sizeof(fulllibname) - 1);
+ strncat(fulllibname, libname, sizeof(fulllibname) - 1);
+
/* get a handle on the shared lib */
- if ((handle = dlopen(libname, DL_LAZY)) == (void *) NULL) {
- die("can't dlopen `%s'", libname);
+ if ((handle = dlopen(fulllibname, DL_LAZY)) == (void *) NULL) {
+ die("can't dlopen `%s'", fulllibname);
}
/* remove the object file and shared object lib */