Changes 1.7.9.3:

* "git p4" (in contrib/) submit the changes to a wrong place when the
  "--use-client-spec" option is set.
* The config.mak.autogen generated by optional autoconf support tried
  to link the binary with -lintl even when libintl.h is missing from
  the system.
* When the filter driver exits before reading the content before the
  main git process writes the contents to be filtered to the pipe to
  it, the latter could be killed with SIGPIPE instead of ignoring
  such an event as an error.
* "git add --refresh <pathspec>" used to warn about unmerged paths
  outside the given pathspec.
* The bulk check-in codepath in "git add" streamed contents that
  needs smudge/clean filters without running them, instead of punting
  and delegating to the codepath to run filters after slurping
  everything to core.
* "git branch --with $that" assumed incorrectly that the user will never
  ask the question with nonsense value in $that.
* "git bundle create" produced a corrupt bundle file upon seeing
  commits with excessively long subject line.
* When a remote helper exits before reading the blank line from the
  main git process to signal the end of commands, the latter could be
  killed with SIGPIPE. Instead we should ignore such event as a
  non-error.
* The commit log template given with "git merge --edit" did not have
  a short instructive text like what "git commit" gives.
* "git rev-list --verify-objects -q" omitted the extra verification
  it needs to do over "git rev-list --objects -q" by mistake.
* "gitweb" used to drop warnings in the log file when "heads" view is
  accessed in a repository whose HEAD does not point at a valid
  branch.
* An invalid regular expression pattern given by an end user made
  "gitweb" to return garbled response.
This commit is contained in:
adam 2012-03-09 17:02:14 +00:00
parent 9c9edf879e
commit 28b71bb30c
7 changed files with 27 additions and 31 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.40 2012/02/28 17:13:09 gdt Exp $
# $NetBSD: Makefile,v 1.41 2012/03/09 17:02:14 adam Exp $
.include "../../devel/scmgit/Makefile.common"
PKGNAME= scmgit-base-${GIT_VERSION}
PKGREVISION= 1
COMMENT= GIT Tree History Storage Tool (base package)
PKG_DESTDIR_SUPPORT= user-destdir

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.28 2012/02/06 13:11:35 adam Exp $
@comment $NetBSD: PLIST,v 1.29 2012/03/09 17:02:14 adam Exp $
bin/git
bin/git-cvsserver
bin/git-receive-pack
@ -277,10 +277,5 @@ ${PLIST.gui}share/gitk/lib/msgs/ja.msg
${PLIST.gui}share/gitk/lib/msgs/pt_br.msg
${PLIST.gui}share/gitk/lib/msgs/ru.msg
${PLIST.gui}share/gitk/lib/msgs/sv.msg
share/gitweb/gitweb.cgi
share/gitweb/static/git-favicon.png
share/gitweb/static/git-logo.png
share/gitweb/static/gitweb.css
share/gitweb/static/gitweb.js
@pkgdir share/examples/scmgit/templates/branches
share/locale/is/LC_MESSAGES/git.mo

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.49 2012/02/23 15:16:24 gdt Exp $
$NetBSD: distinfo,v 1.50 2012/03/09 17:02:14 adam Exp $
SHA1 (git-1.7.9.2.tar.gz) = 7aff1048480a8637de94e8d82744d312c0b5e060
RMD160 (git-1.7.9.2.tar.gz) = af5a35d1630c2ea2472665f461953baaf3a42dfc
Size (git-1.7.9.2.tar.gz) = 3611846 bytes
SHA1 (patch-aa) = 08d1214d864ce00f829a40b931b2cc62e8e7fb25
SHA1 (git-1.7.9.3.tar.gz) = 6216153da1139c25cb96cfb4441eff327013ec4f
RMD160 (git-1.7.9.3.tar.gz) = 3f45d8262526dfbc576004b8f50a92a6c33cf4d6
Size (git-1.7.9.3.tar.gz) = 3615900 bytes
SHA1 (patch-aa) = ce4ba3241b44e81f9a39986008fbb361062f8470
SHA1 (patch-ac) = ae75c6ca3abb5edf688e4877f3df8b6c6297f091
SHA1 (patch-ae) = d420c0a1db0de77bd9713d066434981b20bd4299
SHA1 (patch-af) = d6c942f7d8a0fe0074ea3edb7e6d858354c85232

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.15 2012/02/14 22:46:36 gdt Exp $
$NetBSD: patch-aa,v 1.16 2012/03/09 17:02:14 adam Exp $
--- Makefile.orig 2012-02-14 19:01:35.000000000 +0000
--- Makefile.orig 2012-03-05 22:42:15.000000000 +0000
+++ Makefile
@@ -303,8 +303,6 @@ endif
@@ -307,8 +307,6 @@ endif
CFLAGS = -g -O2 -Wall
LDFLAGS =
@ -11,7 +11,7 @@ $NetBSD: patch-aa,v 1.15 2012/02/14 22:46:36 gdt Exp $
STRIP ?= strip
# Among the variables below, these:
@@ -339,13 +337,9 @@ pathsep = :
@@ -343,13 +341,9 @@ pathsep = :
export prefix bindir sharedir sysconfdir gitwebdir localedir
@ -25,7 +25,7 @@ $NetBSD: patch-aa,v 1.15 2012/02/14 22:46:36 gdt Exp $
RPMBUILD = rpmbuild
TCL_PATH = tclsh
TCLTK_PATH = wish
@@ -931,9 +925,10 @@ ifeq ($(uname_S),Darwin)
@@ -936,9 +929,10 @@ ifeq ($(uname_S),Darwin)
HAVE_DEV_TTY = YesPlease
endif
ifeq ($(uname_S),SunOS)
@ -37,7 +37,7 @@ $NetBSD: patch-aa,v 1.15 2012/02/14 22:46:36 gdt Exp $
SANE_TOOL_PATH = /usr/xpg6/bin:/usr/xpg4/bin
NO_STRCASESTR = YesPlease
NO_MEMMEM = YesPlease
@@ -975,8 +970,6 @@ ifeq ($(uname_S),SunOS)
@@ -980,8 +974,6 @@ ifeq ($(uname_S),SunOS)
NO_STRTOUMAX = YesPlease
GIT_TEST_CMP = cmp
endif
@ -46,7 +46,7 @@ $NetBSD: patch-aa,v 1.15 2012/02/14 22:46:36 gdt Exp $
BASIC_CFLAGS += -D__EXTENSIONS__ -D__sun__ -DHAVE_ALLOCA_H
endif
ifeq ($(uname_O),Cygwin)
@@ -1817,8 +1810,8 @@ DEFAULT_PAGER_CQ_SQ = $(subst ','\'',$(D
@@ -1843,8 +1835,8 @@ DEFAULT_PAGER_CQ_SQ = $(subst ','\'',$(D
BASIC_CFLAGS += -DDEFAULT_PAGER='$(DEFAULT_PAGER_CQ_SQ)'
endif
@ -57,3 +57,11 @@ $NetBSD: patch-aa,v 1.15 2012/02/14 22:46:36 gdt Exp $
export DIFF TAR INSTALL DESTDIR SHELL_PATH
@@ -2464,7 +2456,6 @@ ifndef NO_GETTEXT
endif
ifndef NO_PERL
$(MAKE) -C perl prefix='$(prefix_SQ)' DESTDIR='$(DESTDIR_SQ)' install
- $(MAKE) -C gitweb install
endif
ifndef NO_PYTHON
$(MAKE) -C git_remote_helpers prefix='$(prefix_SQ)' DESTDIR='$(DESTDIR_SQ)' install

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile.version,v 1.36 2012/03/01 05:46:06 apb Exp $
# $NetBSD: Makefile.version,v 1.37 2012/03/09 17:02:14 adam Exp $
#
# used by devel/scmgit/Makefile.common
# used by www/gitweb/Makefile
GIT_VERSION= 1.7.9.2
GIT_VERSION= 1.7.9.3

View file

@ -1,5 +1,4 @@
# $NetBSD: Makefile,v 1.10 2012/02/29 21:19:02 apb Exp $
#
# $NetBSD: Makefile,v 1.11 2012/03/09 17:02:14 adam Exp $
.include "../../devel/scmgit/Makefile.version"
@ -7,7 +6,6 @@ DISTNAME= git-${GIT_VERSION}
PKGNAME= ${DISTNAME:S/git/gitweb/}
CATEGORIES= www
MASTER_SITES= http://www.kernel.org/pub/software/scm/git/
EXTRACT_SUFX= .tar.gz
MAINTAINER= gdt@NetBSD.org
HOMEPAGE= http://git.or.cz/
@ -18,7 +16,8 @@ PKG_DESTDIR_SUPPORT= user-destdir
#DEPENDS+= apache{,2,22}-[0-9]*:../../www/apache22
DEPENDS+= scmgit-base>=${GIT_VERSION}:../../devel/scmgit-base
#EXTRACT_USING= gtar
DISTINFO_FILE= ${.CURDIR}/../../devel/scmgit-base/distinfo
USE_TOOLS+= gmake perl:run
BUILD_DIRS= gitweb

View file

@ -1,5 +0,0 @@
$NetBSD: distinfo,v 1.6 2012/03/01 05:42:20 apb Exp $
SHA1 (git-1.7.9.2.tar.gz) = 7aff1048480a8637de94e8d82744d312c0b5e060
RMD160 (git-1.7.9.2.tar.gz) = af5a35d1630c2ea2472665f461953baaf3a42dfc
Size (git-1.7.9.2.tar.gz) = 3611846 bytes