Use Dimension instead of int for the width and the height.
This makes the package work properly on NetBSD/macppc. Bump PKGREVISION.
This commit is contained in:
parent
f5039ff07b
commit
28fffdd7dc
3 changed files with 17 additions and 8 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.15 2005/07/15 18:27:48 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2005/08/23 10:26:17 hira Exp $
|
||||
|
||||
DISTNAME= xengine-1.0.1
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= benchmarks
|
||||
MASTER_SITES= ftp://ftp.lab.kdd.co.jp/Usenet/comp.sources.x/volume09/xengine/
|
||||
DISTFILES= part01.z patch1.z
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.4 2005/06/12 11:16:56 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.5 2005/08/23 10:26:17 hira Exp $
|
||||
|
||||
SHA1 (xengine/part01.z) = c56961f548c4b653f97075027069a8dec962da88
|
||||
RMD160 (xengine/part01.z) = 5f0f84378674ee32c17015ebe2e15477da0c1ba5
|
||||
|
@ -6,4 +6,4 @@ Size (xengine/part01.z) = 8176 bytes
|
|||
SHA1 (xengine/patch1.z) = b633b0e88389fbdd2b9c9f6243099043040dd4d1
|
||||
RMD160 (xengine/patch1.z) = ccf0c19d2456ec299575b0190248824506b9ca33
|
||||
Size (xengine/patch1.z) = 3506 bytes
|
||||
SHA1 (patch-aa) = 012f076447d69539c0ba02127f12d2a1d85a48f2
|
||||
SHA1 (patch-aa) = 1920656c8efbede334b067b7708bd4adf1912e2f
|
||||
|
|
|
@ -1,8 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.3 2005/06/12 11:16:56 wiz Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2005/08/23 10:26:17 hira Exp $
|
||||
|
||||
--- xengine.c.orig 2005-06-12 13:15:23.000000000 +0200
|
||||
+++ xengine.c
|
||||
@@ -180,13 +180,10 @@ redraw_callback(w, event, params, nparam
|
||||
--- xengine.c.orig 2005-08-23 12:01:39.000000000 +0900
|
||||
+++ xengine.c 2005-08-23 12:10:23.000000000 +0900
|
||||
@@ -35,7 +35,7 @@
|
||||
Widget toplevel, base, rpm_info, engine;
|
||||
GC gcPiston, gcShaft, gcCylinder, gcRoter, gcBack, gcDep, gcPre, gcEngine;
|
||||
Pixmap enginePixmap;
|
||||
-int width, height;
|
||||
+Dimension width, height;
|
||||
|
||||
String colors[] = {"gray", "lightseagreen", "dimgrey", "forestgreen", "black", "red", "cyan", "firebrick"};
|
||||
|
||||
@@ -180,13 +180,10 @@
|
||||
|
||||
Arg args[10];
|
||||
|
||||
|
|
Loading…
Reference in a new issue