Fix pthread linkage for silc option.
This commit is contained in:
parent
bf391c60e3
commit
29031afb9f
4 changed files with 34 additions and 25 deletions
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/07/28 12:10:43 gdt Exp $
|
||||
$NetBSD: distinfo,v 1.2 2007/08/04 13:30:25 joerg Exp $
|
||||
|
||||
SHA1 (pidgin-2.0.1.tar.bz2) = 1b88284bbe89300a4c7227b4ea0a6f907d36dea3
|
||||
RMD160 (pidgin-2.0.1.tar.bz2) = ea3d3a29bdad659a9a8c07a66365be51b42bcef8
|
||||
Size (pidgin-2.0.1.tar.bz2) = 7682458 bytes
|
||||
SHA1 (patch-aa) = 0de59792611d1b3265793a850a515d9ce220848c
|
||||
SHA1 (patch-aa) = 6c53ad95905f081792839ce32de3dbdd19b20fa9
|
||||
SHA1 (patch-ab) = cba3d381e62a5c4976467eee106a3700c4e771be
|
||||
SHA1 (patch-ac) = 02acb88c21a76fe9bfab688c476102b63215ba66
|
||||
SHA1 (patch-ac) = 0b1565ed6ce8f6c7500f65e6421c542c9337163b
|
||||
SHA1 (patch-ad) = c3ec5e83bd258a2cb1c7bb18337cd45c888dda04
|
||||
SHA1 (patch-ae) = 82cc41e44609480f30062f922ca6001d57336862
|
||||
SHA1 (patch-af) = 047d03f91ef386a92e302e7fa2c46ad2d08214e4
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.1.1.1 2007/07/28 12:10:43 gdt Exp $
|
||||
# $NetBSD: options.mk,v 1.2 2007/08/04 13:30:25 joerg Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.libpurple
|
||||
PKG_SUPPORTED_OPTIONS+= gnutls silc perl tcl debug dbus
|
||||
|
@ -27,6 +27,7 @@ PLIST_SUBST+= SILC=
|
|||
CONFIGURE_ARGS+= --with-silc-includes=${BUILDLINK_PREFIX.silc-toolkit}/include/silc
|
||||
CONFIGURE_ARGS+= --with-silc-libs=${BUILDLINK_PREFIX.silc-toolkit}/lib/silc
|
||||
. include "../../devel/silc-toolkit/buildlink3.mk"
|
||||
. include "../../mk/pthread.buildlink3.mk"
|
||||
.else
|
||||
PLIST_SUBST+= SILC="@comment "
|
||||
CONFIGURE_ARGS+= --disable-silc
|
||||
|
|
|
@ -1,12 +1,16 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2007/07/28 12:10:43 gdt Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2007/08/04 13:30:25 joerg Exp $
|
||||
|
||||
sys/param.h is required for definitions of NGROUPS, MAXLOGNAME, etc.
|
||||
Without this, lookup of sys/sysctl.h on NetBSD (and maybe other *BSD
|
||||
systems) does not work correctly.
|
||||
Those preprocessor symbols are also needed during the build.
|
||||
|
||||
--- configure.ac.orig 2007-05-25 18:28:21.000000000 +0200
|
||||
--- configure.ac.orig 2007-05-25 16:28:21.000000000 +0000
|
||||
+++ configure.ac
|
||||
@@ -683,7 +683,7 @@ else
|
||||
if test "$ac_silc_libs" != "no"; then
|
||||
SILC_LIBS="-L$ac_silc_libs"
|
||||
fi
|
||||
- SILC_LIBS="$SILC_LIBS -lsilc -lsilcclient -lpthread $LIBDL"
|
||||
+ SILC_LIBS="$SILC_LIBS -lsilc -lsilcclient ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS} $LIBDL"
|
||||
AC_CHECK_LIB(silcclient, silc_client_init, [silcclient=yes], , $SILC_LIBS)
|
||||
fi
|
||||
AC_SUBST(SILC_LIBS)
|
||||
@@ -1917,8 +1917,13 @@ AC_CHECK_FUNCS(memcpy memmove random str
|
||||
AC_CHECK_HEADERS(malloc.h paths.h sgtty.h stdarg.h sys/cdefs.h)
|
||||
AC_CHECK_HEADERS(sys/file.h sys/filio.h sys/ioctl.h sys/msgbuf.h)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2007/08/04 13:30:25 joerg Exp $
|
||||
|
||||
--- configure.orig 2007-05-25 18:29:17.000000000 +0200
|
||||
--- configure.orig 2007-05-25 16:29:17.000000000 +0000
|
||||
+++ configure
|
||||
@@ -1,27 +1,56 @@
|
||||
#! /bin/sh
|
||||
|
@ -19197,12 +19197,14 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
|
||||
fi
|
||||
if test $ac_cv_header_silcincludes_h = yes; then
|
||||
@@ -29001,8 +29470,8 @@ fi
|
||||
@@ -29000,9 +29469,9 @@ fi
|
||||
if test "$ac_silc_libs" != "no"; then
|
||||
SILC_LIBS="-L$ac_silc_libs"
|
||||
fi
|
||||
SILC_LIBS="$SILC_LIBS -lsilc -lsilcclient -lpthread $LIBDL"
|
||||
- SILC_LIBS="$SILC_LIBS -lsilc -lsilcclient -lpthread $LIBDL"
|
||||
- echo "$as_me:$LINENO: checking for silc_client_init in -lsilcclient" >&5
|
||||
-echo $ECHO_N "checking for silc_client_init in -lsilcclient... $ECHO_C" >&6
|
||||
+ SILC_LIBS="$SILC_LIBS -lsilc -lsilcclient ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS} $LIBDL"
|
||||
+ { echo "$as_me:$LINENO: checking for silc_client_init in -lsilcclient" >&5
|
||||
+echo $ECHO_N "checking for silc_client_init in -lsilcclient... $ECHO_C" >&6; }
|
||||
if test "${ac_cv_lib_silcclient_silc_client_init+set}" = set; then
|
||||
|
@ -27295,7 +27297,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
_ACEOF
|
||||
|
||||
cat >>$CONFIG_STATUS <<\_ACEOF
|
||||
@@ -37251,39 +37151,24 @@ while test $# != 0
|
||||
@@ -37251,39 +37151,26 @@ while test $# != 0
|
||||
do
|
||||
case $1 in
|
||||
--*=*)
|
||||
|
@ -27322,6 +27324,8 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
-_ACEOF
|
||||
-cat >>$CONFIG_STATUS <<\_ACEOF
|
||||
-recheck | --recheck | --rechec | --reche | --rech | --rec | --re | --r)
|
||||
+ : Avoid regenerating within pkgsrc
|
||||
+ exit 0
|
||||
ac_cs_recheck=: ;;
|
||||
- --version | --vers* | -V )
|
||||
- echo "$ac_cs_version"; exit 0 ;;
|
||||
|
@ -27341,7 +27345,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
debug=: ;;
|
||||
--file | --fil | --fi | --f )
|
||||
$ac_shift
|
||||
@@ -37293,18 +37178,24 @@ Try \`$0 --help' for more information."
|
||||
@@ -37293,18 +37180,24 @@ Try \`$0 --help' for more information."
|
||||
$ac_shift
|
||||
CONFIG_HEADERS="$CONFIG_HEADERS $ac_optarg"
|
||||
ac_need_defaults=false;;
|
||||
|
@ -27371,7 +27375,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
|
||||
esac
|
||||
shift
|
||||
@@ -37320,17 +37211,28 @@ fi
|
||||
@@ -37320,17 +37213,28 @@ fi
|
||||
_ACEOF
|
||||
cat >>$CONFIG_STATUS <<_ACEOF
|
||||
if \$ac_cs_recheck; then
|
||||
|
@ -27404,7 +27408,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
AMDEP_TRUE="$AMDEP_TRUE" ac_aux_dir="$ac_aux_dir"
|
||||
INTLTOOL_PERL='${INTLTOOL_PERL}' ac_aux_dir='${ac_aux_dir}'
|
||||
prefix="$prefix" exec_prefix="$exec_prefix" INTLTOOL_LIBDIR="$libdir"
|
||||
@@ -37341,136 +37243,137 @@ INTLTOOL_XGETTEXT='${INTLTOOL_XGETTEXT}'
|
||||
@@ -37341,136 +37245,137 @@ INTLTOOL_XGETTEXT='${INTLTOOL_XGETTEXT}'
|
||||
|
||||
_ACEOF
|
||||
|
||||
|
@ -27663,7 +27667,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
# If the user did not use the arguments to specify the items to instantiate,
|
||||
# then the envvar interface is used. Set only those that are not.
|
||||
# We use the long form for the default assignment because of an extremely
|
||||
@@ -37482,836 +37385,912 @@ if $ac_need_defaults; then
|
||||
@@ -37482,836 +37387,912 @@ if $ac_need_defaults; then
|
||||
fi
|
||||
|
||||
# Have a temporary directory for convenience. Make it in the build tree
|
||||
|
@ -29321,7 +29325,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
# Compute $ac_file's index in $config_headers.
|
||||
_am_stamp_count=1
|
||||
for _am_header in $config_headers :; do
|
||||
@@ -38322,135 +38301,39 @@ for _am_header in $config_headers :; do
|
||||
@@ -38322,135 +38303,39 @@ for _am_header in $config_headers :; do
|
||||
_am_stamp_count=`expr $_am_stamp_count + 1` ;;
|
||||
esac
|
||||
done
|
||||
|
@ -29483,7 +29487,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
# Strip MF so we end up with the name of the file.
|
||||
mf=`echo "$mf" | sed -e 's/:.*$//'`
|
||||
# Check whether this is an Automake generated Makefile or not.
|
||||
@@ -38458,20 +38341,32 @@ echo "$as_me: executing $ac_dest command
|
||||
@@ -38458,20 +38343,32 @@ echo "$as_me: executing $ac_dest command
|
||||
# some people rename them; so instead we look at the file content.
|
||||
# Grep'ing the first line is not enough: some people post-process
|
||||
# each Makefile.in and add a new line on top of each file to say so.
|
||||
|
@ -29526,7 +29530,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
else
|
||||
continue
|
||||
fi
|
||||
@@ -38493,49 +38388,76 @@ echo X"$mf" |
|
||||
@@ -38493,49 +38390,76 @@ echo X"$mf" |
|
||||
sed -e 's/\$(DEPDIR)/'"$DEPDIR"'/g' -e 's/\$U/'"$U"'/g'`; do
|
||||
# Make sure the directory exists.
|
||||
test -f "$dirpart/$file" && continue
|
||||
|
@ -29630,7 +29634,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
|
||||
for file in intltool-extract intltool-merge intltool-update; do
|
||||
sed -e "s|@INTLTOOL_EXTRACT@|`pwd`/intltool-extract|g" \
|
||||
@@ -38556,10 +38478,10 @@ for file in intltool-extract intltool-me
|
||||
@@ -38556,10 +38480,10 @@ for file in intltool-extract intltool-me
|
||||
done
|
||||
|
||||
;;
|
||||
|
@ -29643,7 +29647,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2007/07/28 12:10:45 gdt Exp $
|
|||
rm -f "po/stamp-it" "po/stamp-it.tmp" "po/POTFILES" "po/Makefile.tmp"
|
||||
>"po/stamp-it.tmp"
|
||||
sed '/^#/d
|
||||
@@ -38582,11 +38504,10 @@ echo "$as_me: error: po/Makefile is not
|
||||
@@ -38582,11 +38506,10 @@ echo "$as_me: error: po/Makefile is not
|
||||
rm -f "po/Makefile.tmp"
|
||||
mv "po/stamp-it.tmp" "po/stamp-it"
|
||||
;;
|
||||
|
|
Loading…
Reference in a new issue