Changes 6.17.00:

I am pleased to announce that tcsh-6.17 is now available; this is a mainly a
bug fix release with the exception of these three feature additions:
 10. always save the whole command, not just the first 80 chars of it.
  4. Add autoexpand=onlyhistory (Don Estabrook, m66)
  3. Add history in loops (Laurence Darby, m48)
Please consult the Fixes files for a complete list of changes.
This commit is contained in:
adam 2010-03-14 14:06:09 +00:00
parent befe3715e4
commit 290cedecc0
3 changed files with 27 additions and 18 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.66 2009/08/15 23:43:26 zafer Exp $
# $NetBSD: Makefile,v 1.67 2010/03/14 14:06:09 adam Exp $
DISTNAME= tcsh-6.16.00
DISTNAME= tcsh-6.17.00
CATEGORIES= shells
MASTER_SITES= ftp://ftp.astron.com/pub/tcsh/ \
ftp://ftp.funet.fi/pub/unix/shells/tcsh/
@ -35,12 +35,12 @@ post-install:
cp ${PKGDIR}/PLIST ${PLIST_SRC}
set -e; \
if [ -f ${WRKSRC}/tcsh.C.cat ]; \
then \
[ -d ${DESTDIR}${PREFIX:Q}/${NLSDIR:Q}/C ] || \
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX:Q}/${NLSDIR:Q}/C;\
${INSTALL_DATA} ${WRKSRC:Q}/tcsh.C.cat \
${DESTDIR}${PREFIX}/${NLSDIR:Q}/C/tcsh.cat; \
${ECHO} ${NLSDIR:Q}/C/tcsh.cat >> ${PLIST_SRC:Q}; \
then \
[ -d ${DESTDIR}${PREFIX}/${NLSDIR}/C ] || \
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/${NLSDIR}/C; \
${INSTALL_DATA} ${WRKSRC}/tcsh.C.cat \
${DESTDIR}${PREFIX}/${NLSDIR}/C/tcsh.cat; \
${ECHO} ${NLSDIR}/C/tcsh.cat >> ${PLIST_SRC}; \
for i in \
et:ISO_8859-15:et:EE \
finnish:ISO_8859-1:fi:FI \
@ -65,7 +65,7 @@ post-install:
o=; \
while [ $$# -gt 0 ]; \
do \
d=${NLSDIR:Q}/$${c}_$$1.$${s}; \
d=${NLSDIR}/$${c}_$$1.$${s}; \
[ -d ${DESTDIR}${PREFIX}/$$d ] || \
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/$$d; \
if [ -z "$$o" ]; \

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.24 2008/11/10 09:45:43 adam Exp $
$NetBSD: distinfo,v 1.25 2010/03/14 14:06:09 adam Exp $
SHA1 (tcsh-6.16.00.tar.gz) = 3d3536bbb9201abdf39b8b364b95e0a218970a5c
RMD160 (tcsh-6.16.00.tar.gz) = ed23351273bb737c184658235f33869488e64696
Size (tcsh-6.16.00.tar.gz) = 886468 bytes
SHA1 (patch-aa) = 5ba012bfa662b57be300f5e81a8fcce44b218e72
SHA1 (tcsh-6.17.00.tar.gz) = 9bf67d5ce1b406178e9ba535ecd34553fe0d4d36
RMD160 (tcsh-6.17.00.tar.gz) = 2cc41a895799ade6d62640f877bb626f136dac35
Size (tcsh-6.17.00.tar.gz) = 890084 bytes
SHA1 (patch-aa) = bd2c3a5814b17675c56618feae9184548e40c0d0
SHA1 (patch-ab) = ab71a3826bbcef0702a7d43446f13454176aa671

View file

@ -1,8 +1,17 @@
$NetBSD: patch-aa,v 1.10 2007/04/11 04:56:56 christos Exp $
$NetBSD: patch-aa,v 1.11 2010/03/14 14:06:09 adam Exp $
--- Makefile.in.orig 2007-04-09 20:02:33.000000000 -0400
+++ Makefile.in 2007-04-09 20:04:47.000000000 -0400
@@ -512,17 +512,10 @@
--- Makefile.in.orig 2009-06-24 22:09:05.000000000 +0000
+++ Makefile.in
@@ -278,7 +278,7 @@ P=
prefix=@prefix@
exec_prefix=@exec_prefix@
bindir=@bindir@
-mandir=@datarootdir@/man
+mandir=@mandir@
MANSECT=1
DESTBIN=${DESTDIR}${bindir}
DESTMAN=${DESTDIR}${mandir}/man${MANSECT}
@@ -512,17 +512,10 @@ vgrind:
install-strip: install
install: tcsh$(EXEEXT)