Update to version 3.4.6

Changes:

Version 3.4.6 - 2006-04-25

- fixed opening sites with explicitly specified port (it could
  either use default port or spin).
- fixed ftps over http proxy with CONNECT method.

Version 3.4.5 - 2006-04-22

- handle ftp PRET errors.
- send ssh password twice if needed, this fixes a problem with
  encoded secret keys.
- updated programming examples.
- fixed cross-references between jobs/tasks libraries and lftp.

Version 3.4.4 - 2006-04-06

- new setting mirror:dereference.
- new exit options: top, kill.
- fixed stalling when uploading empty files with ftps.
- fixed lftp exit code when cmd:at-exit is set.
- fixed a rare spinning.

Version 3.4.3 - 2006-03-15

- don't create target file when source file does not exist.
- show done jobs before exit.
- changed default for http:use-propfind to no.
- fixed condition for getting exact time for cls.
- fixed coredump with non-absolute http redirection.
- fixed coredump when exiting lftp with a done job.

Version 3.4.2 - 2006-02-08

- fixed a coredump in cls (option parsing).
- import TIME_STYLE environment variable to cmd:time-style.

Version 3.4.1 - 2006-02-07

- new cls option --time-style, new setting cmd:time-style.
- use PROPFIND first to check directory existence (http).
- fixed CCC - don't try to shutdown ssl connection gracefully.
- fixed an abortion when completing with cmd:remote-completion
  set to false.
This commit is contained in:
salo 2006-05-01 18:53:31 +00:00
parent add245e282
commit 2911e3f2b2
3 changed files with 14 additions and 15 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.67 2006/02/05 23:10:26 joerg Exp $
# $NetBSD: Makefile,v 1.68 2006/05/01 18:53:31 salo Exp $
DISTNAME= lftp-3.4.0
PKGREVISION= 2
DISTNAME= lftp-3.4.6
CATEGORIES= net
MASTER_SITES= http://ftp.yars.free.net/pub/source/lftp/ \
ftp://ftp.iasi.roedu.net/pub/os/Linux/network/ftp/lftp/ \

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.34 2006/02/01 16:41:32 salo Exp $
$NetBSD: distinfo,v 1.35 2006/05/01 18:53:31 salo Exp $
SHA1 (lftp-3.4.0.tar.bz2) = afd968153ed337badb9f91528bacdb082cf0c800
RMD160 (lftp-3.4.0.tar.bz2) = df93b1f75fe71a4dea8d6f2e5175d9f08bdc0d4d
Size (lftp-3.4.0.tar.bz2) = 1275055 bytes
SHA1 (patch-aa) = 601d2beffb72613d385565b00d88f84f1c4bb09a
SHA1 (lftp-3.4.6.tar.bz2) = af1ec8e4b9d24e9b9f2e408e2a3018d2e60eeb7e
RMD160 (lftp-3.4.6.tar.bz2) = 4d3e5192d1bd7abbe4bd897031e6e0afd50830e0
Size (lftp-3.4.6.tar.bz2) = 1272334 bytes
SHA1 (patch-aa) = ca8957b1f3535faaaf5780866857a8a853eed115
SHA1 (patch-ab) = d230522c60786a2bcbce346419d8dfce412578d3
SHA1 (patch-ac) = 8000bf8b44b39b7f87e9d7c89bcb513aa5150753

View file

@ -1,17 +1,17 @@
$NetBSD: patch-aa,v 1.9 2006/02/01 16:41:32 salo Exp $
$NetBSD: patch-aa,v 1.10 2006/05/01 18:53:31 salo Exp $
--- src/Makefile.in.orig 2005-12-31 12:13:40.000000000 +0100
+++ src/Makefile.in 2006-02-01 17:20:39.000000000 +0100
@@ -364,7 +364,7 @@
--- src/Makefile.in.orig 2006-04-25 08:20:34.000000000 +0200
+++ src/Makefile.in 2006-05-01 19:52:34.000000000 +0200
@@ -392,7 +392,7 @@
localedir = $(datadir)/locale
pkgverlibdir = $(pkglibdir)/$(VERSION)
bin_SCRIPTS = lftpget
-pkgdata_SCRIPTS = import-ncftp import-netscape verify-file convert-netscape-cookies
+pkgdata_SCRIPTS = import-ncftp import-netscape
noinst_SCRIPTS = ftpget
EXTRA_DIST = $(pkgdata_SCRIPTS) $(bin_SCRIPTS) $(noinst_SCRIPTS) \
example1.cc example2.cc
@@ -881,7 +881,7 @@
EXTRA_DIST = $(pkgdata_SCRIPTS) $(bin_SCRIPTS) $(noinst_SCRIPTS)
lftp_SOURCES = lftp.cc complete.h complete.cc lftp_rl.c lftp_rl.h
@@ -955,7 +955,7 @@
install-binPROGRAMS: install-libLTLIBRARIES
installdirs: