Prefer C++11 interfaces over tr1.

This commit is contained in:
joerg 2013-05-06 14:52:54 +00:00
parent 08ec26ec84
commit 29304156ef
16 changed files with 328 additions and 37 deletions

View file

@ -1,16 +1,26 @@
$NetBSD: distinfo,v 1.2 2012/07/03 17:42:05 joerg Exp $
$NetBSD: distinfo,v 1.3 2013/05/06 14:52:54 joerg Exp $
SHA1 (openfst-1.1.tar.gz) = b070f84a981dfadc4c049f505bd3406a43dfa55d
RMD160 (openfst-1.1.tar.gz) = 45657bb11f91ffdce5261ff6f4c103c164cc161b
Size (openfst-1.1.tar.gz) = 513404 bytes
SHA1 (patch-src_bin_compile-main.h) = b0f77cf8876acea5597b0ddb622dcddc52103cf0
SHA1 (patch-src_include_fst_cache.h) = 6a29b49f07b61a0ed9d9e2349805b836c45a25bc
SHA1 (patch-src_include_fst_compact-fst.h) = f1a2b9ec65d3c8be4d0574c96fa5e5a52c9e680c
SHA1 (patch-src_include_fst_compose.h) = 4fb25482929aecf37e69d9b6c23491f5512554f8
SHA1 (patch-src_include_fst_config.h.in) = 6c1eba23afe7d30026b37b9e7cf7c6552778c3e4
SHA1 (patch-src_include_fst_const-fst.h) = 758b60a5238f9f6f4a1a5a05c5abc41d81faa3a2
SHA1 (patch-src_include_fst_determinize.h) = 825ad312b52933d981a1ea8dd7103da90b1f3e80
SHA1 (patch-src_include_fst_determinize.h) = c0ec374166a57c3df97cab25b5ec87231ec86df5
SHA1 (patch-src_include_fst_difference.h) = e66c128b621d1be4f9b7501d969cd2097f32aa04
SHA1 (patch-src_include_fst_factor-weight.h) = 88229131e6de6daf950f85db32b1dbcbf4507733
SHA1 (patch-src_include_fst_map.h) = 7c46539d7b72f1f24ea275bfff1678bbb64f932c
SHA1 (patch-src_include_fst_replace.h) = 87604a022040f3f825eede69c36917b37b515cda
SHA1 (patch-src_include_fst_synchronize.h) = 8a43aab991bf48f1e656d4e47dea8f0326d12773
SHA1 (patch-src_include_fst_encode.h) = ad9c3662b63dc40a40fa827fa011ea8332f04962
SHA1 (patch-src_include_fst_epsnormalize.h) = 1bee82d16fab4bdb4d635eb27aa22f9573d57fb9
SHA1 (patch-src_include_fst_equivalent.h) = dbc925b9de2b859a0a5493db4e5823dc8ed57e6c
SHA1 (patch-src_include_fst_factor-weight.h) = 311911d8308cdc073cffa2a2d0a52202330c4324
SHA1 (patch-src_include_fst_map.h) = 61faf469de577c944d2e66c10f1b877619ae0889
SHA1 (patch-src_include_fst_relabel.h) = 6fce070b426dfbcfb2aa89c05daec96b03cd6349
SHA1 (patch-src_include_fst_replace.h) = 2f8984463d5f083d3bc1fa439dc1a88e27f1954f
SHA1 (patch-src_include_fst_rmepsilon.h) = e371a2145c571378a49b707710b9ab5cc592f352
SHA1 (patch-src_include_fst_rmfinalepsilon.h) = fb1834d54a343982eb433f6c7ffddf1315a2b797
SHA1 (patch-src_include_fst_slist.h) = c63321cf232ec861ec07dc0c26a9c5c773c35f49
SHA1 (patch-src_include_fst_synchronize.h) = aed6efedd865bda3a881d5516487c4abdac36217
SHA1 (patch-src_include_fst_test-properties.h) = d82a8e542a8afbe10a7232c12a22a724a9fe0a0c
SHA1 (patch-src_include_fst_vector-fst.h) = 51178b6757e89e5c18807ec8521223dacaeb6c16

View file

@ -0,0 +1,20 @@
$NetBSD: patch-src_bin_compile-main.h,v 1.1 2013/05/06 14:53:16 joerg Exp $
--- src/bin/compile-main.h.orig 2013-05-03 17:26:20.000000000 +0000
+++ src/bin/compile-main.h
@@ -22,8 +22,15 @@
#ifndef FST_COMPILE_MAIN_H__
#define FST_COMPILE_MAIN_H__
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_map>
+using std::unordered_map;
+#else
#include <tr1/unordered_map>
using std::tr1::unordered_map;
+#endif
#include <sstream>
#include <string>
#include <vector>

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_include_fst_config.h.in,v 1.1 2013/05/06 14:53:16 joerg Exp $
--- src/include/fst/config.h.in.orig 2013-05-03 17:47:24.000000000 +0000
+++ src/include/fst/config.h.in
@@ -2,7 +2,7 @@
/* Define to 1 if the system has the type `std::tr1::hash<long long
unsigned>'. */
-#define HAVE_STD__TR1__HASH_LONG_LONG_UNSIGNED_ 1
+#undef HAVE_STD__TR1__HASH_LONG_LONG_UNSIGNED_
/* Define to 1 if the system has the type `__gnu_cxx::slist<int>'. */
-#define HAVE___GNU_CXX__SLIST_INT_ 1
+#undef HAVE___GNU_CXX__SLIST_INT_

View file

@ -1,8 +1,27 @@
$NetBSD: patch-src_include_fst_determinize.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
$NetBSD: patch-src_include_fst_determinize.h,v 1.2 2013/05/06 14:52:54 joerg Exp $
--- src/include/fst/determinize.h.orig 2012-07-03 09:55:10.000000000 +0000
--- src/include/fst/determinize.h.orig 2009-03-21 03:35:33.000000000 +0000
+++ src/include/fst/determinize.h
@@ -171,7 +171,7 @@ class DeterminizeFstImplBase : public Ca
@@ -21,9 +21,17 @@
#ifndef FST_LIB_DETERMINIZE_H__
#define FST_LIB_DETERMINIZE_H__
-#include <algorithm>
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_map>
+using std::unordered_map;
+#else
#include <tr1/unordered_map>
using std::tr1::unordered_map;
+#endif
+
+#include <algorithm>
#include <map>
#include <fst/slist.h>
#include <string>
@@ -171,7 +179,7 @@ class DeterminizeFstImplBase : public Ca
if (!HasStart()) {
StateId start = ComputeStart();
if (start != kNoStateId) {
@ -11,7 +30,7 @@ $NetBSD: patch-src_include_fst_determinize.h,v 1.1 2012/07/03 17:42:05 joerg Exp
}
}
return CacheImpl<A>::Start();
@@ -180,7 +180,7 @@ class DeterminizeFstImplBase : public Ca
@@ -180,7 +188,7 @@ class DeterminizeFstImplBase : public Ca
Weight Final(StateId s) {
if (!HasFinal(s)) {
Weight final = ComputeFinal(s);
@ -20,7 +39,7 @@ $NetBSD: patch-src_include_fst_determinize.h,v 1.1 2012/07/03 17:42:05 joerg Exp
}
return CacheImpl<A>::Final(s);
}
@@ -363,7 +363,7 @@ class DeterminizeFsaImpl : public Determ
@@ -363,7 +371,7 @@ class DeterminizeFsaImpl : public Determ
liter != label_map.end();
++liter)
AddArc(s, liter->first, liter->second);

View file

@ -0,0 +1,20 @@
$NetBSD: patch-src_include_fst_encode.h,v 1.1 2013/05/06 14:53:16 joerg Exp $
--- src/include/fst/encode.h.orig 2013-05-03 17:23:12.000000000 +0000
+++ src/include/fst/encode.h
@@ -20,8 +20,15 @@
#ifndef FST_LIB_ENCODE_H__
#define FST_LIB_ENCODE_H__
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_map>
+using std::unordered_map;
+#else
#include <tr1/unordered_map>
using std::tr1::unordered_map;
+#endif
#include <string>
#include <vector>
#include <fst/map.h>

View file

@ -0,0 +1,21 @@
$NetBSD: patch-src_include_fst_epsnormalize.h,v 1.1 2013/05/06 14:53:16 joerg Exp $
--- src/include/fst/epsnormalize.h.orig 2013-05-03 17:30:15.000000000 +0000
+++ src/include/fst/epsnormalize.h
@@ -20,8 +20,16 @@
#ifndef FST_LIB_EPSNORMALIZE_H__
#define FST_LIB_EPSNORMALIZE_H__
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_map>
+using std::unordered_map;
+#else
#include <tr1/unordered_map>
using std::tr1::unordered_map;
+#endif
+
#include <fst/slist.h>
#include <fst/factor-weight.h>

View file

@ -0,0 +1,20 @@
$NetBSD: patch-src_include_fst_equivalent.h,v 1.1 2013/05/06 14:53:16 joerg Exp $
--- src/include/fst/equivalent.h.orig 2013-05-03 17:31:26.000000000 +0000
+++ src/include/fst/equivalent.h
@@ -22,8 +22,15 @@
#include <algorithm>
#include <deque>
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_map>
+using std::unordered_map;
+#else
#include <tr1/unordered_map>
using std::tr1::unordered_map;
+#endif
#include <utility>
#include <vector>
#include <fst/encode.h>

View file

@ -1,8 +1,27 @@
$NetBSD: patch-src_include_fst_factor-weight.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
$NetBSD: patch-src_include_fst_factor-weight.h,v 1.2 2013/05/06 14:52:54 joerg Exp $
--- src/include/fst/factor-weight.h.orig 2012-07-03 09:54:33.000000000 +0000
--- src/include/fst/factor-weight.h.orig 2009-03-21 03:35:33.000000000 +0000
+++ src/include/fst/factor-weight.h
@@ -215,7 +215,7 @@ class FactorWeightFstImpl
@@ -20,9 +20,17 @@
#ifndef FST_LIB_FACTOR_WEIGHT_H__
#define FST_LIB_FACTOR_WEIGHT_H__
-#include <algorithm>
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_map>
+using std::unordered_map;
+#else
#include <tr1/unordered_map>
using std::tr1::unordered_map;
+#endif
+
+#include <algorithm>
#include <fst/slist.h>
#include <string>
#include <utility>
@@ -215,7 +223,7 @@ class FactorWeightFstImpl
if (s == kNoStateId)
return kNoStateId;
StateId start = FindState(Element(fst_->Start(), Weight::One()));
@ -11,7 +30,7 @@ $NetBSD: patch-src_include_fst_factor-weight.h,v 1.1 2012/07/03 17:42:05 joerg E
}
return CacheImpl<A>::Start();
}
@@ -229,9 +229,9 @@ class FactorWeightFstImpl
@@ -229,9 +237,9 @@ class FactorWeightFstImpl
: (Weight) Times(e.weight, fst_->Final(e.state));
FactorIterator f(w);
if (!(mode_ & kFactorFinalWeights) || f.Done())
@ -23,7 +42,7 @@ $NetBSD: patch-src_include_fst_factor-weight.h,v 1.1 2012/07/03 17:42:05 joerg E
}
return CacheImpl<A>::Final(s);
}
@@ -298,13 +298,13 @@ class FactorWeightFstImpl
@@ -298,13 +306,13 @@ class FactorWeightFstImpl
FactorIterator fit(w);
if (!(mode_ & kFactorArcWeights) || fit.Done()) {
StateId d = FindState(Element(arc.nextstate, Weight::One()));
@ -39,7 +58,7 @@ $NetBSD: patch-src_include_fst_factor-weight.h,v 1.1 2012/07/03 17:42:05 joerg E
}
}
}
@@ -322,10 +322,10 @@ class FactorWeightFstImpl
@@ -322,10 +330,10 @@ class FactorWeightFstImpl
const pair<Weight, Weight> &p = fit.Value();
StateId d = FindState(Element(kNoStateId,
p.second.Quantize(delta_)));

View file

@ -1,8 +1,24 @@
$NetBSD: patch-src_include_fst_map.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
$NetBSD: patch-src_include_fst_map.h,v 1.2 2013/05/06 14:52:54 joerg Exp $
--- src/include/fst/map.h.orig 2012-07-03 09:55:26.000000000 +0000
--- src/include/fst/map.h.orig 2009-03-21 03:35:34.000000000 +0000
+++ src/include/fst/map.h
@@ -336,7 +336,7 @@ class MapFstImpl : public CacheImpl<B> {
@@ -21,8 +21,15 @@
#ifndef FST_LIB_MAP_H__
#define FST_LIB_MAP_H__
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_map>
+using std::unordered_map;
+#else
#include <tr1/unordered_map>
using std::tr1::unordered_map;
+#endif
#include <string>
#include <utility>
#include <fst/cache.h>
@@ -336,7 +343,7 @@ class MapFstImpl : public CacheImpl<B> {
StateId Start() {
if (!HasStart())
@ -11,7 +27,7 @@ $NetBSD: patch-src_include_fst_map.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
return CacheImpl<B>::Start();
}
@@ -348,24 +348,24 @@ class MapFstImpl : public CacheImpl<B> {
@@ -348,24 +355,24 @@ class MapFstImpl : public CacheImpl<B> {
B final_arc = (*mapper_)(A(0, 0, fst_->Final(FindIState(s)),
kNoStateId));
CHECK(final_arc.ilabel == 0 && final_arc.olabel == 0);
@ -41,7 +57,7 @@ $NetBSD: patch-src_include_fst_map.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
break;
}
}
@@ -399,14 +399,14 @@ class MapFstImpl : public CacheImpl<B> {
@@ -399,14 +406,14 @@ class MapFstImpl : public CacheImpl<B> {
void Expand(StateId s) {
// Add exiting arcs.
@ -58,7 +74,7 @@ $NetBSD: patch-src_include_fst_map.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
}
// Check for superfinal arcs.
@@ -422,7 +422,7 @@ class MapFstImpl : public CacheImpl<B> {
@@ -422,7 +429,7 @@ class MapFstImpl : public CacheImpl<B> {
if (superfinal_ == kNoStateId)
superfinal_ = nstates_++;
final_arc.nextstate = superfinal_;
@ -67,7 +83,7 @@ $NetBSD: patch-src_include_fst_map.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
}
break;
}
@@ -431,12 +431,12 @@ class MapFstImpl : public CacheImpl<B> {
@@ -431,12 +438,12 @@ class MapFstImpl : public CacheImpl<B> {
kNoStateId));
if (final_arc.ilabel != 0 || final_arc.olabel != 0 ||
final_arc.weight != B::Weight::Zero())

View file

@ -0,0 +1,20 @@
$NetBSD: patch-src_include_fst_relabel.h,v 1.1 2013/05/06 14:53:16 joerg Exp $
--- src/include/fst/relabel.h.orig 2013-05-03 17:35:08.000000000 +0000
+++ src/include/fst/relabel.h
@@ -20,8 +20,15 @@
#ifndef FST_LIB_RELABEL_H__
#define FST_LIB_RELABEL_H__
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_map>
+using std::unordered_map;
+#else
#include <tr1/unordered_map>
using std::tr1::unordered_map;
+#endif
#include <string>
#include <utility>
#include <vector>

View file

@ -1,8 +1,24 @@
$NetBSD: patch-src_include_fst_replace.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
$NetBSD: patch-src_include_fst_replace.h,v 1.2 2013/05/06 14:52:54 joerg Exp $
--- src/include/fst/replace.h.orig 2012-07-03 10:02:47.000000000 +0000
--- src/include/fst/replace.h.orig 2009-03-21 03:35:34.000000000 +0000
+++ src/include/fst/replace.h
@@ -424,16 +424,16 @@ class ReplaceFstImpl : public CacheImpl<
@@ -21,8 +21,15 @@
#ifndef FST_LIB_REPLACE_H__
#define FST_LIB_REPLACE_H__
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_map>
+using std::unordered_map;
+#else
#include <tr1/unordered_map>
using std::tr1::unordered_map;
+#endif
#include <string>
#include <utility>
#include <vector>
@@ -424,16 +431,16 @@ class ReplaceFstImpl : public CacheImpl<
// return final weight of state (kInfWeight means state is not final)
Weight Final(StateId s) {
@ -22,7 +38,7 @@ $NetBSD: patch-src_include_fst_replace.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
}
return CacheImpl<A>::Final(s);
}
@@ -471,7 +471,7 @@ class ReplaceFstImpl : public CacheImpl<
@@ -471,7 +478,7 @@ class ReplaceFstImpl : public CacheImpl<
const Fst<A>* fst = fst_array_[tuple.fst_id];
StateId fst_state = tuple.fst_state;
if (fst_state == kNoStateId) {
@ -31,7 +47,7 @@ $NetBSD: patch-src_include_fst_replace.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
return;
}
@@ -483,7 +483,7 @@ class ReplaceFstImpl : public CacheImpl<
@@ -483,7 +490,7 @@ class ReplaceFstImpl : public CacheImpl<
StateId nextstate = state_table_->FindState(
StateTuple(prefix_id, top.fst_id, top.nextstate));
@ -40,7 +56,7 @@ $NetBSD: patch-src_include_fst_replace.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
}
// extend arcs leaving the state
@@ -493,7 +493,7 @@ class ReplaceFstImpl : public CacheImpl<
@@ -493,7 +500,7 @@ class ReplaceFstImpl : public CacheImpl<
if (arc.olabel == 0) { // expand local fst
StateId nextstate = state_table_->FindState(
StateTuple(tuple.prefix_id, tuple.fst_id, arc.nextstate));
@ -49,7 +65,7 @@ $NetBSD: patch-src_include_fst_replace.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
} else {
// check for non terminal
typename NonTerminalHash::const_iterator it =
@@ -511,17 +511,17 @@ class ReplaceFstImpl : public CacheImpl<
@@ -511,17 +518,17 @@ class ReplaceFstImpl : public CacheImpl<
StateId nt_nextstate = state_table_->FindState(
StateTuple(nt_prefix, nonterminal, nt_start));
Label ilabel = (epsilon_on_replace_) ? 0 : arc.ilabel;

View file

@ -0,0 +1,20 @@
$NetBSD: patch-src_include_fst_rmepsilon.h,v 1.1 2013/05/06 14:53:17 joerg Exp $
--- src/include/fst/rmepsilon.h.orig 2013-05-03 17:30:43.000000000 +0000
+++ src/include/fst/rmepsilon.h
@@ -20,8 +20,15 @@
#ifndef FST_LIB_RMEPSILON_H__
#define FST_LIB_RMEPSILON_H__
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_map>
+using std::unordered_map;
+#else
#include <tr1/unordered_map>
using std::tr1::unordered_map;
+#endif
#include <fst/slist.h>
#include <stack>
#include <string>

View file

@ -0,0 +1,20 @@
$NetBSD: patch-src_include_fst_rmfinalepsilon.h,v 1.1 2013/05/06 14:53:17 joerg Exp $
--- src/include/fst/rmfinalepsilon.h.orig 2013-05-03 17:24:31.000000000 +0000
+++ src/include/fst/rmfinalepsilon.h
@@ -20,8 +20,15 @@
#ifndef FST_LIB_RMFINALEPSILON_H__
#define FST_LIB_RMFINALEPSILON_H__
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_set>
+using std::unordered_set;
+#else
#include <tr1/unordered_set>
using std::tr1::unordered_set;
+#endif
#include <vector>
#include <fst/connect.h>

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_include_fst_slist.h,v 1.1 2013/05/06 14:53:17 joerg Exp $
--- src/include/fst/slist.h.orig 2013-05-03 17:49:34.000000000 +0000
+++ src/include/fst/slist.h
@@ -47,7 +47,7 @@ template <typename T> class slist : publ
iterator erase_after(iterator pos) {
iterator npos = pos;
- erase(++npos);
+ this->erase(++npos);
return pos;
}
};

View file

@ -1,8 +1,31 @@
$NetBSD: patch-src_include_fst_synchronize.h,v 1.1 2012/07/03 17:42:05 joerg Exp $
$NetBSD: patch-src_include_fst_synchronize.h,v 1.2 2013/05/06 14:52:54 joerg Exp $
--- src/include/fst/synchronize.h.orig 2012-07-03 10:05:34.000000000 +0000
--- src/include/fst/synchronize.h.orig 2009-03-21 03:35:34.000000000 +0000
+++ src/include/fst/synchronize.h
@@ -111,7 +111,7 @@ class SynchronizeFstImpl
@@ -20,11 +20,21 @@
#ifndef FST_LIB_SYNCHRONIZE_H__
#define FST_LIB_SYNCHRONIZE_H__
-#include <algorithm>
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_map>
+using std::unordered_map;
+#include <unordered_set>
+using std::unordered_set;
+#else
#include <tr1/unordered_map>
using std::tr1::unordered_map;
#include <tr1/unordered_set>
using std::tr1::unordered_set;
+#endif
+
+#include <algorithm>
#include <string>
#include <utility>
#include <vector>
@@ -111,7 +121,7 @@ class SynchronizeFstImpl
return kNoStateId;
const String *empty = FindString(new String());
StateId start = FindState(Element(fst_->Start(), empty, empty));
@ -11,7 +34,7 @@ $NetBSD: patch-src_include_fst_synchronize.h,v 1.1 2012/07/03 17:42:05 joerg Exp
}
return CacheImpl<A>::Start();
}
@@ -121,9 +121,9 @@ class SynchronizeFstImpl
@@ -121,9 +131,9 @@ class SynchronizeFstImpl
const Element &e = elements_[s];
Weight w = e.state == kNoStateId ? Weight::One() : fst_->Final(e.state);
if ((w != Weight::Zero()) && (e.istring)->empty() && (e.ostring)->empty())
@ -23,7 +46,7 @@ $NetBSD: patch-src_include_fst_synchronize.h,v 1.1 2012/07/03 17:42:05 joerg Exp
}
return CacheImpl<A>::Final(s);
}
@@ -230,13 +230,13 @@ class SynchronizeFstImpl
@@ -230,13 +240,13 @@ class SynchronizeFstImpl
const String *istring = Cdr(e.istring, arc.ilabel);
const String *ostring = Cdr(e.ostring, arc.olabel);
StateId d = FindState(Element(arc.nextstate, istring, ostring));
@ -39,7 +62,7 @@ $NetBSD: patch-src_include_fst_synchronize.h,v 1.1 2012/07/03 17:42:05 joerg Exp
}
}
@@ -246,9 +246,9 @@ class SynchronizeFstImpl
@@ -246,9 +256,9 @@ class SynchronizeFstImpl
const String *istring = Cdr(e.istring);
const String *ostring = Cdr(e.ostring);
StateId d = FindState(Element(kNoStateId, istring, ostring));

View file

@ -0,0 +1,20 @@
$NetBSD: patch-src_include_fst_test-properties.h,v 1.1 2013/05/06 14:53:17 joerg Exp $
--- src/include/fst/test-properties.h.orig 2013-05-03 17:21:06.000000000 +0000
+++ src/include/fst/test-properties.h
@@ -20,8 +20,15 @@
#ifndef FST_LIB_TEST_PROPERTIES_H__
#define FST_LIB_TEST_PROPERTIES_H__
+#include <ciso646>
+
+#if defined(_LIBCPP_VERSION) || __cplusplus >= 201103L
+#include <unordered_set>
+using std::unordered_set;
+#else
#include <tr1/unordered_set>
using std::tr1::unordered_set;
+#endif
#include <fst/mutable-fst.h>
#include <fst/dfs-visit.h>
#include <fst/connect.h>