Fix build with newer GCC

This commit is contained in:
joerg 2011-11-24 14:13:19 +00:00
parent 9152d30ab6
commit 2935f479ee
3 changed files with 28 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.4 2009/03/24 16:22:57 abs Exp $
$NetBSD: distinfo,v 1.5 2011/11/24 14:13:19 joerg Exp $
SHA1 (mlview-0.9.0.tar.bz2) = 1e2d8e03747ffaaacbf9db15e8a7dabf573cee22
RMD160 (mlview-0.9.0.tar.bz2) = 6b810b478dbdb76dd4bb28fe627e455410f89ea7
@ -9,3 +9,5 @@ SHA1 (patch-ac) = 64ef210c50aee3b9a424850d42749d84ca177778
SHA1 (patch-ad) = bbc891000735b51873d1d0933e4bb329b7cd490e
SHA1 (patch-ae) = c3ae0179ffc01facfa6114268659a367a94e70a8
SHA1 (patch-af) = 7634baf770bc177c3d9a9bcca9924880c4fd08da
SHA1 (patch-src_mlview-ustring.cc) = 0c141d13fe86782aaeb067873c3b89cdb6cadd20
SHA1 (patch-src_mlview-validator.cc) = af10ed1f94a483fc1c66266d12c2251a6be3abac

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_mlview-ustring.cc,v 1.1 2011/11/24 14:13:19 joerg Exp $
--- src/mlview-ustring.cc.orig 2011-11-24 02:25:01.000000000 +0000
+++ src/mlview-ustring.cc
@@ -59,7 +59,7 @@ UString::UString (const Glib::ustring &a
UString::~UString ()
{}
-UString::UString&
+UString&
UString::operator= (const char *a_cstr)
{
if (!a_cstr)

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_mlview-validator.cc,v 1.1 2011/11/24 14:13:19 joerg Exp $
--- src/mlview-validator.cc.orig 2011-11-24 02:26:56.000000000 +0000
+++ src/mlview-validator.cc
@@ -25,6 +25,7 @@
#include "mlview-validator.h"
#include "mlview-safe-ptr-utils.h"
+#include <memory>
#define MESSAGE_LINE_LENGTH 55
namespace mlview