leptonica: updated to 1.79.0
1.79.0: * Clean up auto-generation of files; removed 'register' * Some fixes for issues identified by fuzzer * New source files: checkerboard.c * New programs: replacebytes.c, webpanimio_reg.c, partifytest.c, rectangle_reg.c, lowsat_reg.c, rotate_it.c, scale_it.c, dewarp_it.c, pdfio1_reg.c, pdfio2_reg.c, checkerboard_reg.c, underlinetest.c. * Convert to standard reg test: heap_reg.c, pixa1_reg.c, smallpix_reg.c * Improve data checking when reading image file headers (pnm, png, jpeg, tiff) * Fix some bugs in pnm reading * Fix inconsistencies with the encoding type flags in pdf writing * Allow tiff to write images with colormaps * Fix errors in PS code; made some functions static * Add code for animated webp (requires webp mux and demux libraries) * Add "partify" application for separating parts in a musical score * Enable tif read/write of gray+alpha and rgba; filter out tiff pixels that are not uint and compression by tile * Apply consistent formatting of static const variables * Add programs for scaling, rotation and deskew, named dewkew_it, rotate_it and scale_it, for useful operations on arbitrary images. * Convert pdfiotest program to two regression tests: pdfio1_reg and pdfio2_reg. * Remove all use of strncat; use stringCat(). * New functions from removing outliers in sequences of boxes. * Generalize pixAverageInRect(): mask, region and range filters, and subsampling. New pixAverageInRectRGB(). * Fix int overflow bug in pixMedianCut(); required new heap accessor. * New pixMultiplyGray() allows pix to be multiplied by an array (or another pix) * Better routines for counting color. * Lossless conversion for RGB to cmap with not more than 256 colors. * New histo based global thresholding: pixThresholdByHisto(). * Allow most reg tests to run even if external libraries are not available. * New one-line gplot functions that return a pix. * New application to find where corners meet in a checkerboard. * Add utility functions for painting through mask in cmap pix, creating a hit-miss sela from a color pix, equality of two pta. * Proper handling of 1 bpp colormap tiffs: remove when reading, preserve when writing. * Deprecate three pixSaveTile*() functions; removed all calls to these from the library and progs. * Include auto_config.h explicitly in all src and prog files. * Improve input data checking for bmp files.
This commit is contained in:
parent
5bcb888c58
commit
29542b0dfb
4 changed files with 26 additions and 10 deletions
|
@ -1,16 +1,15 @@
|
|||
# $NetBSD: Makefile,v 1.16 2019/03/22 08:23:04 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.17 2020/01/02 12:55:07 adam Exp $
|
||||
|
||||
DISTNAME= leptonica-1.78.0
|
||||
DISTNAME= leptonica-1.79.0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=danbloomberg/}
|
||||
GITHUB_RELEASE= ${PKGVERSION_NOREV}
|
||||
|
||||
MAINTAINER= adam@NetBSD.org
|
||||
HOMEPAGE= http://www.leptonica.org/
|
||||
COMMENT= Software for image processing and image analysis applications
|
||||
LICENSE= 2-clause-bsd
|
||||
|
||||
GITHUB_RELEASE= ${PKGVERSION_NOREV}
|
||||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2019/03/22 08:23:04 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 2020/01/02 12:55:07 adam Exp $
|
||||
bin/convertfilestopdf
|
||||
bin/convertfilestops
|
||||
bin/convertformat
|
||||
|
@ -40,5 +40,7 @@ include/leptonica/stack.h
|
|||
include/leptonica/stringcode.h
|
||||
include/leptonica/sudoku.h
|
||||
include/leptonica/watershed.h
|
||||
lib/cmake/LeptonicaConfig-version.cmake
|
||||
lib/cmake/LeptonicaConfig.cmake
|
||||
lib/liblept.la
|
||||
lib/pkgconfig/lept.pc
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.14 2019/03/22 08:23:04 adam Exp $
|
||||
$NetBSD: distinfo,v 1.15 2020/01/02 12:55:07 adam Exp $
|
||||
|
||||
SHA1 (leptonica-1.78.0.tar.gz) = ab387b6ae0a3358017c277aac1cd6985c8501a35
|
||||
RMD160 (leptonica-1.78.0.tar.gz) = 6ab179da9136d719a89a6847c45ce89791d3b841
|
||||
SHA512 (leptonica-1.78.0.tar.gz) = f059ccc8e7b5ff2c796aeb4ab18bd25e133ec4f38c36b9e2ee203db35a1e68cf45b8baf78ebc4acba4e3607328d1374ea0e8425f35cbe06c6c5728a1ec8c3f50
|
||||
Size (leptonica-1.78.0.tar.gz) = 12905925 bytes
|
||||
SHA1 (leptonica-1.79.0.tar.gz) = be08309753e949ae9321aeca802a2f6f72d5f2a3
|
||||
RMD160 (leptonica-1.79.0.tar.gz) = b5d535994fad46ddfd2b67c707b79f08070265d7
|
||||
SHA512 (leptonica-1.79.0.tar.gz) = 4d0830683757004bb47752a17985d80c6758b97c0fd6ec64d23bbf43c9c68b04bee751831574afa4c25f5d5030c0c9f7fc22d9fc8ef932aa990401344f588ba5
|
||||
Size (leptonica-1.79.0.tar.gz) = 13438669 bytes
|
||||
SHA1 (patch-src_Makefile.in) = 6a412f514c630c5bea12f6ec228796c6f942acc2
|
||||
|
|
14
graphics/leptonica/patches/patch-src_Makefile.in
Normal file
14
graphics/leptonica/patches/patch-src_Makefile.in
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-src_Makefile.in,v 1.1 2020/01/02 12:55:07 adam Exp $
|
||||
|
||||
Do not create libleptonica.* links.
|
||||
|
||||
--- src/Makefile.in.orig 2019-12-31 22:17:02.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -1196,7 +1196,6 @@ info-am:
|
||||
|
||||
install-data-am: install-pkgincludeHEADERS
|
||||
@$(NORMAL_INSTALL)
|
||||
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
||||
install-dvi: install-dvi-am
|
||||
|
||||
install-dvi-am:
|
Loading…
Reference in a new issue