- install for all npapi browsers

- include <stdlib.h> for free()
This commit is contained in:
tnn 2009-09-22 13:23:57 +00:00
parent 9821b7a1b9
commit 29a6ad028b
5 changed files with 20 additions and 8 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.21 2009/08/26 19:58:05 sno Exp $
# $NetBSD: Makefile,v 1.22 2009/09/22 13:23:57 tnn Exp $
#
DISTNAME= gnash-${VER}
VER= 0.8.3
PKGREVISION= 5
PKGREVISION= 6
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_GNU:=gnash/${VER}/}
EXTRACT_SUFX= .tar.bz2
@ -19,7 +19,6 @@ USE_LANGUAGES= c c++
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
USE_TOOLS+= bash gmake msgfmt pkg-config
CONFIGURE_ARGS+= --with-npapi-plugindir=${PREFIX}/lib/firefox/plugins
# for appending below
INSTALL_TARGET= install

View file

@ -1,3 +1,3 @@
@comment $NetBSD: PLIST.gtk,v 1.1 2008/04/27 06:44:52 wiz Exp $
@comment $NetBSD: PLIST.gtk,v 1.2 2009/09/22 13:23:57 tnn Exp $
bin/gtk-gnash
lib/firefox/plugins/libgnashplugin.so
lib/netscape/plugins/libgnashplugin.so

View file

@ -1,9 +1,10 @@
$NetBSD: distinfo,v 1.13 2008/09/15 19:54:58 abs Exp $
$NetBSD: distinfo,v 1.14 2009/09/22 13:23:57 tnn Exp $
SHA1 (gnash-0.8.3.tar.bz2) = 3cd4a0930e772a42b0155295fca292fd94be7c42
RMD160 (gnash-0.8.3.tar.bz2) = f7bf4d06d35c3ad40df4419b179fc6482731854b
Size (gnash-0.8.3.tar.bz2) = 2902610 bytes
SHA1 (patch-aa) = 05460170941019168fa072c803ad60eac919e44a
SHA1 (patch-ab) = b86c152618ed4258bede5d95f71446db3af8ad0f
SHA1 (patch-ac) = 6454620529a281c707f7ccf68eb17c0754dfe7a7
SHA1 (patch-ae) = d4f18032bc091e5ef84fcb81f16ea649c5c20701
SHA1 (patch-ag) = f4f82df7bff71464cdb3a76b91c4b2475a8e9eef

View file

@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.10 2008/09/11 18:27:24 ahoka Exp $
# $NetBSD: options.mk,v 1.11 2009/09/22 13:23:57 tnn Exp $
#
#
@ -22,7 +22,7 @@ PKG_SUGGESTED_OPTIONS+= agg gstreamer gtk mitshm
.if !empty(PKG_OPTIONS:Mgtk)
GNASH_GUIS+= gtk
PLIST_SRC+= ${PKGDIR}/PLIST.gtk
CONFIGURE_ARGS+= --with-npapi-plugindir=${PREFIX}/lib/firefox/plugins
CONFIGURE_ARGS+= --with-npapi-plugindir=${PREFIX}/lib/netscape/plugins
INSTALL_TARGET+= install-plugin
.include "../../x11/gtk2/buildlink3.mk"
.endif

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.6 2009/09/22 13:23:57 tnn Exp $
--- libbase/utility.h.orig 2008-06-06 22:07:55.000000000 +0200
+++ libbase/utility.h
@@ -29,6 +29,7 @@
#include <typeinfo>
#include <cmath>
#include <boost/cstdint.hpp>
+#include <stdlib.h>
#if defined(__GNUC__) && __GNUC__ > 2
# include <cxxabi.h>