Disambiguate pow.
This commit is contained in:
parent
02a34a2acc
commit
29b8707c9c
3 changed files with 47 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.12 2015/11/03 01:12:39 agc Exp $
|
$NetBSD: distinfo,v 1.13 2020/05/26 11:25:02 joerg Exp $
|
||||||
|
|
||||||
SHA1 (libvisual-plugins-0.4.0.tar.gz) = 20490573c282d900ec0bd05133cb3707640254f5
|
SHA1 (libvisual-plugins-0.4.0.tar.gz) = 20490573c282d900ec0bd05133cb3707640254f5
|
||||||
RMD160 (libvisual-plugins-0.4.0.tar.gz) = f7a82f4a9e4dec3e877833612ece570ffbf2404d
|
RMD160 (libvisual-plugins-0.4.0.tar.gz) = f7a82f4a9e4dec3e877833612ece570ffbf2404d
|
||||||
|
@ -12,5 +12,7 @@ SHA1 (patch-ae) = ce54b7682f0d7a184a15392ee8f3a7cd2510be13
|
||||||
SHA1 (patch-af) = 35e2b6517a7c7bd5605fd6593a113f184d8dc1b3
|
SHA1 (patch-af) = 35e2b6517a7c7bd5605fd6593a113f184d8dc1b3
|
||||||
SHA1 (patch-plugins_actor_G-Force_Common_GeneralTools_UtilStr.cpp) = 6dfb4d2d8ba5ed6be37523b66515df630bfba604
|
SHA1 (patch-plugins_actor_G-Force_Common_GeneralTools_UtilStr.cpp) = 6dfb4d2d8ba5ed6be37523b66515df630bfba604
|
||||||
SHA1 (patch-plugins_actor_G-Force_Common_UI_LineXX.cpp) = f0e527dd7bc2918fbab00846cbf3c7c882ba82eb
|
SHA1 (patch-plugins_actor_G-Force_Common_UI_LineXX.cpp) = f0e527dd7bc2918fbab00846cbf3c7c882ba82eb
|
||||||
|
SHA1 (patch-plugins_actor_G-Force_GForceCommon_G-Force.cpp) = 3db98e9132c816383060b526c87f57f3caa00b1b
|
||||||
|
SHA1 (patch-plugins_actor_G-Force_GForceCommon_WaveShape.cpp) = 84d1ed2e062f136aef268ed9445aabdc2a42080c
|
||||||
SHA1 (patch-plugins_actor_corona_corona.cpp) = 89292f12be75a59a62f7a52c660a1146fda8f1e5
|
SHA1 (patch-plugins_actor_corona_corona.cpp) = 89292f12be75a59a62f7a52c660a1146fda8f1e5
|
||||||
SHA1 (patch-plugins_morph_flash_morph__flash_c) = 94d696aa43213fa43fb98a563cdc040d5fe9a92c
|
SHA1 (patch-plugins_morph_flash_morph__flash_c) = 94d696aa43213fa43fb98a563cdc040d5fe9a92c
|
||||||
|
|
|
@ -0,0 +1,22 @@
|
||||||
|
$NetBSD: patch-plugins_actor_G-Force_GForceCommon_G-Force.cpp,v 1.1 2020/05/26 11:25:02 joerg Exp $
|
||||||
|
|
||||||
|
--- plugins/actor/G-Force/GForceCommon/G-Force.cpp.orig 2020-05-26 00:17:08.719115589 +0000
|
||||||
|
+++ plugins/actor/G-Force/GForceCommon/G-Force.cpp
|
||||||
|
@@ -624,7 +624,7 @@ void GForce::ManageColorChanges() {
|
||||||
|
// If in a ColorMap transition/morph then we must set mColorTrans, for it's linked into mGF_Palette
|
||||||
|
if ( mColorTransTime > 0 ) {
|
||||||
|
float t = (float) ( mColorTransEnd - mT_MS ) / ( (float) mColorTransTime );
|
||||||
|
- mColorTrans = pow( t, TRANSITION_ALPHA );
|
||||||
|
+ mColorTrans = pow( t, float(TRANSITION_ALPHA) );
|
||||||
|
}
|
||||||
|
|
||||||
|
// Evaluate the palette at this time
|
||||||
|
@@ -983,7 +983,7 @@ void GForce::RecordSample( long inCurTim
|
||||||
|
// Is the text is about to expire? if not, continue drawing.
|
||||||
|
if ( t <= 1 ) {
|
||||||
|
|
||||||
|
- intensity = 255.5 * pow( t, 1.5 );
|
||||||
|
+ intensity = 255.5 * pow( t, 1.5f );
|
||||||
|
mCurPort -> SetTextColor( mPalette[ intensity ] );
|
||||||
|
mCurPort -> SetTrackTextFont();
|
||||||
|
mCurPort -> DrawText( mTrackTextPos.h, mTrackTextPos.v, mTrackText ); }
|
|
@ -0,0 +1,22 @@
|
||||||
|
$NetBSD: patch-plugins_actor_G-Force_GForceCommon_WaveShape.cpp,v 1.1 2020/05/26 11:25:02 joerg Exp $
|
||||||
|
|
||||||
|
--- plugins/actor/G-Force/GForceCommon/WaveShape.cpp.orig 2020-05-26 00:18:26.285232815 +0000
|
||||||
|
+++ plugins/actor/G-Force/GForceCommon/WaveShape.cpp
|
||||||
|
@@ -202,7 +202,7 @@ void WaveShape::Draw( long inNumSteps, P
|
||||||
|
else {
|
||||||
|
w2Waves = inWave2 -> mNumWaves;
|
||||||
|
dialate = inMorphPct;
|
||||||
|
- mShapeTrans = pow( dialate, SHAPE_MORPH_ALPHA );
|
||||||
|
+ mShapeTrans = pow( dialate, float(SHAPE_MORPH_ALPHA) );
|
||||||
|
SetupFrame( inWave2, mShapeTrans );
|
||||||
|
|
||||||
|
if ( mNumWaves > w2Waves ) {
|
||||||
|
@@ -212,7 +212,7 @@ void WaveShape::Draw( long inNumSteps, P
|
||||||
|
maxWaves = w2Waves;
|
||||||
|
|
||||||
|
// Set the wave scale factor to the wave leaving/arriving
|
||||||
|
- dialate = 20.0 * pow( dialate, 4.0 ) + 1.0;
|
||||||
|
+ dialate = 20.0 * pow( dialate, 4.0f ) + 1.0;
|
||||||
|
|
||||||
|
// Calc the x and y scale factors for wave 2
|
||||||
|
xscaleW2 = xoff;
|
Loading…
Reference in a new issue