u-boot & u-boot-pinecube: fix pinecube builds

As of py-setuptools 69.0, PEP 440 versioning is strictly enforced, so
builds that invoked pylibfdt were failing with a version string that
included "u-boot-" in it.
This commit is contained in:
gutteridge 2023-12-18 21:57:35 +00:00
parent 7847f83e08
commit 29b9ae18be
3 changed files with 23 additions and 6 deletions

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2023/10/24 22:11:15 wiz Exp $
# $NetBSD: Makefile,v 1.3 2023/12/18 21:57:35 gutteridge Exp $
UBOOT_TARGET= pinecube
UBOOT_CONFIG= pinecube_defconfig
@ -8,12 +8,12 @@ UBOOT_INSTALLBOOT_PLIST= installboot.plist
UBOOT_VERSION= 2022.04
PKGREVISION= 1
.include "../../mk/bsd.prefs.mk"
PKGREVISION= 1
# u-boot-arm.mk must be before bsd.prefs.mk so that PATCHDIR is set correctly.
.include "../../sysutils/u-boot/u-boot-arm.mk"
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "Darwin"
.include "../../security/openssl/buildlink3.mk"
.endif
.include "../../sysutils/u-boot/u-boot-arm.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo-2022.04,v 1.1 2022/07/10 16:32:43 brook Exp $
$NetBSD: distinfo-2022.04,v 1.2 2023/12/18 21:57:35 gutteridge Exp $
BLAKE2s (u-boot-2022.04.tar.bz2) = f30bb94e07143168fc352e2840e4c8517716b90dfbedb196cc26c4d2c4e5b88a
SHA512 (u-boot-2022.04.tar.bz2) = 113056e542db049eea3b1d1ccbbe52c79539a2f9bb6129d284ec9200dcffec7bd5969821913a9899631575b80991c84ad01bc845b4bba614e42e54466d9f0d64
Size (u-boot-2022.04.tar.bz2) = 17772787 bytes
SHA1 (patch-scripts_dtc_pylibfdt_Makefile) = fc3fb6c2aa6ad8e71aecb30839c9e474adcf5229

View File

@ -0,0 +1,16 @@
$NetBSD: patch-scripts_dtc_pylibfdt_Makefile,v 1.1 2023/12/18 21:57:35 gutteridge Exp $
Fix build with py-setuptools >= 69.0, which strictly enforces PEP 440
versioning.
--- scripts/dtc/pylibfdt/Makefile.orig 2022-01-10 13:46:34.000000000 -0500
+++ scripts/dtc/pylibfdt/Makefile
@@ -17,7 +17,7 @@
cmd_pymod = unset CROSS_COMPILE; unset CFLAGS; \
CC="$(HOSTCC)" LDSHARED="$(HOSTCC) -shared " \
LDFLAGS="$(HOSTLDFLAGS)" \
- VERSION="u-boot-$(UBOOTVERSION)" \
+ VERSION="$(UBOOTVERSION)" \
CPPFLAGS="$(HOSTCFLAGS) -I$(LIBFDT_srcdir)" OBJDIR=$(obj) \
SOURCES="$(PYLIBFDT_srcs)" \
SWIG_OPTS="-I$(LIBFDT_srcdir) -I$(LIBFDT_srcdir)/.." \