Patch "configure" to explicitly disable search for libg++.

This commit is contained in:
fredb 1999-09-13 21:20:33 +00:00
parent dd2c0bbe2d
commit 29c3fca0e7
2 changed files with 77 additions and 10 deletions

View file

@ -1,7 +1,7 @@
$NetBSD: patch-sum,v 1.2 1999/07/16 21:11:03 jlam Exp $
$NetBSD: patch-sum,v 1.3 1999/09/13 21:20:33 fredb Exp $
MD5 (patch-aa) = a6827fdf571e7aefa149b94accb44b4a
MD5 (patch-ab) = a960999fafabcf952e65ef51b76b97a5
MD5 (patch-ab) = 336064d47267bc61ed2541c56711fe1f
MD5 (patch-ac) = 546d83d15d2279277a6c77e754dbb93a
MD5 (patch-ad) = 8f9e20face0c55074e54bf7176252a7d
MD5 (patch-ae) = dad6ffedeff83e83afadeac434fa9972

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ab,v 1.5 1999/07/16 18:43:48 jlam Exp $
$NetBSD: patch-ab,v 1.6 1999/09/13 21:20:34 fredb Exp $
--- configure.orig Thu Feb 12 18:46:01 1998
+++ configure Thu Jul 15 03:09:54 1999
--- configure.orig Thu Feb 12 17:46:01 1998
+++ configure Mon Sep 13 15:33:07 1999
@@ -1628,6 +1628,7 @@
test -z "$cf_dir" && cf_dir=/usr/man
cf_rename=""
@ -28,7 +28,74 @@ $NetBSD: patch-ab,v 1.5 1999/07/16 18:43:48 jlam Exp $
debug) DFT_DEP_SUFFIX='_g.a' ;;
profile) DFT_DEP_SUFFIX='_p.a' ;;
shared)
@@ -5310,7 +5313,7 @@
@@ -4842,36 +4845,37 @@
cross_compiling=$ac_cv_prog_cxx_cross
-cf_cxx_library=unknown
-if test $ac_cv_prog_gxx = yes; then
- echo $ac_n "checking for libg++""... $ac_c" 1>&6
-echo "configure:4849: checking for libg++" >&5
- cf_save="$LIBS"
- LIBS="$LIBS -lg++ -lm"
- cat > conftest.$ac_ext <<EOF
-#line 4853 "configure"
-#include "confdefs.h"
-
-#include <builtin.h>
-
-int main() {
-float foo=abs(1.0)
-; return 0; }
-EOF
-if { (eval echo configure:4862: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
- rm -rf conftest*
- cf_cxx_library=yes
- CXXLIBS="$CXXLIBS -lg++ -lm"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- cf_cxx_library=no
-fi
-rm -f conftest*
- LIBS="$cf_save"
+cf_cxx_library=no
+#cf_cxx_library=unknown
+#if test $ac_cv_prog_gxx = yes; then
+# echo $ac_n "checking for libg++""... $ac_c" 1>&6
+#echo "configure:4849: checking for libg++" >&5
+# cf_save="$LIBS"
+# LIBS="$LIBS -lg++ -lm"
+# cat > conftest.$ac_ext <<EOF
+##line 4853 "configure"
+##include "confdefs.h"
+#
+##include <builtin.h>
+#
+#int main() {
+#float foo=abs(1.0)
+#; return 0; }
+#EOF
+#if { (eval echo configure:4862: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+# rm -rf conftest*
+# cf_cxx_library=yes
+# CXXLIBS="$CXXLIBS -lg++ -lm"
+#else
+# echo "configure: failed program was:" >&5
+# cat conftest.$ac_ext >&5
+# rm -rf conftest*
+# cf_cxx_library=no
+#fi
+#rm -f conftest*
+# LIBS="$cf_save"
echo "$ac_t""$cf_cxx_library" 1>&6
-fi
+#fi
echo $ac_n "checking how to run the C++ preprocessor""... $ac_c" 1>&6
echo "configure:4878: checking how to run the C++ preprocessor" >&5
@@ -5310,7 +5314,7 @@
# dependencies and linker-arguments for test-programs
TEST_DEPS="${LIB_PREFIX}${LIB_NAME}${DFT_DEP_SUFFIX} $TEST_DEPS"
@ -37,7 +104,7 @@ $NetBSD: patch-ab,v 1.5 1999/07/16 18:43:48 jlam Exp $
# dependencies and linker-arguments for utility-programs
PROG_ARGS="$TEST_ARGS"
@@ -5353,16 +5356,13 @@
@@ -5353,16 +5357,13 @@
EOF
TEST_DEPS="${LIB_PREFIX}${cf_dir}${DFT_DEP_SUFFIX} $TEST_DEPS"
@ -56,7 +123,7 @@ $NetBSD: patch-ab,v 1.5 1999/07/16 18:43:48 jlam Exp $
SRC_SUBDIRS="man include"
@@ -5888,7 +5888,7 @@
@@ -5888,7 +5889,7 @@
case $cf_item in
@ -65,7 +132,7 @@ $NetBSD: patch-ab,v 1.5 1999/07/16 18:43:48 jlam Exp $
debug) cf_suffix='_g.a' ;;
profile) cf_suffix='_p.a' ;;
shared)
@@ -5931,7 +5931,7 @@
@@ -5931,7 +5932,7 @@
case $cf_item in
@ -74,7 +141,7 @@ $NetBSD: patch-ab,v 1.5 1999/07/16 18:43:48 jlam Exp $
debug) cf_suffix='_g.a' ;;
profile) cf_suffix='_p.a' ;;
shared)
@@ -6120,7 +6120,7 @@
@@ -6120,7 +6121,7 @@
for i in `cat $srcdir/$cf_dir/headers |fgrep -v "#"`
do
echo " @ (cd \$(INSTALL_PREFIX)\$(includedir) && rm -f `basename $i`) ; ../headers.sh \$(INSTALL_DATA) \$(INSTALL_PREFIX)\$(includedir) \$(srcdir) $i" >>$cf_dir/Makefile