lua-rocks: Force pkgsrc unzip.

Otherwise it complains:

Error: Failed unpacking rock file: /tmp/luarocks_luarocks-rock-digestif-0.3-1-B5qFAU/digestif-0.3-1.src.rock: 'unzip -n' program not found. Make sure unzip is installed and is available in your PATH (or you may want to edit the 'variables.UNZIP' value in file '/usr/pkg/etc/luarocks/config-5.4.lua')
This commit is contained in:
nia 2020-07-02 12:13:36 +00:00
parent 9df9631cf9
commit 29e1e86aa8
3 changed files with 20 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.11 2020/07/02 10:26:18 nia Exp $
# $NetBSD: Makefile,v 1.12 2020/07/02 12:13:36 nia Exp $
DISTNAME= luarocks-3.3.1
PKGNAME= ${DISTNAME:S/luarocks/${LUA_PKGPREFIX}-rocks/}
@ -19,6 +19,8 @@ MAKE_FILE= GNUmakefile
.include "../../mk/bsd.prefs.mk"
PREFER.unzip= pkgsrc
HAS_CONFIGURE= yes
USE_LANGUAGES= # none

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.6 2020/07/01 11:06:40 nia Exp $
$NetBSD: distinfo,v 1.7 2020/07/02 12:13:36 nia Exp $
SHA1 (luarocks-3.3.1.tar.gz) = b85a4afd890d172994f4ebc95fe647f71de7eeb4
RMD160 (luarocks-3.3.1.tar.gz) = 937a2d6d62474e3245927dc77fbe982b8ca4f2bb
SHA512 (luarocks-3.3.1.tar.gz) = 0a695ceb30ae575cbca52abd2aad9675e33a234c53c5d1e125442d874c21e0e3cf6157431f07085e4311f81833680366adfe5c626a66cb5880380b48899a116a
Size (luarocks-3.3.1.tar.gz) = 241636 bytes
SHA1 (patch-GNUmakefile) = 1f84ae6e926a57b07abcc65789d784c8e6a0fa75
SHA1 (patch-src_luarocks_core_cfg.lua) = 24c8c7e66fa12b2daf67924ac8ae0a2458380250

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_luarocks_core_cfg.lua,v 1.1 2020/07/02 12:13:36 nia Exp $
It seems to not like NetBSD unzip(1).
--- src/luarocks/core/cfg.lua.orig 2020-02-07 10:24:14.000000000 +0000
+++ src/luarocks/core/cfg.lua
@@ -253,7 +253,7 @@ local function make_defaults(lua_version
MKTEMP = "mktemp",
ZIP = "zip",
- UNZIP = "unzip -n",
+ UNZIP = "@PREFIX@/bin/unzip -n",
GUNZIP = "gunzip",
BUNZIP2 = "bunzip2",
TAR = "tar",