Work with system curses
This commit is contained in:
parent
5690b63c5a
commit
2a11bd3a01
4 changed files with 11 additions and 10 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.5 2012/10/06 11:54:30 asau Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2013/10/17 09:19:01 roy Exp $
|
||||
#
|
||||
|
||||
DISTNAME= bastet-0.41
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://fph.altervista.org/prog/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -24,5 +24,5 @@ do-install:
|
|||
${INSTALL_PROGRAM} ${WRKSRC}/bastet ${DESTDIR}${PREFIX}/bin/
|
||||
${INSTALL_MAN} ${WRKSRC}/bastet.6 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man6/
|
||||
|
||||
.include "../../devel/ncurses/buildlink3.mk"
|
||||
.include "../../mk/curses.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.3 2006/09/14 21:58:59 rillig Exp $
|
||||
$NetBSD: distinfo,v 1.4 2013/10/17 09:19:01 roy Exp $
|
||||
|
||||
SHA1 (bastet-0.41.tgz) = 644a0f76adedef84946159520c1639ff0c6c47ec
|
||||
RMD160 (bastet-0.41.tgz) = 00801881e8ee5d42f91fe5f231d3151606032851
|
||||
Size (bastet-0.41.tgz) = 24195 bytes
|
||||
SHA1 (patch-aa) = 249ef96a5324e46f439767226fcfc8c887094b85
|
||||
SHA1 (patch-aa) = 987f3ea4697eeebc0b955ee293586621c9f93d4d
|
||||
SHA1 (patch-ab) = ce2a671e0582fc227bac442186c9f8c1621db278
|
||||
SHA1 (patch-ac) = 899f9b4be7057fae6c8f7bcfb69b132142881c9b
|
||||
SHA1 (patch-ac) = 01c31c8506180300bec74fbf3627784e25e0809c
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-aa,v 1.2 2006/09/14 21:18:44 rillig Exp $
|
||||
$NetBSD: patch-aa,v 1.3 2013/10/17 09:19:01 roy Exp $
|
||||
|
||||
SunPro does not like non-static inline functions. BSD-based operating
|
||||
systems have <termios.h> instead of <termio.h>.
|
||||
|
@ -8,7 +8,8 @@ systems have <termios.h> instead of <termio.h>.
|
|||
@@ -1,7 +1,11 @@
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
#include <ncurses.h>
|
||||
-#include <ncurses.h>
|
||||
+#include <curses.h>
|
||||
+#if defined(__linux)
|
||||
#include <termio.h>
|
||||
+#else
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ac,v 1.2 2006/09/14 21:58:59 rillig Exp $
|
||||
$NetBSD: patch-ac,v 1.3 2013/10/17 09:19:01 roy Exp $
|
||||
|
||||
For one-time building, the dependencies are not needed.
|
||||
|
||||
|
@ -11,7 +11,7 @@ For one-time building, the dependencies are not needed.
|
|||
-CFLAGS=-Wall -DHIGHSCORE_FILE=\"$(DATA_PREFIX)$(HISCORE)\"
|
||||
-LDFLAGS=-lncurses
|
||||
+CFLAGS+=-Wall -DHIGHSCORE_FILE=\"$(DATA_PREFIX)$(HISCORE)\"
|
||||
+LDFLAGS+=-lncurses
|
||||
+LDFLAGS+=-lcurses
|
||||
SOURCES=main.c game.c highscore.c bast.c
|
||||
EXNAME=bastet
|
||||
|
||||
|
|
Loading…
Reference in a new issue