Updated py-twisted to 16.5.0.

Twisted Core 16.5.0 (2016-10-28)
================================

Features
--------
 - Added twisted.internet.defer.Deferred.addTimeout method to enable
   timeouts of deferreds. (#5786)
 - Perspective Broker (the twisted.spread package) has been ported to
   Python 3 (#7598)
 - 'yield from' can now be used on Deferreds inside generators, when
   the generator is wrapped with
   twisted.internet.defer.ensureDeferred. (#8087)
 - twisted.internet.asyncioreactor has been added, which is a Twisted
   reactor on top of Python 3.4+'s native asyncio reactor. It can be
   selected by passing "--reactor=asyncio" to Twisted tools (twistd,
   Trial, etc) on platforms that support it (Python 3.4+). (#8367)
 - twisted.python.zippath now works on Windows with Python 3. (#8747)
 - twisted.internet.cfreactor is ported to Python 3 and supported on
   2.7 and 3.5+. (#8838)

Bugfixes
--------
 - twisted.internet.test.test_iocp and twisted.internet.test.test_tcp
   have been fixed to work under Python 3 with the Windows IOCP
   reactor (#8631)
 - Arguments to processes on Windows are now passed mbcs-encoded
   arguments.  This prevents process-related tests from hanging on
   Windows with Python 3. (#8735)
 - Client and server TLS connections made via the client TLS endpoint
   and the server SSL endpoint, as well as any other code that uses
   twisted.internet.ssl.CertificateOptions, no longer accept 3DES-
   based cipher suites by default, to defend against SWEET32. (#8781)
 - twisted.logger.jsonFileLogObserver no longer emits non-JSON
   tracebacks into its file; additionally,
   twisted.logger.formatEventAsClassicLogText now includes traceback
   information for the log event it formats. (#8858)
 - twisted.python.version now exports a version of Incremental that is
   16.10.1 or higher, making t.p.v.Version package name comparisons
   case-insensitive. (#8863)
 - twisted.python.reflect.safe_str encodes unicode as ascii with
   backslashreplace error handling on Python 2. (#8864)

Improved Documentation
----------------------
 - The twisted.internet.interfaces.IProtocol.dataReceived() method
   takes one parameter of type bytes.  This has been clarified in the
   doc string. (#8763)

Deprecations and Removals
-------------------------
 - twisted.python.constants is deprecated in preference to constantly
   on PyPI, which is the same code rolled into its own package.
   (#7351)
 - twisted.python.dist3 has been made private API. (#8761)
 - When the source code is checked out, bin/trial is no longer in the
   tree.  Developers working on the Twisted source code itself should
   either (1) run all tests under tox, or (2) run 'python setup.py
   develop' to install trial before running any tests. (#8765)
 - twisted.protocols.gps, deprecated since Twisted 15.2, has been
   removed. (#8787)

Other
-----
 - #4926, #7868, #8209, #8214, #8271, #8308, #8324, #8348, #8367,
   #8377, #8378, #8379, #8380, #8381, #8383, #8385, #8387, #8388,
   #8389, #8391, #8392, #8393, #8394, #8397, #8406, #8410, #8412,
   #8413, #8414, #8421, #8425, #8426, #8430, #8432, #8434, #8435,
   #8437, #8438, #8439, #8444, #8451, #8452, #8453, #8454, #8456,
   #8457, #8459, #8462, #8463, #8465, #8468, #8469, #8479, #8482,
   #8483, #8486, #8490, #8493, #8494, #8496, #8497, #8498, #8499,
   #8501, #8503, #8504, #8507, #8508, #8510, #8513, #8514, #8515,
   #8516, #8517, #8520, #8521, #8522, #8523, #8524, #8527, #8528,
   #8529, #8531, #8532, #8534, #8536, #8537, #8538, #8543, #8544,
   #8548, #8552, #8553, #8554, #8555, #8557, #8560, #8563, #8565,
   #8568, #8569, #8572, #8573, #8574, #8580, #8581, #8582, #8586,
   #8589, #8590, #8592, #8593, #8598, #8603, #8604, #8606, #8609,
   #8615, #8616, #8617, #8618, #8619, #8621, #8622, #8624, #8627,
   #8628, #8630, #8632, #8634, #8640, #8644, #8645, #8646, #8647,
   #8662, #8664, #8666, #8668, #8671, #8672, #8677, #8678, #8684,
   #8691, #8702, #8705, #8706, #8716, #8719, #8724, #8725, #8727,
   #8734, #8741, #8749, #8752, #8754, #8755, #8756, #8757, #8758,
   #8767, #8773, #8776, #8779, #8780, #8785, #8788, #8789, #8790,
   #8792, #8793, #8799, #8808, #8817, #8839, #8845, #8852


Twisted Conch 16.5.0 (2016-10-28)
=================================

Features
--------
 - SSH key fingerprints can be generated using base64 encoded SHA256
   hashes. (#8701)

Bugfixes
--------
 - SSHUserAuthServer does not crash on keyboard interactive
   authentication when running on Python 3 (#8771)
 - twisted.conch.insults.insults.ServerProtocol no longer corrupts a
   client's display when attempting to set the cursor position, and
   its ECMA-48 terminal manipulation works on Python 3. (#8803)

Other
-----
 - #8495, #8511, #8715, #8851


Twisted Mail 16.5.0 (2016-10-28)
================================

Deprecations and Removals
-------------------------
 - twisted.mail.protocols.DomainSMTP and DomainESMTP, deprecated since
   2003, have been removed. (#8772)

Other
-----
 - #6289, #8525, #8786, #8830


Twisted Names 16.5.0 (2016-10-28)
=================================

No significant changes have been made for this release.

Other
-----
 - #8625, #8663


Twisted Pair 16.5.0 (2016-10-28)
================================

Features
--------
 - twisted.pair has been ported to Python 3 (#8744)


Twisted Web 16.5.0 (2016-10-28)
===============================

Bugfixes
--------
 - twisted.web.client.HTTPConnectionPool and anything that uses it,
   like twisted.web.client.Agent, have had their logic for resuming
   transports changed so that transports are resumed after state
   machine transitions are complete, rather than before. This change
   allows the HTTP client infrastructure to work with alternative HTTP
   implementations such as HTTP/2 which may be able to deliver a
   complete response synchronously when producing is resumed. (#8720)

Other
-----
 - #8519, #8530, #8629, #8707, #8777, #8778, #8844


Twisted Words 16.5.0 (2016-10-28)
=================================

No significant changes have been made for this release.

Other
-----
 - #8360, #8460
This commit is contained in:
wiz 2016-11-01 15:55:46 +00:00
parent be8f92cbd9
commit 2a2a2256bd
5 changed files with 54 additions and 57 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.26 2016/09/18 22:21:26 wiz Exp $
# $NetBSD: Makefile,v 1.27 2016/11/01 15:55:46 wiz Exp $
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
COMMENT= Framework for writing networked applications
@ -7,10 +7,9 @@ COMMENT= Framework for writing networked applications
DEPENDS+= ${PYPKGPREFIX}-OpenSSL>=0.6:../../security/py-OpenSSL
DEPENDS+= ${PYPKGPREFIX}-ZopeInterface>=3.0.1:../../devel/py-ZopeInterface
REPLACE_PYTHON+= twisted/mail/test/pop3testserver.py
REPLACE_PYTHON+= twisted/trial/test/scripttest.py
REPLACE_PYTHON+= twisted/topfiles/setup.py
REPLACE_PYTHON+= twisted/python/test/pullpipe.py
REPLACE_PYTHON+= src/twisted/mail/test/pop3testserver.py
REPLACE_PYTHON+= src/twisted/trial/test/scripttest.py
REPLACE_PYTHON+= src/twisted/python/test/pullpipe.py
CFLAGS.SunOS+= -D_XOPEN_SOURCE=1 -D_XOPEN_SOURCE_EXTENDED=1 -Du_int=uint32_t

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile.common,v 1.33 2016/09/20 14:45:56 wiz Exp $
# $NetBSD: Makefile.common,v 1.34 2016/11/01 15:55:46 wiz Exp $
#
# used by net/py-twisted/Makefile
# used by net/py-twisted-docs/Makefile
DISTNAME= Twisted-16.4.1
DISTNAME= Twisted-16.5.0
CATEGORIES= net python
MASTER_SITES= http://twistedmatrix.com/Releases/Twisted/${PKGVERSION_NOREV:R}/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.24 2016/08/31 09:10:02 wiz Exp $
@comment $NetBSD: PLIST,v 1.25 2016/11/01 15:55:46 wiz Exp $
bin/cftp-${PYVERSSUFFIX}
bin/ckeygen-${PYVERSSUFFIX}
bin/conch-${PYVERSSUFFIX}
@ -474,9 +474,6 @@ ${PYSITELIB}/twisted/internet/_posixstdio.pyo
${PYSITELIB}/twisted/internet/_signals.py
${PYSITELIB}/twisted/internet/_signals.pyc
${PYSITELIB}/twisted/internet/_signals.pyo
${PYSITELIB}/twisted/internet/_ssl.py
${PYSITELIB}/twisted/internet/_ssl.pyc
${PYSITELIB}/twisted/internet/_ssl.pyo
${PYSITELIB}/twisted/internet/_sslverify.py
${PYSITELIB}/twisted/internet/_sslverify.pyc
${PYSITELIB}/twisted/internet/_sslverify.pyo
@ -495,6 +492,9 @@ ${PYSITELIB}/twisted/internet/abstract.pyo
${PYSITELIB}/twisted/internet/address.py
${PYSITELIB}/twisted/internet/address.pyc
${PYSITELIB}/twisted/internet/address.pyo
${PYSITELIB}/twisted/internet/asyncioreactor.py
${PYSITELIB}/twisted/internet/asyncioreactor.pyc
${PYSITELIB}/twisted/internet/asyncioreactor.pyo
${PYSITELIB}/twisted/internet/base.py
${PYSITELIB}/twisted/internet/base.pyc
${PYSITELIB}/twisted/internet/base.pyo
@ -623,6 +623,7 @@ ${PYSITELIB}/twisted/internet/test/_posixifaces.pyo
${PYSITELIB}/twisted/internet/test/_win32ifaces.py
${PYSITELIB}/twisted/internet/test/_win32ifaces.pyc
${PYSITELIB}/twisted/internet/test/_win32ifaces.pyo
${PYSITELIB}/twisted/internet/test/_yieldfromtests.py.3only
${PYSITELIB}/twisted/internet/test/connectionmixins.py
${PYSITELIB}/twisted/internet/test/connectionmixins.pyc
${PYSITELIB}/twisted/internet/test/connectionmixins.pyo
@ -658,9 +659,6 @@ ${PYSITELIB}/twisted/internet/test/test_abstract.pyo
${PYSITELIB}/twisted/internet/test/test_address.py
${PYSITELIB}/twisted/internet/test/test_address.pyc
${PYSITELIB}/twisted/internet/test/test_address.pyo
${PYSITELIB}/twisted/internet/test/test_await.py
${PYSITELIB}/twisted/internet/test/test_await.pyc
${PYSITELIB}/twisted/internet/test/test_await.pyo
${PYSITELIB}/twisted/internet/test/test_base.py
${PYSITELIB}/twisted/internet/test/test_base.pyc
${PYSITELIB}/twisted/internet/test/test_base.pyo
@ -670,6 +668,9 @@ ${PYSITELIB}/twisted/internet/test/test_baseprocess.pyo
${PYSITELIB}/twisted/internet/test/test_core.py
${PYSITELIB}/twisted/internet/test/test_core.pyc
${PYSITELIB}/twisted/internet/test/test_core.pyo
${PYSITELIB}/twisted/internet/test/test_coroutines.py
${PYSITELIB}/twisted/internet/test/test_coroutines.pyc
${PYSITELIB}/twisted/internet/test/test_coroutines.pyo
${PYSITELIB}/twisted/internet/test/test_default.py
${PYSITELIB}/twisted/internet/test/test_default.pyc
${PYSITELIB}/twisted/internet/test/test_default.pyo
@ -877,6 +878,12 @@ ${PYSITELIB}/twisted/logger/test/test_util.pyo
${PYSITELIB}/twisted/mail/__init__.py
${PYSITELIB}/twisted/mail/__init__.pyc
${PYSITELIB}/twisted/mail/__init__.pyo
${PYSITELIB}/twisted/mail/_cred.py
${PYSITELIB}/twisted/mail/_cred.pyc
${PYSITELIB}/twisted/mail/_cred.pyo
${PYSITELIB}/twisted/mail/_except.py
${PYSITELIB}/twisted/mail/_except.pyc
${PYSITELIB}/twisted/mail/_except.pyo
${PYSITELIB}/twisted/mail/alias.py
${PYSITELIB}/twisted/mail/alias.pyc
${PYSITELIB}/twisted/mail/alias.pyo
@ -886,6 +893,9 @@ ${PYSITELIB}/twisted/mail/bounce.pyo
${PYSITELIB}/twisted/mail/imap4.py
${PYSITELIB}/twisted/mail/imap4.pyc
${PYSITELIB}/twisted/mail/imap4.pyo
${PYSITELIB}/twisted/mail/interfaces.py
${PYSITELIB}/twisted/mail/interfaces.pyc
${PYSITELIB}/twisted/mail/interfaces.pyo
${PYSITELIB}/twisted/mail/mail.py
${PYSITELIB}/twisted/mail/mail.pyc
${PYSITELIB}/twisted/mail/mail.pyo
@ -1245,15 +1255,6 @@ ${PYSITELIB}/twisted/protocols/finger.pyo
${PYSITELIB}/twisted/protocols/ftp.py
${PYSITELIB}/twisted/protocols/ftp.pyc
${PYSITELIB}/twisted/protocols/ftp.pyo
${PYSITELIB}/twisted/protocols/gps/__init__.py
${PYSITELIB}/twisted/protocols/gps/__init__.pyc
${PYSITELIB}/twisted/protocols/gps/__init__.pyo
${PYSITELIB}/twisted/protocols/gps/nmea.py
${PYSITELIB}/twisted/protocols/gps/nmea.pyc
${PYSITELIB}/twisted/protocols/gps/nmea.pyo
${PYSITELIB}/twisted/protocols/gps/rockwell.py
${PYSITELIB}/twisted/protocols/gps/rockwell.pyc
${PYSITELIB}/twisted/protocols/gps/rockwell.pyo
${PYSITELIB}/twisted/protocols/haproxy/__init__.py
${PYSITELIB}/twisted/protocols/haproxy/__init__.pyc
${PYSITELIB}/twisted/protocols/haproxy/__init__.pyo
@ -1376,6 +1377,9 @@ ${PYSITELIB}/twisted/python/_release.pyc
${PYSITELIB}/twisted/python/_release.pyo
${PYSITELIB}/twisted/python/_sendmsg.c
${PYSITELIB}/twisted/python/_sendmsg.so
${PYSITELIB}/twisted/python/_setup.py
${PYSITELIB}/twisted/python/_setup.pyc
${PYSITELIB}/twisted/python/_setup.pyo
${PYSITELIB}/twisted/python/_shellcomp.py
${PYSITELIB}/twisted/python/_shellcomp.pyc
${PYSITELIB}/twisted/python/_shellcomp.pyo
@ -1403,12 +1407,6 @@ ${PYSITELIB}/twisted/python/context.pyo
${PYSITELIB}/twisted/python/deprecate.py
${PYSITELIB}/twisted/python/deprecate.pyc
${PYSITELIB}/twisted/python/deprecate.pyo
${PYSITELIB}/twisted/python/dist.py
${PYSITELIB}/twisted/python/dist.pyc
${PYSITELIB}/twisted/python/dist.pyo
${PYSITELIB}/twisted/python/dist3.py
${PYSITELIB}/twisted/python/dist3.pyc
${PYSITELIB}/twisted/python/dist3.pyo
${PYSITELIB}/twisted/python/failure.py
${PYSITELIB}/twisted/python/failure.pyc
${PYSITELIB}/twisted/python/failure.pyo
@ -1505,9 +1503,6 @@ ${PYSITELIB}/twisted/python/test/test_constants.pyo
${PYSITELIB}/twisted/python/test/test_deprecate.py
${PYSITELIB}/twisted/python/test/test_deprecate.pyc
${PYSITELIB}/twisted/python/test/test_deprecate.pyo
${PYSITELIB}/twisted/python/test/test_dist.py
${PYSITELIB}/twisted/python/test/test_dist.pyc
${PYSITELIB}/twisted/python/test/test_dist.pyo
${PYSITELIB}/twisted/python/test/test_dist3.py
${PYSITELIB}/twisted/python/test/test_dist3.pyc
${PYSITELIB}/twisted/python/test/test_dist3.pyo
@ -1532,6 +1527,9 @@ ${PYSITELIB}/twisted/python/test/test_runtime.pyo
${PYSITELIB}/twisted/python/test/test_sendmsg.py
${PYSITELIB}/twisted/python/test/test_sendmsg.pyc
${PYSITELIB}/twisted/python/test/test_sendmsg.pyo
${PYSITELIB}/twisted/python/test/test_setup.py
${PYSITELIB}/twisted/python/test/test_setup.pyc
${PYSITELIB}/twisted/python/test/test_setup.pyo
${PYSITELIB}/twisted/python/test/test_shellcomp.py
${PYSITELIB}/twisted/python/test/test_shellcomp.pyc
${PYSITELIB}/twisted/python/test/test_shellcomp.pyo
@ -1682,6 +1680,21 @@ ${PYSITELIB}/twisted/spread/pb.pyo
${PYSITELIB}/twisted/spread/publish.py
${PYSITELIB}/twisted/spread/publish.pyc
${PYSITELIB}/twisted/spread/publish.pyo
${PYSITELIB}/twisted/spread/test/__init__.py
${PYSITELIB}/twisted/spread/test/__init__.pyc
${PYSITELIB}/twisted/spread/test/__init__.pyo
${PYSITELIB}/twisted/spread/test/test_banana.py
${PYSITELIB}/twisted/spread/test/test_banana.pyc
${PYSITELIB}/twisted/spread/test/test_banana.pyo
${PYSITELIB}/twisted/spread/test/test_jelly.py
${PYSITELIB}/twisted/spread/test/test_jelly.pyc
${PYSITELIB}/twisted/spread/test/test_jelly.pyo
${PYSITELIB}/twisted/spread/test/test_pb.py
${PYSITELIB}/twisted/spread/test/test_pb.pyc
${PYSITELIB}/twisted/spread/test/test_pb.pyo
${PYSITELIB}/twisted/spread/test/test_pbfailure.py
${PYSITELIB}/twisted/spread/test/test_pbfailure.pyc
${PYSITELIB}/twisted/spread/test/test_pbfailure.pyo
${PYSITELIB}/twisted/spread/util.py
${PYSITELIB}/twisted/spread/util.pyc
${PYSITELIB}/twisted/spread/util.pyo
@ -1815,9 +1828,6 @@ ${PYSITELIB}/twisted/test/test_amp.pyo
${PYSITELIB}/twisted/test/test_application.py
${PYSITELIB}/twisted/test/test_application.pyc
${PYSITELIB}/twisted/test/test_application.pyo
${PYSITELIB}/twisted/test/test_banana.py
${PYSITELIB}/twisted/test/test_banana.pyc
${PYSITELIB}/twisted/test/test_banana.pyo
${PYSITELIB}/twisted/test/test_compat.py
${PYSITELIB}/twisted/test/test_compat.pyc
${PYSITELIB}/twisted/test/test_compat.pyo
@ -1881,9 +1891,6 @@ ${PYSITELIB}/twisted/test/test_iosim.pyo
${PYSITELIB}/twisted/test/test_iutils.py
${PYSITELIB}/twisted/test/test_iutils.pyc
${PYSITELIB}/twisted/test/test_iutils.pyo
${PYSITELIB}/twisted/test/test_jelly.py
${PYSITELIB}/twisted/test/test_jelly.pyc
${PYSITELIB}/twisted/test/test_jelly.pyo
${PYSITELIB}/twisted/test/test_lockfile.py
${PYSITELIB}/twisted/test/test_lockfile.pyc
${PYSITELIB}/twisted/test/test_lockfile.pyo
@ -1905,21 +1912,12 @@ ${PYSITELIB}/twisted/test/test_modules.pyo
${PYSITELIB}/twisted/test/test_monkey.py
${PYSITELIB}/twisted/test/test_monkey.pyc
${PYSITELIB}/twisted/test/test_monkey.pyo
${PYSITELIB}/twisted/test/test_nmea.py
${PYSITELIB}/twisted/test/test_nmea.pyc
${PYSITELIB}/twisted/test/test_nmea.pyo
${PYSITELIB}/twisted/test/test_nooldstyle.py
${PYSITELIB}/twisted/test/test_nooldstyle.pyc
${PYSITELIB}/twisted/test/test_nooldstyle.pyo
${PYSITELIB}/twisted/test/test_paths.py
${PYSITELIB}/twisted/test/test_paths.pyc
${PYSITELIB}/twisted/test/test_paths.pyo
${PYSITELIB}/twisted/test/test_pb.py
${PYSITELIB}/twisted/test/test_pb.pyc
${PYSITELIB}/twisted/test/test_pb.pyo
${PYSITELIB}/twisted/test/test_pbfailure.py
${PYSITELIB}/twisted/test/test_pbfailure.pyc
${PYSITELIB}/twisted/test/test_pbfailure.pyo
${PYSITELIB}/twisted/test/test_pcp.py
${PYSITELIB}/twisted/test/test_pcp.pyc
${PYSITELIB}/twisted/test/test_pcp.pyo

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.29 2016/09/18 22:21:26 wiz Exp $
$NetBSD: distinfo,v 1.30 2016/11/01 15:55:46 wiz Exp $
SHA1 (Twisted-16.4.1.tar.bz2) = 1f6797971677efbcee1314520583082e8d52b437
RMD160 (Twisted-16.4.1.tar.bz2) = 58ef16349fbf5d7a789eeccc67bbf718b200648e
SHA512 (Twisted-16.4.1.tar.bz2) = 7d841f5ef7fbcc5c215e5fb0d56934c6b37ecb0835a9e602a2b788a76960c669eb910a58c1f40f3e15121a7852a1055d377891c7ce3f2e360292a41341ab6bfe
Size (Twisted-16.4.1.tar.bz2) = 2975697 bytes
SHA1 (patch-ab) = 26495e5abd57025e915b923cc7089704bbd85629
SHA1 (Twisted-16.5.0.tar.bz2) = fae668e042fccdcabc76c145698d888fcecd0eca
RMD160 (Twisted-16.5.0.tar.bz2) = cd033fc84f91c4e8f46035e82a5723c650d3db46
SHA512 (Twisted-16.5.0.tar.bz2) = 4d137df8e48eb7d75f1c8f45929b9f7a3974db101bccb1ad8fecd05350d4a7e7caa0ddfad706d1c3d404d8de85317a521bd46b4294391930324d1291d40e6fe7
Size (Twisted-16.5.0.tar.bz2) = 2970708 bytes
SHA1 (patch-src_twisted_runner_portmap.c) = b3bd85bfa067bdb7050e83eeff53da83b3e6b998

View file

@ -1,11 +1,11 @@
$NetBSD: patch-ab,v 1.1 2005/03/16 12:02:20 rillig Exp $
$NetBSD: patch-src_twisted_runner_portmap.c,v 1.1 2016/11/01 15:55:46 wiz Exp $
Let's be polite and let the system first include its headers before
Python redefines everything.
--- twisted/runner/portmap.c.orig Thu Dec 5 08:59:31 2002
+++ twisted/runner/portmap.c Wed Mar 16 03:41:57 2005
@@ -19,9 +19,9 @@
--- src/twisted/runner/portmap.c.orig 2016-10-26 02:57:22.000000000 +0000
+++ src/twisted/runner/portmap.c
@@ -7,9 +7,9 @@
/* portmap.c: A simple Python wrapper for pmap_set(3) and pmap_unset(3) */